Skip to content

Latest commit

 

History

History
86 lines (67 loc) · 2.49 KB

1565.md

File metadata and controls

86 lines (67 loc) · 2.49 KB

斜二进制数 1565: Skew Binary

题目要求将斜二进制数转换为十进制输出。

题目来源

1565: Skew Binary

总时间限制: 1000ms 内存限制: 65536kB

描述

When a number is expressed in decimal, the kth digit represents a multiple of 10 k. (Digits are numbered from right to left, where the least significant digit is number 0.) For example, 81307(10) = 8 * 10^4 + 1 * 10 ^3 + 3 * 10^2 + 0 * 10^1 + 7 * 10^0 = 80000 + 1000 + 300 + 0 + 7 = 81307.

When a number is expressed in binary, the kth digit represents a multiple of 2^k . For example,

10011(2) = 1 * 2^4 + 0 * 2^3 + 0 * 2^2 + 1 * 2^1 + 1 * 2^0 = 16 + 0 + 0 + 2 + 1 = 19.

In skew binary, the kth digit represents a multiple of 2^(k+1)-1. The only possible digits are 0 and 1, except that the least-significant nonzero digit can be a 2. For example,

10120(skew) = 1 * (2^5-1) + 0 * (2^4-1) + 1 * (2^3-1) + 2 * (2^2-1) + 0 * (2^1-1) = 31 + 0 + 7 + 6 + 0 = 44.

The first 10 numbers in skew binary are 0, 1, 2, 10, 11, 12, 20, 100, 101, and 102. (Skew binary is useful in some applications because it is possible to add 1 with at most one carry. However, this has nothing to do with the current problem.)

输入

The input contains one or more lines, each of which contains an integer n. If n = 0 it signals the end of the input, and otherwise n is a nonnegative integer in skew binary.

输出

For each number, output the decimal equivalent. The decimal value of n will be at most 2^31-1 = 2147483647.

样例输入

10120
200000000000000000000000000000
10
1000000000000000000000000000000
11
100
11111000001110000101101102000
0

样例输出

44
2147483646
3
2147483647
4
7
1041110737

可以从低位开始转换,累加即可。

#include <iostream>
#include <string>
using namespace std;
int main() {
	string str;
	int i;
	while (cin >> str && str != "0") {
		long sum = 0, bin = 1;
		for (i = str.length() - 1; i >= 0; --i) {
			bin <<= 1;
			sum += (str[i] - '0') * (bin - 1);
		}
		cout << sum << endl;
	}
	return 0;
}

1565.cpp 代码长度:293B 内存:136kB 时间:3ms 通过率:96% 最小内存:136kB 最短时间:0ms

由于数的范围不超过32位,因此可以用long型来存储,但斜二进制数可能比较长,我们用string来存储,然后从低位遍历累加即可。

类似题目: 2973

有任何的改进意见欢迎大家在微信平台公众号主页面留言或者发表issue。