Skip to content

Latest commit

 

History

History
88 lines (71 loc) · 2.56 KB

2915.md

File metadata and controls

88 lines (71 loc) · 2.56 KB

字符串排序 2915: 字符串排序

题目要求将输入的多个字符串按照长短排序,对于字符串为stop的情况特殊处理。

题目来源

2915: 字符串排序

总时间限制: 1000ms 内存限制: 65536kB

描述

先输入你要输入的字符串的个数。然后换行输入该组字符串。每个字符串以回车结束,每个字符串少于一百个字符。如果在输入过程中输入的一个字符串为“stop”,也结束输入。

然后将这输入的该组字符串按每个字符串的长度,由小到大排序,按排序结果输出字符串。

根据输入的字符串个数来动态分配存储空间(采用new()函数)。每个字符串会少于100个字符。

测试数据有多组,注意使用while()循环输入。

输入

字符串的个数,以及该组字符串。每个字符串以‘\n’结束。如果输入字符串为“stop”,也结束输入.

输出

将输入的所有字符串按长度由小到大排序输出(如果有“stop”,不输出“stop”)。

样例输入

5
sky is grey
cold
very cold
stop
3
it is good enough to be proud of
good
it is quite good

样例输出

cold
very cold
sky is grey
good
it is quite good
it is good enough to be proud of

通过循环不断输入字符串,并检测是否为stop,之后将不包括stop的所有字符串按长度排序输出即可。

#include <iostream>
#include <vector>
#include <string>
#include <algorithm>
using namespace std;
bool compare(string s1, string s2) {
	return s1.length() < s2.length();
}
int main() {
	int n, i;
	while (cin >> n) {
		cin.ignore();
		vector<string> vs;
		char cstr[101];
		for (i = 0; i < n; ++i) {
			cin.getline(cstr, 101);
			string str(cstr);
			if (str == "stop") {
				break;
			}
			vs.push_back(str);
		}
		sort(vs.begin(), vs.end(), compare);
		for (i = 0; i < vs.size(); ++i) {
			cout << vs[i] << endl;
		}
	}
	return 0;
}

2915.cpp 代码长度:534B 内存:144kB 时间:1ms 通过率:92% 最小内存:144kB 最短时间:0ms

对于包含空格的字符串输入需要使用cin.getline,另外区分是否为stop,所以可以采用string类型存储方便处理。

对于按字符串长度排序,可以重新给出一个比较函数compare作为标准库sort的函数参数。比较函数的返回值应为bool型,参数为待排序的两个数据实例,函数体返回比较的结果。

有任何的改进意见欢迎大家在微信平台公众号主页面留言或者发表issue。