Skip to content

Commit

Permalink
textproc/sd: update to 1.0.0
Browse files Browse the repository at this point in the history
[1.0.0] - 2023-11-07

A quick note to any packages. The generated shell completions and man page are
now in the gen directory of the repo. They're also included in the pre-built
release artifacts on the releases page.

Improvements
 #115 Do not replace symlink with output file (@SimplyDanny)
      Fixes an issue where a symlink would be replaced with a regular file
 #124 Fix tests (@Linus789)
      Removed displaying the file path when passing the --preview flag and fixed how text coloring was handled in tests

Breaking
 #192 Rename --string-mode to --fixed-strings (@CosmicHorrorDev)
      Renamed -s --string-mode to -f --fixed-strings to better match similar
      tools
      -s and --string-mode will still continue to work for backwards
      compatibility, but are no longer documented
 #258 Error on $<num><non_num> capture replacement names (@CosmicHorrorDev)
      Previously when you tried to use a numbered capture group right before
      some letters in the replacement text (e.g. $1foo) then it would be
      considered the impossible-to-use 1foo capture. The correct way to pass
      the numbered capture group in this case would be to surround the number
      with curly braces like so ${1}foo. The error just detects this case and
      informs the user of the issue

Docs
 #93 Add note about in-place file modification to --help output (@jchook)
 #148 Doc: nitpick -- has no special meaning to shells (@hexagonrecursion)
 #181 Fix man page -f flag help text (@ulope)
      Fixed copy-pasted text in the man page's -f flag's help text
 #186 Improve error message for failed replacements (@CosmicHorrorDev)
 #187 Freshen up README (@CosmicHorrorDev)
      Added a repology badge to document different installation methods
      Improved the formatting of the benchmarks
 #207 Documenting $ escape (@yahkbar)
      Adds a section in the README that covers that $$ is a literal $ in the
      replacement text
 #227 Improve README readability (@vassudanagunta)
      Various formatting improvements
 #231 Use clap_mangen and roff to generate manpage (@nc7s)
      This change ensures the man page contents stay in sync with the CLI
      automatically, and fixes some broken rendering of the existing manpage
 #243 Exclude unsupported packages from the repology badge (@CosmicHorrorDev)

Pre-built Releases
 (11295fb) Add ARM target (@chmln)
           Added the arm-unknown-linux-gnueabihf target to CI and releases
 #114 Adding aarch64-apple-darwin target (@yahkbar)
 #143 Fix paths to release binary in "publish" action (@skrattaren)
 #179 Build Adjustments (@yahkbar)
      striped release binaries and added the aarch64-ubuntu-linux-musl target
 #204 Adding armv7-unknown-linux-gnueabihf target (@yahkbar)
      Added the armv7-unknown-linux-gnueabihf target to the list of targets to
      build in CI and for each release
 #205 Resolving broken aarch64-apple-darwin tests (@yahkbar)
      Switched aarch64-apple-darwin to only try building the executable without
      running the tests since there seems to be no easy way to test for ARM
      Apple targets
 #206 Adding Windows builds back (@yahkbar)
      Added the x86_64-pc-windows-gnu and x86_64-windows-musl targets back to
      the list of targets to build in CI and for each release

Internal
 #118 Fix master (@SimplyDanny)
      Fixes several cross-compilation issues that effected different targets
      in CI
 #182 cargo update (@CosmicHorrorDev)
      Bumps dependencies to their latest compatible versions
 #183 Switch memmap -> memmap2 (@CosmicHorrorDev)
      Switches away from an unmaintained crate
 #184 Add editor config file matching rustfmt config (@CosmicHorrorDev)
      Adds an .editorconfig file matching the settings listed in the
      .rustfmt.toml file
 #185 Fix warnings and clippy lints (@CosmicHorrorDev)
 #188 Switch atty for is-terminal (@CosmicHorrorDev)
      Switches away from an unmaintained crate
 #189 Replace structopt with clap v4 (@CosmicHorrorDev)
      Switches away from a defacto deprecated crate
 #190 Change how all shell variants are expressed (@CosmicHorrorDev)
      Tiny tidying up PR
 #196 Move generating static assets to a cargo-xtask task (@CosmicHorrorDev)
      Moves the generation of the man page and shell completions from a build
      script to a cargo-xtask task
 #197 Add a release checklist (@CosmicHorrorDev)
 #209 Dependency updates (@yahkbar)
 #235 Update generated assets (@CosmicHorrorDev)
 #236 Tone down dependabot (@CosmicHorrorDev)
 #245 Update sd to 2021 edition (@CosmicHorrorDev)
      Updates sd to the Rust 2021 edition
 #248 Misc Cargo.toml tweaks (@CosmicHorrorDev)
      Switches to use workspace edition and dependencies where appropriate
 #249 Resolve CI warnings (@CosmicHorrorDev)
      Switched from actions-rs actions to dtolnay@rust-toolchain
      Switched from using ::set-output to $GITHUB_ENV
 #251 Update dependencies (@CosmicHorrorDev)
 A lot of sad CI tweaking:
      #252 Fix build target usage in CI (@CosmicHorrorDev)
      #253 Improve publishing CI job (@CosmicHorrorDev)
      #256 More CI tweaks (@CosmicHorrorDev)
      #257 Fix publish action (@CosmicHorrorDev)
 #267 Rework the replacements flag (@CosmicHorrorDev)
 #269 Make modified text blue instead of green (@CosmicHorrorDev)
 #271 Fix release checklist indentation (@CosmicHorrorDev)
 #272 Remove outdated release checklist step (@CosmicHorrorDev)
 #274 Prepare 1.0.0-beta.0 release (@CosmicHorrorDev)
 #275 Update sd version in lockfile (@CosmicHorrorDev)
  • Loading branch information
0323pin committed Nov 8, 2023
1 parent 11a32d7 commit 09f7324
Show file tree
Hide file tree
Showing 3 changed files with 436 additions and 263 deletions.
13 changes: 7 additions & 6 deletions textproc/sd/Makefile
Original file line number Diff line number Diff line change
@@ -1,21 +1,22 @@
# $NetBSD: Makefile,v 1.5 2022/02/25 09:15:24 pin Exp $
# $NetBSD: Makefile,v 1.6 2023/11/08 06:56:54 pin Exp $

DISTNAME= sd-0.7.6
DISTNAME= sd-1.0.0
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GITHUB:=chmln/}
GITHUB_TAG= v${PKGVERSION_NOREV}

MAINTAINER= pkgsrc-users@NetBSD.org
MAINTAINER= pin@NetBSD.org
HOMEPAGE= https://github.com/chmln/sd/
COMMENT= Intuitive find and replace CLI
LICENSE= mit

.include "cargo-depends.mk"

INSTALLATION_DIRS= bin
INSTALLATION_DIRS= ${PKGMANDIR}/man1

do-install:
${INSTALL_PROGRAM} ${WRKSRC}/target/release/sd ${DESTDIR}${PREFIX}/bin
post-install:
${INSTALL_MAN} ${WRKSRC}/gen/sd.1 \
${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/sd.1

.include "../../lang/rust/cargo.mk"
.include "../../mk/bsd.pkg.mk"
171 changes: 107 additions & 64 deletions textproc/sd/cargo-depends.mk
Original file line number Diff line number Diff line change
@@ -1,71 +1,114 @@
# $NetBSD: cargo-depends.mk,v 1.1 2021/01/31 15:57:00 pin Exp $
# $NetBSD: cargo-depends.mk,v 1.2 2023/11/08 06:56:54 pin Exp $

CARGO_CRATE_DEPENDS+= aho-corasick-0.7.10
CARGO_CRATE_DEPENDS+= ansi_term-0.11.0
CARGO_CRATE_DEPENDS+= anyhow-1.0.32
CARGO_CRATE_DEPENDS+= assert_cmd-1.0.1
CARGO_CRATE_DEPENDS+= atty-0.2.14
CARGO_CRATE_DEPENDS+= autocfg-1.0.0
CARGO_CRATE_DEPENDS+= bitflags-1.2.1
CARGO_CRATE_DEPENDS+= cfg-if-0.1.10
CARGO_CRATE_DEPENDS+= clap-2.33.0
CARGO_CRATE_DEPENDS+= crossbeam-deque-0.7.3
CARGO_CRATE_DEPENDS+= crossbeam-epoch-0.8.2
CARGO_CRATE_DEPENDS+= crossbeam-queue-0.2.1
CARGO_CRATE_DEPENDS+= crossbeam-utils-0.7.2
CARGO_CRATE_DEPENDS+= difference-2.0.0
CARGO_CRATE_DEPENDS+= aho-corasick-1.1.2
CARGO_CRATE_DEPENDS+= ansi-to-html-0.1.3
CARGO_CRATE_DEPENDS+= ansi_term-0.12.1
CARGO_CRATE_DEPENDS+= anstream-0.6.4
CARGO_CRATE_DEPENDS+= anstyle-1.0.4
CARGO_CRATE_DEPENDS+= anstyle-parse-0.2.2
CARGO_CRATE_DEPENDS+= anstyle-query-1.0.0
CARGO_CRATE_DEPENDS+= anstyle-wincon-3.0.1
CARGO_CRATE_DEPENDS+= anyhow-1.0.75
CARGO_CRATE_DEPENDS+= assert_cmd-2.0.12
CARGO_CRATE_DEPENDS+= autocfg-1.1.0
CARGO_CRATE_DEPENDS+= bit-set-0.5.3
CARGO_CRATE_DEPENDS+= bit-vec-0.6.3
CARGO_CRATE_DEPENDS+= bitflags-1.3.2
CARGO_CRATE_DEPENDS+= bitflags-2.4.1
CARGO_CRATE_DEPENDS+= bstr-1.7.0
CARGO_CRATE_DEPENDS+= cfg-if-1.0.0
CARGO_CRATE_DEPENDS+= clap-4.4.6
CARGO_CRATE_DEPENDS+= clap_builder-4.4.6
CARGO_CRATE_DEPENDS+= clap_complete-4.4.3
CARGO_CRATE_DEPENDS+= clap_derive-4.4.2
CARGO_CRATE_DEPENDS+= clap_lex-0.5.1
CARGO_CRATE_DEPENDS+= clap_mangen-0.2.14
CARGO_CRATE_DEPENDS+= colorchoice-1.0.0
CARGO_CRATE_DEPENDS+= console-0.15.7
CARGO_CRATE_DEPENDS+= crossbeam-deque-0.8.3
CARGO_CRATE_DEPENDS+= crossbeam-epoch-0.9.15
CARGO_CRATE_DEPENDS+= crossbeam-utils-0.8.16
CARGO_CRATE_DEPENDS+= difflib-0.4.0
CARGO_CRATE_DEPENDS+= doc-comment-0.3.3
CARGO_CRATE_DEPENDS+= either-1.5.3
CARGO_CRATE_DEPENDS+= getrandom-0.1.14
CARGO_CRATE_DEPENDS+= heck-0.3.1
CARGO_CRATE_DEPENDS+= hermit-abi-0.1.11
CARGO_CRATE_DEPENDS+= either-1.9.0
CARGO_CRATE_DEPENDS+= encode_unicode-0.3.6
CARGO_CRATE_DEPENDS+= errno-0.3.5
CARGO_CRATE_DEPENDS+= fastrand-2.0.1
CARGO_CRATE_DEPENDS+= fnv-1.0.7
CARGO_CRATE_DEPENDS+= getrandom-0.2.10
CARGO_CRATE_DEPENDS+= heck-0.4.1
CARGO_CRATE_DEPENDS+= hermit-abi-0.3.3
CARGO_CRATE_DEPENDS+= insta-1.34.0
CARGO_CRATE_DEPENDS+= is-terminal-0.4.9
CARGO_CRATE_DEPENDS+= itertools-0.11.0
CARGO_CRATE_DEPENDS+= lazy_static-1.4.0
CARGO_CRATE_DEPENDS+= libc-0.2.69
CARGO_CRATE_DEPENDS+= man-0.3.0
CARGO_CRATE_DEPENDS+= maybe-uninit-2.0.0
CARGO_CRATE_DEPENDS+= memchr-2.3.3
CARGO_CRATE_DEPENDS+= memmap-0.7.0
CARGO_CRATE_DEPENDS+= memoffset-0.5.4
CARGO_CRATE_DEPENDS+= num_cpus-1.13.0
CARGO_CRATE_DEPENDS+= ppv-lite86-0.2.6
CARGO_CRATE_DEPENDS+= predicates-1.0.4
CARGO_CRATE_DEPENDS+= predicates-core-1.0.0
CARGO_CRATE_DEPENDS+= predicates-tree-1.0.0
CARGO_CRATE_DEPENDS+= proc-macro-error-1.0.2
CARGO_CRATE_DEPENDS+= proc-macro-error-attr-1.0.2
CARGO_CRATE_DEPENDS+= proc-macro2-1.0.10
CARGO_CRATE_DEPENDS+= quote-1.0.3
CARGO_CRATE_DEPENDS+= rand-0.7.3
CARGO_CRATE_DEPENDS+= rand_chacha-0.2.2
CARGO_CRATE_DEPENDS+= rand_core-0.5.1
CARGO_CRATE_DEPENDS+= rand_hc-0.2.0
CARGO_CRATE_DEPENDS+= rayon-1.3.1
CARGO_CRATE_DEPENDS+= rayon-core-1.7.1
CARGO_CRATE_DEPENDS+= redox_syscall-0.1.56
CARGO_CRATE_DEPENDS+= regex-1.3.9
CARGO_CRATE_DEPENDS+= regex-syntax-0.6.18
CARGO_CRATE_DEPENDS+= remove_dir_all-0.5.2
CARGO_CRATE_DEPENDS+= roff-0.1.0
CARGO_CRATE_DEPENDS+= scopeguard-1.1.0
CARGO_CRATE_DEPENDS+= strsim-0.8.0
CARGO_CRATE_DEPENDS+= structopt-0.3.15
CARGO_CRATE_DEPENDS+= structopt-derive-0.4.8
CARGO_CRATE_DEPENDS+= syn-1.0.17
CARGO_CRATE_DEPENDS+= syn-mid-0.5.0
CARGO_CRATE_DEPENDS+= tempfile-3.1.0
CARGO_CRATE_DEPENDS+= textwrap-0.11.0
CARGO_CRATE_DEPENDS+= thiserror-1.0.20
CARGO_CRATE_DEPENDS+= thiserror-impl-1.0.20
CARGO_CRATE_DEPENDS+= thread_local-1.0.1
CARGO_CRATE_DEPENDS+= treeline-0.1.0
CARGO_CRATE_DEPENDS+= libc-0.2.149
CARGO_CRATE_DEPENDS+= libm-0.2.8
CARGO_CRATE_DEPENDS+= linked-hash-map-0.5.6
CARGO_CRATE_DEPENDS+= linux-raw-sys-0.4.10
CARGO_CRATE_DEPENDS+= memchr-2.6.4
CARGO_CRATE_DEPENDS+= memmap2-0.9.0
CARGO_CRATE_DEPENDS+= memoffset-0.9.0
CARGO_CRATE_DEPENDS+= num-traits-0.2.17
CARGO_CRATE_DEPENDS+= ppv-lite86-0.2.17
CARGO_CRATE_DEPENDS+= predicates-3.0.4
CARGO_CRATE_DEPENDS+= predicates-core-1.0.6
CARGO_CRATE_DEPENDS+= predicates-tree-1.0.9
CARGO_CRATE_DEPENDS+= proc-macro2-1.0.69
CARGO_CRATE_DEPENDS+= proptest-1.3.1
CARGO_CRATE_DEPENDS+= quick-error-1.2.3
CARGO_CRATE_DEPENDS+= quote-1.0.33
CARGO_CRATE_DEPENDS+= rand-0.8.5
CARGO_CRATE_DEPENDS+= rand_chacha-0.3.1
CARGO_CRATE_DEPENDS+= rand_core-0.6.4
CARGO_CRATE_DEPENDS+= rand_xorshift-0.3.0
CARGO_CRATE_DEPENDS+= rayon-1.8.0
CARGO_CRATE_DEPENDS+= rayon-core-1.12.0
CARGO_CRATE_DEPENDS+= redox_syscall-0.3.5
CARGO_CRATE_DEPENDS+= regex-1.10.2
CARGO_CRATE_DEPENDS+= regex-automata-0.4.3
CARGO_CRATE_DEPENDS+= regex-syntax-0.7.5
CARGO_CRATE_DEPENDS+= regex-syntax-0.8.2
CARGO_CRATE_DEPENDS+= roff-0.2.1
CARGO_CRATE_DEPENDS+= rustix-0.38.20
CARGO_CRATE_DEPENDS+= rusty-fork-0.3.0
CARGO_CRATE_DEPENDS+= scopeguard-1.2.0
CARGO_CRATE_DEPENDS+= serde-1.0.189
CARGO_CRATE_DEPENDS+= serde_derive-1.0.189
CARGO_CRATE_DEPENDS+= similar-2.3.0
CARGO_CRATE_DEPENDS+= strsim-0.10.0
CARGO_CRATE_DEPENDS+= syn-2.0.38
CARGO_CRATE_DEPENDS+= tempfile-3.8.0
CARGO_CRATE_DEPENDS+= terminal_size-0.3.0
CARGO_CRATE_DEPENDS+= termtree-0.4.1
CARGO_CRATE_DEPENDS+= thiserror-1.0.50
CARGO_CRATE_DEPENDS+= thiserror-impl-1.0.50
CARGO_CRATE_DEPENDS+= unarray-0.1.4
CARGO_CRATE_DEPENDS+= unescape-0.1.0
CARGO_CRATE_DEPENDS+= unicode-segmentation-1.6.0
CARGO_CRATE_DEPENDS+= unicode-width-0.1.7
CARGO_CRATE_DEPENDS+= unicode-xid-0.2.0
CARGO_CRATE_DEPENDS+= vec_map-0.8.1
CARGO_CRATE_DEPENDS+= version_check-0.9.1
CARGO_CRATE_DEPENDS+= unicode-ident-1.0.12
CARGO_CRATE_DEPENDS+= unicode-width-0.1.11
CARGO_CRATE_DEPENDS+= utf8parse-0.2.1
CARGO_CRATE_DEPENDS+= wait-timeout-0.2.0
CARGO_CRATE_DEPENDS+= wasi-0.9.0+wasi-snapshot-preview1
CARGO_CRATE_DEPENDS+= winapi-0.3.8
CARGO_CRATE_DEPENDS+= wasi-0.11.0+wasi-snapshot-preview1
CARGO_CRATE_DEPENDS+= winapi-0.3.9
CARGO_CRATE_DEPENDS+= winapi-i686-pc-windows-gnu-0.4.0
CARGO_CRATE_DEPENDS+= winapi-x86_64-pc-windows-gnu-0.4.0
CARGO_CRATE_DEPENDS+= windows-sys-0.45.0
CARGO_CRATE_DEPENDS+= windows-sys-0.48.0
CARGO_CRATE_DEPENDS+= windows-targets-0.42.2
CARGO_CRATE_DEPENDS+= windows-targets-0.48.5
CARGO_CRATE_DEPENDS+= windows_aarch64_gnullvm-0.42.2
CARGO_CRATE_DEPENDS+= windows_aarch64_gnullvm-0.48.5
CARGO_CRATE_DEPENDS+= windows_aarch64_msvc-0.42.2
CARGO_CRATE_DEPENDS+= windows_aarch64_msvc-0.48.5
CARGO_CRATE_DEPENDS+= windows_i686_gnu-0.42.2
CARGO_CRATE_DEPENDS+= windows_i686_gnu-0.48.5
CARGO_CRATE_DEPENDS+= windows_i686_msvc-0.42.2
CARGO_CRATE_DEPENDS+= windows_i686_msvc-0.48.5
CARGO_CRATE_DEPENDS+= windows_x86_64_gnu-0.42.2
CARGO_CRATE_DEPENDS+= windows_x86_64_gnu-0.48.5
CARGO_CRATE_DEPENDS+= windows_x86_64_gnullvm-0.42.2
CARGO_CRATE_DEPENDS+= windows_x86_64_gnullvm-0.48.5
CARGO_CRATE_DEPENDS+= windows_x86_64_msvc-0.42.2
CARGO_CRATE_DEPENDS+= windows_x86_64_msvc-0.48.5
CARGO_CRATE_DEPENDS+= yaml-rust-0.4.5
Loading

0 comments on commit 09f7324

Please sign in to comment.