Skip to content

Commit

Permalink
apache-ant: update to 1.10.14.
Browse files Browse the repository at this point in the history
Changes from Ant 1.10.13 TO Ant 1.10.14
=======================================

Changes that could break older environments:
-------------------------------------------

 * Resource#compareTo now invokes getName rather than toString as the
   later may be costly (for example in the case of a StringResource).
   Bugzilla Report 66496

 * When using Java 18 or higher, Ant will no longer use Java SecurityManager
   because it has been deprecated for removal and by default is disallowed
   to be set at runtime https://openjdk.org/jeps/411.
   This will mean that the "<permissions>" type is no longer functional when
   using Java 18 or higher.
   Furthermore, when using Java 18 or higher, if the build executes
   tasks that call "java.lang.System.exit()" and if those tasks aren't
   running in a forked VM of their own, then such tasks will now kill
   the entire Ant build process. It is recommended that such tasks be
   updated to launch in a forked JVM so that the System.exit() call
   will not impact the JVM in which Ant process runs.

Fixed bugs:
-----------

 * log only the stylesheet name in the xslt task.
   Github Pull Request #199

 * junitlauncher task's "test" and "listener" elements which take
   a "outputDir" property were incorrectly resolving the outputDir
   against the current working directory instead of the project's
   basedir. This has now been fixed.
   Bugzilla Report 66504

 * regexmapper would, in some cases, incorrectly consume backslash characters
   from the "to" attribute, resulting in missing backslashes in the output.
   This is now fixed.
   Bugzilla Report 66468

 * <fixcrlf>, <replace> and <replaceregexp> now try to preserve the
   file permissions of the files they modify.
   Bugzilla Report 66522

 * junitlauncher task would fail if a forked test timed out even
   if haltOnFailure was set to false. This is now fixed.
   Bugzilla Report 66411

 * fixes a bug in org.apache.tools.zip.ZipOutputStream where, even
   when "zip64Mode" is set to "always", ZipOutputStream may not create
   a CEN extra field data for the entry.
   Bugzilla Report 66873

 * legacy-xml listener of junitlauncher task wouldn't report certain
   failures involving junit jupiter dynamic tests. This has now been
   fixed.
   Github Pull Request #122

Other changes:
--------------

 * <fork> element of the junitlauncher task now has a new optional "java"
   attribute which can be used to point to a different Java installation
   for runnning the forked tests.
   Bugzilla Report 66464

 * made sure <echoproperties> sorts the echoed properties on JDK9+ as well.
   Bugzilla Report 66588

 * org.apache.tools.ant.taskdefs.Recorder class now introduces a
   setLogLevel(LogLevel level) method.
   Bugzilla Report 66238

 * The <fork> element of junitlaunchertask now allows a "forkMode"
   attribute. forkMode=perTestClass can now be used to launch
   each test class in a separate forked JVM.
   Bugzilla Report 65176
  • Loading branch information
0-wiz-0 committed Sep 9, 2023
1 parent f3a2ac6 commit 127bf02
Show file tree
Hide file tree
Showing 3 changed files with 14 additions and 22 deletions.
5 changes: 2 additions & 3 deletions devel/apache-ant/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.57 2023/02/16 10:32:36 abs Exp $
# $NetBSD: Makefile,v 1.58 2023/09/09 21:12:49 wiz Exp $

DISTNAME= apache-ant-1.10.13-bin
DISTNAME= apache-ant-1.10.14-bin
PKGNAME= ${DISTNAME:S/-bin//}
PKGREVISION= 1
CATEGORIES= devel java
MASTER_SITES= ${MASTER_SITE_APACHE:=ant/binaries/}
EXTRACT_SUFX= .tar.xz
Expand Down
23 changes: 8 additions & 15 deletions devel/apache-ant/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.31 2023/01/17 09:45:48 wiz Exp $
@comment $NetBSD: PLIST,v 1.32 2023/09/09 21:12:49 wiz Exp $
bin/ant
bin/antRun
lib/java/ant/ant-antlr.jar
Expand Down Expand Up @@ -227,12 +227,12 @@ share/doc/java/ant/anttaskslist.html
share/doc/java/ant/api/allclasses-index.html
share/doc/java/ant/api/allpackages-index.html
share/doc/java/ant/api/constant-values.html
share/doc/java/ant/api/copy.svg
share/doc/java/ant/api/deprecated-list.html
share/doc/java/ant/api/element-list
share/doc/java/ant/api/help-doc.html
share/doc/java/ant/api/index-all.html
share/doc/java/ant/api/index.html
share/doc/java/ant/api/jquery-ui.overrides.css
share/doc/java/ant/api/legal/ADDITIONAL_LICENSE_INFO
share/doc/java/ant/api/legal/ASSEMBLY_EXCEPTION
share/doc/java/ant/api/legal/LICENSE
Expand Down Expand Up @@ -961,6 +961,7 @@ share/doc/java/ant/api/org/apache/tools/ant/taskdefs/optional/junitlauncher/Stan
share/doc/java/ant/api/org/apache/tools/ant/taskdefs/optional/junitlauncher/TestExecutionContext.html
share/doc/java/ant/api/org/apache/tools/ant/taskdefs/optional/junitlauncher/TestResultFormatter.html
share/doc/java/ant/api/org/apache/tools/ant/taskdefs/optional/junitlauncher/confined/Constants.html
share/doc/java/ant/api/org/apache/tools/ant/taskdefs/optional/junitlauncher/confined/ForkDefinition.ForkMode.html
share/doc/java/ant/api/org/apache/tools/ant/taskdefs/optional/junitlauncher/confined/ForkDefinition.html
share/doc/java/ant/api/org/apache/tools/ant/taskdefs/optional/junitlauncher/confined/JUnitLauncherTask.html
share/doc/java/ant/api/org/apache/tools/ant/taskdefs/optional/junitlauncher/confined/LaunchDefinition.html
Expand All @@ -969,6 +970,7 @@ share/doc/java/ant/api/org/apache/tools/ant/taskdefs/optional/junitlauncher/conf
share/doc/java/ant/api/org/apache/tools/ant/taskdefs/optional/junitlauncher/confined/NamedTest.html
share/doc/java/ant/api/org/apache/tools/ant/taskdefs/optional/junitlauncher/confined/SingleTestClass.html
share/doc/java/ant/api/org/apache/tools/ant/taskdefs/optional/junitlauncher/confined/TestClasses.html
share/doc/java/ant/api/org/apache/tools/ant/taskdefs/optional/junitlauncher/confined/TestDefinition.ForkedRepresentation.html
share/doc/java/ant/api/org/apache/tools/ant/taskdefs/optional/junitlauncher/confined/TestDefinition.html
share/doc/java/ant/api/org/apache/tools/ant/taskdefs/optional/junitlauncher/confined/package-summary.html
share/doc/java/ant/api/org/apache/tools/ant/taskdefs/optional/junitlauncher/confined/package-tree.html
Expand Down Expand Up @@ -1426,6 +1428,7 @@ share/doc/java/ant/api/org/apache/tools/ant/util/ScriptRunner.html
share/doc/java/ant/api/org/apache/tools/ant/util/ScriptRunnerBase.html
share/doc/java/ant/api/org/apache/tools/ant/util/ScriptRunnerCreator.html
share/doc/java/ant/api/org/apache/tools/ant/util/ScriptRunnerHelper.html
share/doc/java/ant/api/org/apache/tools/ant/util/SecurityManagerUtil.html
share/doc/java/ant/api/org/apache/tools/ant/util/SourceFileScanner.html
share/doc/java/ant/api/org/apache/tools/ant/util/SplitClassLoader.html
share/doc/java/ant/api/org/apache/tools/ant/util/StreamUtils.html
Expand Down Expand Up @@ -1538,22 +1541,12 @@ share/doc/java/ant/api/overview-tree.html
share/doc/java/ant/api/package-search-index.js
share/doc/java/ant/api/resources/glass.png
share/doc/java/ant/api/resources/x.png
share/doc/java/ant/api/script-dir/images/ui-bg_glass_55_fbf9ee_1x400.png
share/doc/java/ant/api/script-dir/images/ui-bg_glass_65_dadada_1x400.png
share/doc/java/ant/api/script-dir/images/ui-bg_glass_75_dadada_1x400.png
share/doc/java/ant/api/script-dir/images/ui-bg_glass_75_e6e6e6_1x400.png
share/doc/java/ant/api/script-dir/images/ui-bg_glass_95_fef1ec_1x400.png
share/doc/java/ant/api/script-dir/images/ui-bg_highlight-soft_75_cccccc_1x100.png
share/doc/java/ant/api/script-dir/images/ui-icons_222222_256x240.png
share/doc/java/ant/api/script-dir/images/ui-icons_2e83ff_256x240.png
share/doc/java/ant/api/script-dir/images/ui-icons_454545_256x240.png
share/doc/java/ant/api/script-dir/images/ui-icons_888888_256x240.png
share/doc/java/ant/api/script-dir/images/ui-icons_cd0a0a_256x240.png
share/doc/java/ant/api/script-dir/jquery-3.5.1.min.js
share/doc/java/ant/api/script-dir/jquery-3.6.1.min.js
share/doc/java/ant/api/script-dir/jquery-ui.min.css
share/doc/java/ant/api/script-dir/jquery-ui.min.js
share/doc/java/ant/api/script-dir/jquery-ui.structure.min.css
share/doc/java/ant/api/script.js
share/doc/java/ant/api/search-page.js
share/doc/java/ant/api/search.html
share/doc/java/ant/api/search.js
share/doc/java/ant/api/serialized-form.html
share/doc/java/ant/api/stylesheet.css
Expand Down
8 changes: 4 additions & 4 deletions devel/apache-ant/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.41 2023/02/16 10:32:36 abs Exp $
$NetBSD: distinfo,v 1.42 2023/09/09 21:12:49 wiz Exp $

BLAKE2s (apache-ant-1.10.13-bin.tar.xz) = 91e6bad1f10e7d95b521ab8fce9ce81cf7bd12464579219ec27fc9b54ed8933e
SHA512 (apache-ant-1.10.13-bin.tar.xz) = 26e56bf670c22c8093fe51ec952fa51e813b1ab4200cb09fcd68fa291c5f6f626d7c6a42b4d3358b38111466e249d4bc6089b8c4093383759d6f8a08d39bc32d
Size (apache-ant-1.10.13-bin.tar.xz) = 4852532 bytes
BLAKE2s (apache-ant-1.10.14-bin.tar.xz) = 4383cda2c280fe5f70d738049ca441de671d356d844447c972535193a3759028
SHA512 (apache-ant-1.10.14-bin.tar.xz) = a77c2008582ed99802ddd5c87eef7b433978da9a3e5d500da6f5df9d9571bd5a165b7ce85d1742b7f0d89650ff89c23cb1f4fe52a7775c774ef432d28ac0d82a
Size (apache-ant-1.10.14-bin.tar.xz) = 4844448 bytes
SHA1 (patch-bin_ant) = 4087064f78ad86bc209c777f717f63d5e612cfd6

0 comments on commit 127bf02

Please sign in to comment.