Skip to content

Commit

Permalink
bash: properly install shared objects; pkglint fixes
Browse files Browse the repository at this point in the history
  • Loading branch information
adam committed Nov 25, 2022
1 parent 2138647 commit 296f0f1
Show file tree
Hide file tree
Showing 6 changed files with 25 additions and 9 deletions.
4 changes: 2 additions & 2 deletions shells/bash/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.107 2022/11/25 18:20:46 kre Exp $
# $NetBSD: Makefile,v 1.108 2022/11/25 23:29:47 adam Exp $

BASH_VERSION= 5.2
BASH_PATCHLEVEL= 12
Expand Down Expand Up @@ -70,7 +70,7 @@ BUILDLINK_API_DEPENDS.readline+= readline>=7.0
.include "../../devel/readline/buildlink3.mk"
.endif

.if !empty(USE_CROSS_COMPILE:M[yY][eE][sS]) && ${OPSYS} == "NetBSD"
.if ${USE_CROSS_COMPILE:U:tl} == yes && ${OPSYS} == "NetBSD"
CONFIGURE_ENV+= CC_FOR_BUILD=${NATIVE_CC:Q}
CONFIGURE_ENV+= ac_cv_c_long_long=yes
CONFIGURE_ENV+= ac_cv_c_long_double=yes
Expand Down
9 changes: 5 additions & 4 deletions shells/bash/distinfo
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.75 2022/11/25 18:20:46 kre Exp $
$NetBSD: distinfo,v 1.76 2022/11/25 23:29:47 adam Exp $

BLAKE2s (bash-5.2.tar.gz) = 430755ea2af4903dba2bdbeffd4d861edb9f54c248071362f0d14f15171764cd
SHA512 (bash-5.2.tar.gz) = 5647636223ba336bf33e0c65e516d8ebcf6932de8b44f37bc468eedb87579c628ad44213f78534beb10f47aebb9c6fa670cb0bed3b4e7717e5faf7e9a1ef81ae
Expand Down Expand Up @@ -39,11 +39,12 @@ Size (bash52-011) = 1229 bytes
BLAKE2s (bash52-012) = b980049d0314616909334aa332dbe55e7f2c4be0cab342a2b35342ca98d4c9af
SHA512 (bash52-012) = 8f969cb36ee81ac47a4c3c6ee7fbe62159192fa4f14cb48973eccd55c458e6a093adc3045ee1c379544d8183d77813977a43cad5d225322d8816540a1cb8893b
Size (bash52-012) = 9107 bytes
SHA1 (patch-af) = e26e3209902247263884cfebc11a2f7e43245062
SHA1 (patch-ag) = cd3b151e3bb045d2bb609c0a03d7d3df2c871f47
SHA1 (patch-aj) = 2e4c15afd9b50d44967ee8e1f85bdc908c0eeeb0
SHA1 (patch-Makefile.in) = 2e4c15afd9b50d44967ee8e1f85bdc908c0eeeb0
SHA1 (patch-builtins_printf.def) = e26e3209902247263884cfebc11a2f7e43245062
SHA1 (patch-builtins_psize.c) = cd3b151e3bb045d2bb609c0a03d7d3df2c871f47
SHA1 (patch-builtins_ulimit.def) = 1390069344607204eb3abbd6ddeb148ff590c55e
SHA1 (patch-configure) = c4e1ab53a1ee85f3e6121047f0aca8ceb85e6e5d
SHA1 (patch-examples_loadables_Makefile.in) = 0d27f82399c4ae9fae8ac0f8c48c68a23a3dcbd8
SHA1 (patch-examples_loadables_fdflags.c) = dce409c76b7d6c838eb25c3ccc7a89ee57ca69b8
SHA1 (patch-examples_loadables_getconf.c) = a71df9f54d77ee14de453b67bd4b3658ad7123eb
SHA1 (patch-lib_malloc_malloc.c) = 6e500228972eac0cb4d4defb02e9cf573b7fa207
Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-aj,v 1.2 2015/03/07 22:40:48 rodent Exp $
$NetBSD: patch-Makefile.in,v 1.1 2022/11/25 23:29:47 adam Exp $

This patch fixes the build on MirBSD and OpenBSD, where LIBINTL and
LIBICONV are incorrectly set.
Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-af,v 1.8 2016/06/11 12:54:24 rillig Exp $
$NetBSD: patch-builtins_printf.def,v 1.1 2022/11/25 23:29:47 adam Exp $

Fixes PRIdMAX and PRIuMAX on AIX < 5.1.

Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-ag,v 1.4 2016/06/11 12:54:24 rillig Exp $
$NetBSD: patch-builtins_psize.c,v 1.1 2022/11/25 23:29:47 adam Exp $

Use the definition of errno from <errno.h>.

Expand Down
15 changes: 15 additions & 0 deletions shells/bash/patches/patch-examples_loadables_Makefile.in
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
$NetBSD: patch-examples_loadables_Makefile.in,v 1.1 2022/11/25 23:29:47 adam Exp $

Correctly install shared objects (e.g. unstripped on some platforms).

--- examples/loadables/Makefile.in.orig 2022-11-25 23:21:05.000000000 +0000
+++ examples/loadables/Makefile.in
@@ -281,7 +281,7 @@ install-supported: all installdirs insta
@echo installing example loadable builtins in $(DESTDIR)${loadablesdir}
@for prog in ${ALLPROG}; do \
echo $$prog ; \
- $(INSTALL_PROGRAM) $(INSTALLMODE) $$prog $(DESTDIR)$(loadablesdir)/$$prog ;\
+ ${BSD_INSTALL_LIB} $(INSTALLMODE) $$prog $(DESTDIR)$(loadablesdir)/$$prog ;\
done

uninstall-dev:

0 comments on commit 296f0f1

Please sign in to comment.