Skip to content

Commit

Permalink
add gnumeric112 for the latest (gtk3 based) stable gnumeric version
Browse files Browse the repository at this point in the history
  • Loading branch information
drochner committed Mar 14, 2013
1 parent 9cb56b6 commit 8bec566
Show file tree
Hide file tree
Showing 8 changed files with 1,026 additions and 1 deletion.
3 changes: 2 additions & 1 deletion math/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.248 2013/03/11 12:29:47 taca Exp $
# $NetBSD: Makefile,v 1.249 2013/03/14 19:00:44 drochner Exp $

COMMENT= Mathematics

Expand Down Expand Up @@ -99,6 +99,7 @@ SUBDIR+= genius
SUBDIR+= glpk
SUBDIR+= gnumeric
SUBDIR+= gnumeric110
SUBDIR+= gnumeric112
SUBDIR+= gp-autpgrp
SUBDIR+= gp-factint
SUBDIR+= gp-fplsa
Expand Down
7 changes: 7 additions & 0 deletions math/gnumeric112/DESCR
Original file line number Diff line number Diff line change
@@ -0,0 +1,7 @@
Gnumeric is a powerful and easy to use spreadsheet program from
the GNOME project. The goal for this spreadsheet is to compete
with the commercial offerings. Users of Excel should be already
familiar with Gnumeric advanced features. A plugin system lets
you extend Gnumeric with GPL extensions, and an optional
Python and Perl plugins let you define complex functions in those
popular languages.
52 changes: 52 additions & 0 deletions math/gnumeric112/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# $NetBSD: Makefile,v 1.1 2013/03/14 19:00:45 drochner Exp $

DISTNAME= gnumeric-1.12.1
CATEGORIES= math gnome
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/gnumeric/1.12/}
EXTRACT_SUFX= .tar.xz

MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.gnome.org/projects/gnumeric/
COMMENT= Spreadsheet program from the GNOME project
LICENSE= gnu-gpl-v2

USE_TOOLS+= gmake intltool msgfmt perl:run pkg-config
USE_LIBTOOL= yes
USE_PKGLOCALEDIR= yes
GNU_CONFIGURE= yes
PKGCONFIG_OVERRIDE= libspreadsheet.pc.in

REPLACE_PERL+= plugins/perl-func/perl_func.pl

# PLIST contains versioned directory
GOFFICE_VERSION= 0.10.0
PLIST_SUBST+= GOFFICE_VERSION=${GOFFICE_VERSION}

.include "options.mk"

CONFIGURE_ARGS+= --with-python
CONFIGURE_ENV+= PYTHON=${PYTHONBIN:Q}
.include "../../lang/python/application.mk"
.include "../../devel/py-gobject3/buildlink3.mk"

#CONFIGURE_ARGS+= --with-gnome

.include "../../devel/glib2/schemas.mk"
# XXX: that version's not in pkgsrc yet
#BUILDLINK_API_DEPENDS.libgda+= libgda>=3.1.1
#.include "../../databases/libgda/buildlink3.mk"
#.include "../../databases/libgnomedb/buildlink3.mk"
BUILDLINK_API_DEPENDS.libgsf+= libgsf>=1.14.18
.include "../../devel/libgsf/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../lang/perl5/buildlink3.mk"
BUILDLINK_API_DEPENDS.goffice0.10+= goffice0.10-${GOFFICE_VERSION}{,nb*}
.include "../../misc/goffice0.10/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../mk/omf-scrollkeeper.mk"
.include "../../x11/gtk3/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"

.include "../../mk/bsd.pkg.mk"
908 changes: 908 additions & 0 deletions math/gnumeric112/PLIST

Large diffs are not rendered by default.

7 changes: 7 additions & 0 deletions math/gnumeric112/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1 2013/03/14 19:00:45 drochner Exp $

SHA1 (gnumeric-1.12.1.tar.xz) = bd1ed3ca0f005dd6c6830b279fdaad091f4d2cee
RMD160 (gnumeric-1.12.1.tar.xz) = 712bedeaafe1c58c9230eb33664e7281b55002ba
Size (gnumeric-1.12.1.tar.xz) = 15692328 bytes
SHA1 (patch-aa) = f1cefe02242eebccef616365bd08627d5e9fb4cd
SHA1 (patch-ab) = cb1f97384986219f8f54c3a87af5499d27dc8b1b
12 changes: 12 additions & 0 deletions math/gnumeric112/options.mk
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
# $NetBSD: options.mk,v 1.1 2013/03/14 19:00:45 drochner Exp $

PKG_OPTIONS_VAR= PKG_OPTIONS.gnumeric
PKG_SUPPORTED_OPTIONS= psiconv

.include "../../mk/bsd.options.mk"

.if !empty(PKG_OPTIONS:Mpsiconv)
.include "../../converters/psiconv/buildlink3.mk"
.else
CONFIGURE_ARGS+= --without-psiconv
.endif
16 changes: 16 additions & 0 deletions math/gnumeric112/patches/patch-aa
Original file line number Diff line number Diff line change
@@ -0,0 +1,16 @@
$NetBSD: patch-aa,v 1.1 2013/03/14 19:00:45 drochner Exp $

--- plugins/fn-numtheory/numtheory.c.orig 2009-09-07 02:03:35.000000000 +0000
+++ plugins/fn-numtheory/numtheory.c
@@ -38,7 +38,10 @@ GNM_PLUGIN_MODULE_HEADER;
* represented in a gnm_float _and_ in a guint64. (For regular "double",
* the latter part is irrelevant.)
*/
-static const double bit_max = MIN (1 / GNM_EPSILON, (gnm_float)G_MAXUINT64);
+static inline double bit_max_fn(void) {
+ return MIN (1 / GNM_EPSILON, (gnm_float)G_MAXUINT64);
+}
+#define bit_max (bit_max_fn())

/* ------------------------------------------------------------------------- */

22 changes: 22 additions & 0 deletions math/gnumeric112/patches/patch-ab
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
$NetBSD: patch-ab,v 1.1 2013/03/14 19:00:45 drochner Exp $

--- plugins/excelplugins/Makefile.in.orig 2013-03-01 23:01:25.000000000 +0000
+++ plugins/excelplugins/Makefile.in
@@ -93,7 +93,7 @@ am__uninstall_files_from_dir = { \
am__installdirs = "$(DESTDIR)$(gnumeric_plugin_excelpluginsdir)" \
"$(DESTDIR)$(xmldir)"
LTLIBRARIES = $(gnumeric_plugin_excelplugins_LTLIBRARIES)
-plugin_la_DEPENDENCIES = ../../src/.libs/libspreadsheet.la
+plugin_la_DEPENDENCIES = ../../src/libspreadsheet.la
am_plugin_la_OBJECTS = excelplugins.lo
plugin_la_OBJECTS = $(am_plugin_la_OBJECTS)
AM_V_lt = $(am__v_lt_@AM_V@)
@@ -376,7 +376,7 @@ gnumeric_plugin_excelpluginsdir = $(gnum
xmldir = $(gnumeric_plugin_excelpluginsdir)
gnumeric_plugin_excelplugins_LTLIBRARIES = plugin.la xlcall32.la
plugin_la_LDFLAGS = -module $(GNUMERIC_PLUGIN_LDFLAGS)
-plugin_la_LIBADD = ../../src/.libs/libspreadsheet.la
+plugin_la_LIBADD = ../../src/libspreadsheet.la
plugin_la_SOURCES = excelplugins.c
xlcall32_la_LDFLAGS = -module $(GNUMERIC_PLUGIN_LDFLAGS)
xlcall32_la_SOURCES = xlcall32_emulation.c win32replacements.h xlcall.h

0 comments on commit 8bec566

Please sign in to comment.