Skip to content

Commit

Permalink
add goffice0.10 for the latest stable branch of the gnumeric helper
Browse files Browse the repository at this point in the history
library
  • Loading branch information
drochner committed Mar 14, 2013
1 parent bc92d6b commit 9cb56b6
Show file tree
Hide file tree
Showing 7 changed files with 503 additions and 1 deletion.
3 changes: 2 additions & 1 deletion misc/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.393 2013/03/10 08:11:26 taca Exp $
# $NetBSD: Makefile,v 1.394 2013/03/14 18:56:05 drochner Exp $
#

COMMENT= Miscellaneous utilities
Expand Down Expand Up @@ -77,6 +77,7 @@ SUBDIR+= gnome-utils
SUBDIR+= gnuls
SUBDIR+= goffice0.6
SUBDIR+= goffice0.8
SUBDIR+= goffice0.10
SUBDIR+= gok
SUBDIR+= gone
SUBDIR+= gperiodic
Expand Down
7 changes: 7 additions & 0 deletions misc/goffice0.10/DESCR
Original file line number Diff line number Diff line change
@@ -0,0 +1,7 @@
goffice is a GLIB/GTK set of document centric objects and utilities.

There are common operations for document centric applications that are
conceptually simple, but complex to implement fully.
- plugins
- load/save documents
- undo/redo
34 changes: 34 additions & 0 deletions misc/goffice0.10/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# $NetBSD: Makefile,v 1.1 2013/03/14 18:56:06 drochner Exp $
#

DISTNAME= goffice-0.10.1
PKGNAME= ${DISTNAME:S/goffice/goffice0.10/}
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/goffice/0.10/}
EXTRACT_SUFX= .tar.xz

MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.gnome.org/
COMMENT= Library of document-centric objects and utilities
LICENSE= gnu-gpl-v2

USE_PKGLOCALEDIR= yes
USE_LIBTOOL= yes
PKGCONFIG_OVERRIDE+= ${WRKSRC}/libgoffice.pc.in
GNU_CONFIGURE= yes
USE_TOOLS+= gmake intltool msgfmt pkg-config

.include "../../converters/libiconv/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
BUILDLINK_API_DEPENDS.glib2+= glib2>=2.8.0
.include "../../devel/glib2/buildlink3.mk"
.include "../../devel/libgsf/buildlink3.mk"
BUILDLINK_API_DEPENDS.pango+= pango>=1.8.1
.include "../../devel/pango/buildlink3.mk"
.include "../../graphics/cairo/buildlink3.mk"
.include "../../graphics/gdk-pixbuf2/buildlink3.mk"
.include "../../graphics/librsvg/buildlink3.mk"
.include "../../graphics/lasem/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../x11/gtk3/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
402 changes: 402 additions & 0 deletions misc/goffice0.10/PLIST

Large diffs are not rendered by default.

22 changes: 22 additions & 0 deletions misc/goffice0.10/buildlink3.mk
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
# $NetBSD: buildlink3.mk,v 1.1 2013/03/14 18:56:06 drochner Exp $

BUILDLINK_TREE+= goffice0.8

.if !defined(GOFFICE0.8_BUILDLINK3_MK)
GOFFICE0.8_BUILDLINK3_MK:=

BUILDLINK_API_DEPENDS.goffice0.8+= goffice0.10>=0.10.0
BUILDLINK_ABI_DEPENDS.goffice0.8+= goffice0.10>=0.10.0
BUILDLINK_PKGSRCDIR.goffice0.8?= ../../misc/goffice0.10

.include "../../devel/glib2/buildlink3.mk"
.include "../../devel/libgsf/buildlink3.mk"
.include "../../devel/pango/buildlink3.mk"
.include "../../graphics/cairo/buildlink3.mk"
.include "../../graphics/librsvg/buildlink3.mk"
.include "../../graphics/lasem/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../x11/gtk3/buildlink3.mk"
.endif # GOFFICE0.8_BUILDLINK3_MK

BUILDLINK_TREE+= -goffice0.8
6 changes: 6 additions & 0 deletions misc/goffice0.10/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1 2013/03/14 18:56:06 drochner Exp $

SHA1 (goffice-0.10.1.tar.xz) = 1d9e5ac1aea893e10c10b5eb3c37e339dee80f1d
RMD160 (goffice-0.10.1.tar.xz) = 727e41758faa80d58daec271d53792231b21a742
Size (goffice-0.10.1.tar.xz) = 2120484 bytes
SHA1 (patch-go_cspline.c) = 25b4ef0285ec7991d2fe3f338e17ef159dd3a529
30 changes: 30 additions & 0 deletions misc/goffice0.10/patches/patch-go_cspline.c
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
$NetBSD: patch-go_cspline.c,v 1.1 2013/03/14 18:56:07 drochner Exp $

upstream commit 01f93869b7e2e9b38bd62c94d9d71103dffa4f08

--- goffice/math/go-cspline.c.orig 2013-02-23 23:20:13.000000000 +0000
+++ goffice/math/go-cspline.c
@@ -229,9 +229,9 @@ SUFFIX(go_cspline_ref) (GOCSpline *sp)

GType
#ifdef LONG_DOUBLE
-go_cspline_get_type (void)
-#else
go_csplinel_get_type (void)
+#else
+go_cspline_get_type (void)
#endif
{
static GType t = 0;
@@ -239,9 +239,9 @@ go_csplinel_get_type (void)
if (t == 0) {
t = g_boxed_type_register_static (
#ifdef LONG_DOUBLE
- "GOCSpline",
-#else
"GOCSplinel",
+#else
+ "GOCSpline",
#endif
(GBoxedCopyFunc)SUFFIX(go_cspline_ref),
(GBoxedFreeFunc)SUFFIX(go_cspline_destroy));

0 comments on commit 9cb56b6

Please sign in to comment.