Skip to content

Commit

Permalink
(devel/R-roxygen2) Updated 7.2.3 to 7.3.0
Browse files Browse the repository at this point in the history
# roxygen2 7.3.0

## New features

* `@docType package` now works more like documenting `"_PACKAGE"`,
  creating a `{packagename}-package` alias and clearly suggesting that
  you should switch to `"_PACKAGE"` instead (#1491).

* `_PACKAGE` will no longer generate an alias for your package name if
  a function of the same name exists (#1160).

* The NAMESPACE roclet now reports if you have S3 methods that are missing
  an `@export` tag. All S3 methods need to be `@export`ed (which confusingly
  really registers the method) even if the generic is not. This avoids rare,
  but hard to debug, problems (#1175). You can suppress the warning with
  `@exportS3Method NULL` (#1550).

* The `NAMESPACE` roclet once again regenerates imports _before_ loading
  package code and parsing roxygen blocks. This has been the goal for a long
  time (#372), but we accidentally broke it when adding support for code
  execution in markdown blocks. This resolves a family of problems where you
  somehow bork your `NAMESPACE` and can't easily get out of it because you
  can't re-document the package because your code doesn't reload.

## Minor improvements and bug fixes

* If you document a function from another package it is automatically
  imported. Additionally, if you set `@rdname` or `@name` you can opt out
  of the default `reexports` topic generation and provide your own docs
  (#1408).

* Generate correct usage for S4 methods with non-syntactic class names.

* The `ROXYGEN_PKG` env var provides the name of the package being documented
  (#1517).

* `@describeIn foo` now suggests that you might want `@rdname` instead
  (#1493). It also gives a more informative warning if you use it with an
  unsupported type (#1490).

* In `DESCRIPTION`, URLs containing escapes in `URL` and `BugReports` are
  now correctly handled (@HenningLorenzen-ext-bayer, #1415). Authors can now
  have multiple email addresses (@jmbarbone, #1487).

* `escape_examples()` is now exported (#1450).

* `@exportS3Method` provides the needed metadata to generate correct usage
  for S3 methods, just like `@method` (#1202).

* `is_s3_generic()` now ignores non-function objects when looking for a
  candidate function. I believe this is closer to how R operates.

* `@import` and friends are now ignored if they try to import from the
  package being documented. This is useful to add self-dependencies in
  standalone files meant to be used in other packages (r-lib/usethis#1853).

* `@importFrom` throws a friendlier error if you try and import a non-existing
  functions (@MichaelChirico, #1409).

* `@include` now gives an informative warning if you use a path that doesn't
  exist (#1497).

* `@inherit` can now also inherit from `@format` (#1293).
  • Loading branch information
mef committed Jan 22, 2024
1 parent 39f48bb commit 82d58fd
Show file tree
Hide file tree
Showing 2 changed files with 15 additions and 6 deletions.
13 changes: 11 additions & 2 deletions devel/R-roxygen2/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.5 2022/12/18 04:51:33 mef Exp $
# $NetBSD: Makefile,v 1.6 2024/01/22 23:16:31 mef Exp $

R_PKGNAME= roxygen2
R_PKGVER= 7.2.3
R_PKGVER= 7.3.0
CATEGORIES= devel

MAINTAINER= pkgsrc-users@NetBSD.org
Expand All @@ -22,9 +22,18 @@ DEPENDS+= R-knitr-[0-9]*:../../print/R-knitr
TEST_DEPENDS+= R-R.methodsS3-[0-9]*:../../devel/R-R.methodsS3
TEST_DEPENDS+= R-R.oo-[0-9]*:../../devel/R-R.oo
TEST_DEPENDS+= R-devtools-[0-9]*:../../devel/R-devtools
# character coding related error
TEST_DEPENDS+= R-testthat-[0-9]*:../../devel/R-testthat
TEST_DEPENDS+= R-rmarkdown-[0-9]*:../../textproc/R-rmarkdown

# !pdfTeX error: pdflatex (file tctt1000): Font tctt1000 at 600 not found
TEST_DEPENDS+= tex-ec-[0-9]*:../../fonts/tex-ec
TEST_DEPENDS+= tex-inconsolata-[0-9]*:../../fonts/tex-inconsolata
TEST_DEPENDS+= tex-latex-bin-[0-9]*:../../print/tex-latex-bin
TEST_DEPENDS+= tex-xkeyval-[0-9]*:../../print/tex-xkeyval
TEST_DEPENDS+= tex-xkeyval-[0-9]*:../../print/tex-xkeyval
TEST_DEPENDS+= tex-url-[0-9]*:../../print/tex-url

USE_LANGUAGES= c c++

.include "../../math/R/Makefile.extension"
Expand Down
8 changes: 4 additions & 4 deletions devel/R-roxygen2/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.6 2022/12/18 04:51:33 mef Exp $
$NetBSD: distinfo,v 1.7 2024/01/22 23:16:31 mef Exp $

BLAKE2s (R/roxygen2_7.2.3.tar.gz) = 0a71242df6b05994a8dc1d9cc3dad5083a2e2f1879f38645ad3577353325258b
SHA512 (R/roxygen2_7.2.3.tar.gz) = 9c57e4afaf263ad29ebd1d936c57fba4f46637b65b0154290fe4ef221d1362ce99c780609604594752e4a0d598a350b3f18dcc82df9b2d2138775f4b9ce6f3eb
Size (R/roxygen2_7.2.3.tar.gz) = 279442 bytes
BLAKE2s (R/roxygen2_7.3.0.tar.gz) = c5048a5c4fe5f39b0cf90a181ef431b39d1a132a2ac0702c6c8c493893145875
SHA512 (R/roxygen2_7.3.0.tar.gz) = 82b55df02c7f23fd8405b88e40d2fa58d31f7387e2608fac19b0c216906fcec09984c1c66470dd8098f9efcf7c5f57e5b346e56530c1fb58729c28f378d05753
Size (R/roxygen2_7.3.0.tar.gz) = 293925 bytes

0 comments on commit 82d58fd

Please sign in to comment.