-
Notifications
You must be signed in to change notification settings - Fork 0
/
KSmallestElements
78 lines (61 loc) · 1.8 KB
/
KSmallestElements
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
You are given an integer k and an array of integers that contain numbers in random order.
Write a program to find k smallest numbers from given array. You need to save them in an array and return it.
Time complexity should be O(n * logk) and space complexity should not be more than O(k).
Note: Order of elements in the output is not important.
Input Format :
The first line of input contains an integer, that denotes the value of the size of the array. Let us denote it with the symbol N.
The following line contains N space separated integers, that denote the value of the elements of the array.
The following line contains an integer, that denotes the value of k.
Output Format :
The first and only line of output print k smallest elements. The elements in the output are separated by a single space.
Sample Input 1 :
13
2 12 9 16 10 5 3 20 25 11 1 8 6
4
Sample Output 1 :
1 2 3 5
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
#include "solution.h"
int main() {
int size;
cin >> size;
int *input = new int[size];
for (int i = 0; i < size; i++) {
cin >> input[i];
}
int k;
cin >> k;
vector<int> output = kSmallest(input, size, k);
sort(output.begin(), output.end());
for (int i = 0; i < output.size(); i++) {
cout << output[i] << " ";
}
delete[] input;
}
#include <queue>
vector<int> kSmallest(int arr[], int n, int k) {
priority_queue<int> pq;
for(int i = 0; i < k; i++) {
pq.push(arr[i]);
}
for(int i = k; i < n; i++) {
if(arr[i]<pq.top()){
pq.push(arr[i]);
pq.pop();
}
}
int l = k-1;
while(!pq.empty()) {
arr[l] = pq.top();
pq.pop();
l--;
}
int j = 0;
while(j<k){
cout << arr[j] << " ";
j++;
}
}