-
Notifications
You must be signed in to change notification settings - Fork 78
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Showing
1 changed file
with
8 additions
and
6 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,14 +1,16 @@ | ||
diff --git PKGBUILD PKGBUILD | ||
index b776af4..bbe3adb 100644 | ||
index dc761d5..55f9a37 100644 | ||
--- PKGBUILD | ||
+++ PKGBUILD | ||
@@ -83,7 +83,8 @@ check() { | ||
local _python_version=$(python -c 'import sys; print("".join(map(str, sys.version_info[:2])))') | ||
@@ -84,8 +84,10 @@ check() { | ||
local python_version=$(python -c 'import sys; print("".join(map(str, sys.version_info[:2])))') | ||
mv tests/autobahn/test_autobahn.py{,.bak} # Docker tests | ||
# https://github.com/aio-libs/aiohttp/issues/8234 | ||
- PYTHONPATH="$PWD/build/lib.linux-$CARCH-cpython-${_python_version}" pytest -k 'not test_aiohttp_plugin' | ||
+ # skip import time test | ||
+ PYTHONPATH="$PWD/build/lib.linux-$CARCH-cpython-${_python_version}" pytest -k 'not test_aiohttp_plugin and not test_import_time' | ||
+ # and skip import time test for slow riscv64 | ||
PYTHONPATH="$PWD/build/lib.linux-$CARCH-cpython-$python_version" pytest \ | ||
- --deselect 'tests/test_pytest_plugin.py::test_aiohttp_plugin' | ||
+ --deselect 'tests/test_pytest_plugin.py::test_aiohttp_plugin' \ | ||
+ --deselect 'tests/test_imports.py::test_import_time' | ||
mv tests/autobahn/test_autobahn.py{.bak,} | ||
} | ||
|