Skip to content

Commit

Permalink
updpatch: python-aiohttp 3.10.5-1
Browse files Browse the repository at this point in the history
Fix rotten.
  • Loading branch information
felixonmars committed Dec 9, 2024
1 parent d890f07 commit 9827039
Showing 1 changed file with 8 additions and 6 deletions.
14 changes: 8 additions & 6 deletions python-aiohttp/riscv64.patch
Original file line number Diff line number Diff line change
@@ -1,14 +1,16 @@
diff --git PKGBUILD PKGBUILD
index b776af4..bbe3adb 100644
index dc761d5..55f9a37 100644
--- PKGBUILD
+++ PKGBUILD
@@ -83,7 +83,8 @@ check() {
local _python_version=$(python -c 'import sys; print("".join(map(str, sys.version_info[:2])))')
@@ -84,8 +84,10 @@ check() {
local python_version=$(python -c 'import sys; print("".join(map(str, sys.version_info[:2])))')
mv tests/autobahn/test_autobahn.py{,.bak} # Docker tests
# https://github.com/aio-libs/aiohttp/issues/8234
- PYTHONPATH="$PWD/build/lib.linux-$CARCH-cpython-${_python_version}" pytest -k 'not test_aiohttp_plugin'
+ # skip import time test
+ PYTHONPATH="$PWD/build/lib.linux-$CARCH-cpython-${_python_version}" pytest -k 'not test_aiohttp_plugin and not test_import_time'
+ # and skip import time test for slow riscv64
PYTHONPATH="$PWD/build/lib.linux-$CARCH-cpython-$python_version" pytest \
- --deselect 'tests/test_pytest_plugin.py::test_aiohttp_plugin'
+ --deselect 'tests/test_pytest_plugin.py::test_aiohttp_plugin' \
+ --deselect 'tests/test_imports.py::test_import_time'
mv tests/autobahn/test_autobahn.py{.bak,}
}

0 comments on commit 9827039

Please sign in to comment.