Skip to content

Commit

Permalink
updpatch: qemu 9.1.1-2
Browse files Browse the repository at this point in the history
  • Loading branch information
felixonmars committed Nov 13, 2024
1 parent 3ff5d1a commit f2f195b
Showing 1 changed file with 18 additions and 16 deletions.
34 changes: 18 additions & 16 deletions qemu/riscv64.patch
Original file line number Diff line number Diff line change
@@ -1,3 +1,5 @@
diff --git PKGBUILD PKGBUILD
index d6b9c07..d2958dc 100644
--- PKGBUILD
+++ PKGBUILD
@@ -22,7 +22,6 @@ pkgname=(
Expand All @@ -7,7 +9,7 @@
- qemu-vmsr-helper
qemu-{base,desktop,emulators-full,full}
)
pkgver=9.1.0
pkgver=9.1.1
@@ -123,6 +122,7 @@ makedepends=(
zlib
zstd
Expand All @@ -16,7 +18,7 @@
source=(
https://download.qemu.org/qemu-$pkgver.tar.xz{,.sig}
bridge.conf
@@ -429,13 +429,6 @@ package_qemu-common() {
@@ -431,13 +431,6 @@ package_qemu-common() {
# remove unneeded files
find "$pkgdir" -name .buildinfo -delete

Expand All @@ -30,7 +32,7 @@
(
# create man page symlinks for all system emulators
cd "$pkgdir/usr/share/man/man1"
@@ -496,6 +489,9 @@ package_qemu-common() {
@@ -498,6 +491,9 @@ package_qemu-common() {

_pick qemu-system-aarch64 usr/bin/qemu-system-aarch64
_pick qemu-system-aarch64 usr/share/man/man1/qemu-system-aarch64.1*
Expand All @@ -40,7 +42,7 @@

_pick qemu-system-alpha usr/bin/qemu-system-alpha
_pick qemu-system-alpha usr/share/man/man1/qemu-system-alpha.1*
@@ -506,6 +502,9 @@ package_qemu-common() {
@@ -508,6 +504,9 @@ package_qemu-common() {
_pick qemu-system-arm usr/share/man/man1/qemu-system-arm.1*

_pick qemu-system-arm-firmware usr/share/qemu/npcm7xx_bootrom.bin
Expand All @@ -50,7 +52,7 @@

_pick qemu-system-avr usr/bin/qemu-system-avr
_pick qemu-system-avr usr/share/man/man1/qemu-system-avr.1*
@@ -580,6 +579,13 @@ package_qemu-common() {
@@ -582,6 +581,13 @@ package_qemu-common() {

_pick qemu-system-x86-firmware usr/share/qemu/{kvmvapic,linuxboot,multiboot{,_dma},pvh}.bin
_pick qemu-system-x86-firmware usr/share/qemu/qboot.rom
Expand All @@ -64,42 +66,42 @@

_pick qemu-system-xtensa usr/bin/qemu-system-xtensa{,eb}
_pick qemu-system-xtensa usr/share/man/man1/qemu-system-xtensa{,eb}.1*
@@ -607,7 +613,6 @@ package_qemu-common() {
@@ -609,7 +615,6 @@ package_qemu-common() {
_pick qemu-vhost-user-gpu usr/lib/qemu/vhost-user-gpu
_pick qemu-vhost-user-gpu usr/share/qemu/vhost-user/50-qemu-gpu.json

- _pick qemu-vmsr-helper usr/bin/qemu-vmsr-helper
)
}

@@ -804,7 +809,7 @@ package_qemu-hw-s390x-virtio-gpu-ccw() {
@@ -806,7 +811,7 @@ package_qemu-hw-s390x-virtio-gpu-ccw() {

package_qemu-system-aarch64() {
pkgdesc="QEMU system emulator for AARCH64"
- depends=("${_qemu_system_deps[@]}" edk2-aarch64 systemd-libs libudev.so)
+ depends=("${_qemu_system_deps[@]}" systemd-libs libudev.so)
- depends=("${_qemu_system_deps[@]}" dtc edk2-aarch64 systemd-libs libudev.so)
+ depends=("${_qemu_system_deps[@]}" dtc systemd-libs libudev.so)
mv -v $pkgname/* "$pkgdir"
_install_licenses
}
@@ -825,7 +830,7 @@ package_qemu-system-alpha-firmware() {
@@ -827,7 +832,7 @@ package_qemu-system-alpha-firmware() {

package_qemu-system-arm() {
pkgdesc="QEMU system emulator for ARM"
- depends=("${_qemu_system_deps[@]}" edk2-arm qemu-system-arm-firmware=$pkgver-$pkgrel systemd-libs libudev.so)
+ depends=("${_qemu_system_deps[@]}" qemu-system-arm-firmware=$pkgver-$pkgrel systemd-libs libudev.so)
- depends=("${_qemu_system_deps[@]}" dtc edk2-arm qemu-system-arm-firmware=$pkgver-$pkgrel systemd-libs libudev.so)
+ depends=("${_qemu_system_deps[@]}" dtc qemu-system-arm-firmware=$pkgver-$pkgrel systemd-libs libudev.so)
mv -v $pkgname/* "$pkgdir"
_install_licenses
}
@@ -987,7 +992,7 @@ package_qemu-system-tricore() {
@@ -989,7 +994,7 @@ package_qemu-system-tricore() {

package_qemu-system-x86() {
pkgdesc="QEMU system emulator for x86"
- depends=("${_qemu_system_deps[@]}" edk2-ovmf qemu-system-x86-firmware=$pkgver-$pkgrel seabios systemd-libs libudev.so)
+ depends=("${_qemu_system_deps[@]}" qemu-system-x86-firmware=$pkgver-$pkgrel systemd-libs libudev.so)
- depends=("${_qemu_system_deps[@]}" dtc edk2-ovmf qemu-system-x86-firmware=$pkgver-$pkgrel seabios systemd-libs libudev.so)
+ depends=("${_qemu_system_deps[@]}" dtc qemu-system-x86-firmware=$pkgver-$pkgrel systemd-libs libudev.so)
mv -v $pkgname/* "$pkgdir"
_install_licenses
}
@@ -1231,7 +1236,6 @@ package_qemu-full() {
@@ -1233,7 +1238,6 @@ package_qemu-full() {
qemu-tests=$pkgver-$pkgrel
qemu-tools=$pkgver-$pkgrel
qemu-user=$pkgver-$pkgrel
Expand Down

0 comments on commit f2f195b

Please sign in to comment.