23. Section Intro

Appium Setup on MAC - iOS

Simulator
Understand the Role of WebDriverAgent Server
Understand Apple’s Code Signing Process

Real Device Setup using Free Account
Real Device Setup using Paid Account
Join the Apple Developer Program

Build and Distribute the Application IPA for Real Device

0 & ¢, 1:32/1:36

HomeBrew
a. Package manager for mac OS; used to install Software packages

b. Go to: https://brew.sh/

c. Hit this command in Terminal (This will download and install Command Line Tools

for XCode first):
i.  /bin/bash -c "$(curl -fsSL
h 1/ /raw.gi rcontent.com/Homebr install/HEAD /install.

h)"

Terminal Shell Edit View Window Help

B upemy_aAppium Mobile Autor: % [B] UDEMY_Appium Mobile Autorn X <=
o0 we 1 rajatverma — -zsh — B0x24
Last lngin: Wed Jan 5§ 1Z:18:44 on congo

Fpb

la
rajatvermafrajats-MacBook-Air ~ % EGEOE-EELEE-E Y-},

serconten t.com/Homebrew/ in 1/HEAD/install.sh)

 hu bl 1o

ii.


https://brew.sh/
https://raw.githubusercontent.com/Homebrew/install/HEAD/install.sh
https://raw.githubusercontent.com/Homebrew/install/HEAD/install.sh

§ HERD is now at Efc4B7f2abe cloudflare-wrangler: update 1.19.7 battle.
==> Downloading https://gher.io/v2/homebrew/portable-ruby/portable-ruby/blobs/sha2ss: f2dsc

Jcd@altoléeifeaZiTdlc25aak@cdeifloe2Pans
AR AR R R AR AR IR RO R AR AR RSP A AR AR RSP E AR IR IRERE TR R AR IRIRERRTRERRARIRE

» Powuring portable-ruby-2.4.8.armés_big_sur.bottle.tar.gz
Warning: /opt/homebrew/bin is not in your PATH.
Instructions on how to configure your shell for Homebrew
can be found in the "Next steps' section below.
==» Installation successfull

| ==> Homebrew has enabled anonymous aggregate formulae and cask analytics.
Read the analytics decumentation (amd how to opt-out) here:
hitps:/f/docs.brew. shfknalytics
No analytics data has been sent yet (nor will any be during this install run).
==> HWomebrew is rum entirely by unpaid volunteers. Please consider donating:
nttps://github.com/Homebrew/brewsdonations

==> Next steps:
- Run these two conmands in your terminal to add Homebrew to your PATH:

eche 'eval "S(/opt/homebrew/bin/brew shellenv)®' »>»> /Users/rajatverma/.zprofile
eval "S(/opt/homebrew/bin/brew shellenv)"®

- Run brew halp to get started

- Further documentation:
https://docs.brew.sh

rajatvermafrajats—MacBook-Air -~ %
rajatvermafrajats—-MacBook-air ~ % ]

iii.
d. Hitthese commands:
i.  echo 'eval "$(/opt/homebrew/bin/brew shellenv)" >>
/Users/rajatverma/.zprofile
ii. eval "$(/opt/homebrew/bin/brew shellenv)"
e. To verify that Brew is setup sucessfully
i.  brew help

a. Command to install node (this will install npm as well)
i. brew install node
b. Ifnode is already installed in your machine and you want to upgrade the version
i.  brew upgrade node
c. To check the version of Node
i. node-v
d. To check the path of Node installation
i. where node
Appium CLI
a. To install Appium using NPM
i. npm install -g appium
b. To check the version of Appium
i. appium -v
C. To check the path of Appium installation
i. where appium
d. To start the Appium server (Default port: 4723)
i. appium

Appium Desktop Client
a. Go to: https://appium.io/downloads.html

b. Download the DMG file and install it

c. NOTE:
i.  Ifyou are unable to install it -> throws Error like this:



https://appium.io/downloads.html

(%

“Appium Server GUI" can't be
opened because Apple cannot
check it for malicious software.

This software needs to be updated.
Contact the developer for more
Information

github.com

ii. Then,
1. Go to System Preferences -> Security & Privacy -> Open Anyway
2. Right click on the Appium app -> Click on Open

i e L i Security & Privacy Q

]

General  Filevault  Firewall  Privacy

A login password has been set for this user  Change Password..

Require password 5 minutes [ after sleep or screen saver begins

Allow apps downloaded from:

“Appium Server GUI" was blocked from use because it is not from an Open Anyway
identified developer.

Appium Inspector
a. Inthe latest version:
i.  They are not giving Appium Inspector included in this app
1. This inspector helps in identifying the Ul elements for Native apps.
ii.  You need to download other application:
1. https://github.com/appium/appium-inspector/releases

2. Appium-Inspector-mac-2021.12.2.dmg
NOTE:

1. We have installed Appium CLI and Appium Desktop app
2. We can not run both on the same ports
a. To run Appium server on a different port: appium -p 4725

a. Appium requires XCode to communicate with XCUITest framework
i. Before start installation,
1. Make sure you have latest version OS


https://github.com/appium/appium-inspector/releases

a. Click on Safari icon (top-left corner) -> About This MAC ->
Software Update
2. Configure Apple ID in Account preferences
a. System preferences -> Sign in with Apple ID

b. To download Xcode:
i.  App Store -> XCode

XCode Command Line Tool
a. Terminal ->
I. xcode-select --install

XCPretty
a. Optional component
b. Itis used to make XCode output reasonable
c. Terminal ->
1. gem install xcpretty
ii.  Ifyou face any issue -
1. sudo gem install xcpretty

Carthage
a. Dependency Manager
b. Required for WebDriverAgent
c. Terminal ->
i. brew install carthage

Appium Doctor
a. To install Appium-Doctor:
i. Terminal ->
1. npm install -g appium-doctor
2. appium-doctor --h

Check Appium setup for iOS
a. Terminal ->
i. appium-doctor --ios
b. Now, if you face any warning for XCode like below:

Bye! Aun appium—doctor again when all manual fixes have been a
| pplied!

| rajatverma@rajats-MacBook-Air - % appium-doctor --ios
Appium Doctor v.1.14.8
### Diagnostic for dependencies starting 888
The Nede.js binary was found at: fopt/homebrew/bin/node
Mode wersion is 17.3.8
WARN = Error running xcrun simctl
Xcode Command Line Tools are installed im: /Library/Develop
er/CommandLineTools
DevToclsSecurity is enabled.
The Authorizatien DB is set up properly.
. Carthage was found at: Jopt/homebrew/bin/carthage. Installe
1. d version is: 8.3B.8

ii.  Then, we need to change the XCode installation path
iii. =~ Recommended path: /Applications/Xcode.app/Contents/Developer



allation-for-your-machine/
i.  To know the XCode installation path -> xcode-select -p
ii.  Change the path-> sudo xcode-select --switch
/Applications/Xcode.app/Contents/Developer/

UIKitCatalog App for Simulator
a. This app is open-source and very helpful if you want to practice automation for

different views
b. Developed by Apple and now, adopted by Appium to perform testing at their end
c. Go to: https://github.com ium /i
d. Download ZIP
e.

Go to the downloaded path
i.  Open the terminal inside this location -> UIKitCatalog
ii. cd /Users/rajatverma/Desktop/Work/Other\
Apps/ios-uicatalog-master/UIKitCatalog
f.  We need to build this application
i.  Terminal:
1. npm install
ii.  UlKitCatalog Inside this location, you must get an folder structure
iii.  build/Release-iphonesimulator/UIKitCatalogiphonesimulator.app
1. UIKitCatalogiphonesimulator.app ->
a. Thisis the application which we can use for practice

Automation
ios-uicatalog-master
sfBloo & & & O Q
Name Date Modified Size Kirs
T guipfile.js
= index.js
' LICENSE
ations - node_modules
op ¥ package-lock.json
% package json
B README.md
loads > UiCatalog

vicatalog-info.md
v UlKitCatalog

| Drive: v build
v Release-iphonesimulator 26§
- UlKitCatalog-iphonesimulator Today at 5:25 PM 2.2 MB
mi. & UlKitCatalog.app.dSYM 3y at 5:25 F
Wk > UiKitCatalog swiftmodule Y
2. » UlKitCatalog.build

Simulator
a. Open Xcode
b. Click on Xcode (Top-Left corner) -> Developer Tools -> Simulator



http://yangruixuan.github.io/blog/how-to-change-the-path-to-the-active-xcode-installation-for-your-machine/
http://yangruixuan.github.io/blog/how-to-change-the-path-to-the-active-xcode-installation-for-your-machine/
https://github.com/appium/ios-uicatalog
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About Xcode
Xcode Extensions...

Preferences...
Behaviors

Xcode Server...

@ Instruments
Services ulator
Hide Xcode @ :(I:c;sslblllty Inspector
ileMerge
Hide Others s P
(U Create ML
Show All 1
03 Reality Ci

D Velcome to Xcode

More Developer Tools...
Version 13.2.1 (13C100) No Recent Projects

Create a new Xcode project
Create an app for iPhone, iPad, Mac, Apple Watch, or Apple TV.

Clone an existing project
Start working on something from a Git repository.

Open a project or file
Open an existing project or file on your Mac.

Show this window when Xcode launches

) =80 s @@ 7

d. By default, it will open any device in Simulator
e. Ifyou want to change it, then, File -> Open Device -> Select the Device

Open Simulator —i0s 152 > | iPhone8
tv0S 16.2 > iPhone 8 Plus
Save Screen ®S h
watchOS 8.3 > iPhone 11
Record Screen ® .
iPhone 11 Pro

Stop Recording

iPhone 11 Pro Max
iPhone SE (2nd generation)

Ap
9ithub- - Gpy selection > 1PhonellZan|
ison.md

Save Complication Bundle

THURSDAY

Ap X
ps://wn Close Window -
Apprumuutior =+ mpeg-consumer iPhone 12 Pro
atures. Please install it with 'npm PhonSIBEI D Max

WARN ppiumDoctor K
tor. Please read https://github.com iPhone 13 Pro

WBRN AppiumDoctor = Why idb is nee W I i
R oo o e|g  iPhonets Pr.o.Max
WARN AppiunDoctor = Why applesimut iPhone 13 mini
ppium.io/docs/en/drivers/ios-xcuite i ent Projects
WARN AopiunDoctor - ios-deploy is v/iPhonegl J
lications to real device. Please re iPod touch (7th generation)
to install it 4 .
info AppiumDoctor Createaney iPad Pro (9.7-inch)
info Appiumboctor ### Createanapf  ipad (9th generation)

iPad Air (4th generation)

info AppiumDoctor
iPad Pro (11-inch) (3rd generation)

info AppiumDoctor Bye! Run appium-d
pplied!

info AppiumDoctor
rajatverma@rajats-MacBook-Air ~ % []

Clone an exi
Start working

Open a proji
Open an exist  iPad mini (6th ge

v Show this window when Xcode

Appium Desktop and Appium Inspector



a. We are going to use these 2 to establish the connection between application and
device
Start Appium server using Appium Server GUI
c. Start Appium Inspector
i.  App path: /Users/rajatverma/Desktop/Work/Other\
Apps/ios-uicatalog-master/UlKitCatalog/build/Release-iphonesimulator/UIKi
tCatalog-iphonesimulator.app

& Appiuminspector Edit View Window Help @ © W T Q & © Thu6Jan 3:02PM

LN
Appium Server Select Cloud Providers

Remote Host Remote Port

Remote Path | fwd/hub|

> Advanced Settings

Desired Capabilities Saved Capability Sets 1 Attach to Session...

platformName text i0s X
JSON Representation

appium:deviceName text iPhone

. {
i
-
4
i
9
4
4
B
4
‘i
i
4
7
4
4
i
1
4
4
7

appium:automationName text XCUITest
“platformName": "i0S",

appium:udid text 18FB4726-3A15-498D-8F “appium:deviceName": "iPhone",
“appiun:automationName": "XCUITest",
“appium:udid”: "18FB4726-3A15-498D-8F7E-84965AB706EF" ,
“appium:app": "/Users/rajatverma/Desktop/Work/OtherApps/ios-uicatalog-
master/UIKitCatalog/build/Re lease-iphonesimulator/UIKitCatalog-
iphones inulator. app"

}

appium:app text [Users]rajatverma/Desktop;

Automatically add necessary Appium vendor prefixes on start

& Desired Capabilities Documentation Save As..
) N >, ) (o
IBOR®T=2B0Veg @8~ "o@0@A0D LT P oEmy

d. To get the device name:
i.  Simulator -> Settings -> General -> About -> Name
e. To getthe udid (Unique Identifier):
i.  Terminal ->
1. List of simulators:
a. xcrun simctl list
b. xcrun xctrace list devices
ii. XCode:
1. Window -> Devices and Simulators ->
2. Select the device
3. 18FB4726-3A15-498D-8F7E-84965AB706EF



Appium Inspector  Edit View Window Help
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3:04 = @m  Source  Actions

. UIKitCatalog
UlkitCatalog [ App Source < Selected Element
Activity Indicators

Activity Indicators ActivityindicatorViewController

ActivityindicatorViewController

¥ <XCUIElementTypeApplication name="UIKitCat: Interactions are not available for this

> <XCUIElementTypeWindow> element

Alert Views Alert Views
AlertControllerViewController AlertControllerViewController
Buttons Buttons
ButtonViewController ButtonViewController

Date Picker Date Picker

DatePickerController DatePickerController

Image View
ImageViewController

Image View
ImageViewController

Page Control
PageControlViewController

Page Control
PageControlViewController

Picker View
PickerViewController

Progress Views

ProgressViewController Progress Views

ProgressViewController
Search h
SearchViewControllers Searcl
SearchViewControllers

Segmented Controls

Segmented Controls
SegmentedControlViewController

Sliders "
SliderViewController Sliders

. SliderViewController
Stack Views
StackViewController Stack Views

StackviewController

Steppers

StepperViewController Steppers
Switches StepperViewController
SwitchViewController Switches
Text Fields SwitchViewController
TextFieldViewController .

Text Fields

Text View
TextViewController

TextFieldViewController

Text View

Toolbars TextViewController

SegmentedControlViewController

Toolbars
TooIbarVieW CoNtr Qg —

========Appium setup on Mac - Android - START==========
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Appium Setup on MAC - Android

Emulator

Real Device

Create Android Virtual Device

Enable USB Debugging on Real Device

Create new Driver Session

Installed previously (Above section)
a.

1. Install homebrew (package manager for mac0S and is used to install software packages)

Link: https://brew.sh/
Command: /usr/bin/ruby —e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

2. Install node and npm (Appium dependencies)

Commands to check if node and npm are installed:
node -v
npm -v
Command to install node: brew install node (This will jig
Command to check node installation path: where node

Important update:
From Appium v1.22.0 and

v2.0, Appium Inspector is no

3. Install Appium server using NPM (Appium CLI) I

Command to install Appium: npm install fig Appium Desktop Server. Itisa
Command to check Appium version: appium -v separate application.
Command to check Appium installation path: where appium

OR

3. Install Appium server using Appium gpsktop client

Download link: https://appium.io

Java JDK
a. Goto:

tml

b. Download and install
c. Verify whether Java is setup or not? -> Terminal ->


https://www.oracle.com/in/java/technologies/javase/javase8-archive-downloads.html
https://www.oracle.com/in/java/technologies/javase/javase8-archive-downloads.html

i. java -version
Android Studio
a. https://developerandroid.com/studio
b. Download and Install it
c. Android Studio -> More Actions -> SDK Manager
i.  Android SDK Location: /Users/rajatverma/Library/Android/sdk

Appearance & Behavior > System Settings > Android SDK
Manager for the Android SDK and Tools used by the IDE

Android SDK Location: | /Users/rajatverma/Library/Android/sdk

SDK Platforms SDK Tools SDK Update Sites

Each Android SDK Platform package includes the Android platform and sources pertaining to
an API level by default. Once installed, the IDE will automatically check for updates. Check
"show package details" to display individual SDK components.

Name APl Le... Revision Status

v |=/ Android APl 32
¥ Android SDK Platform 32 32 Installed
v Google APIs ARM 64 v8a System Image 32 Installed
Google APIs Intel x86 Atom_64 System Image 32 Not installed
Google Play ARM 64 v8a System Image 32 Not installed
Google Play Intel x86 Atom_64 System Image 32 Not installed
v |=| Android 12.0 (S)
¥| Android SDK Platform 31 31
¥ Sources for Android 31 31
Android TV Intel x86 Atom System Image 31
ARM 64 v8a System Image <
Intel x86 Atom_64 System Image 31

Not installed
Not installed
Not installed
Not installed
Not installed
Google TV Intel x86 Atom System Image 31 Not installed
Google APIs ARM 64 v8a System Image 31 Not installed
Not installed

Not installed

Google APIs Intel x86 Atom_64 System Image 31
Google Play ARM 64 v8a System Image 31
Google Play Intel x86 Atom_64 System Image 31
Android 11.0 (R)
Android SDK Platform 30 30 3 Not installed
Saurces far Android 30 30 1 Not installed
v| Hide Obsolete Packages v/ Show Package Details

00 00 0 00 WNNW-= =

Not installed

Cancel Apply

ii.


https://developer.android.com/studio

Appearance & Behavior > System Settings *> Android SDK

Manager for the Android SDK and Tools used by the IDE

Android SDK Location: | /Users/rajatverma/Library/Android/sdk

SDK Platforms SDK Tools SDK Update Sites

Below are the available SDK developer tools. Once installed, the IDE will automatically check
for updates. Check "show package details" to display available versions of an SDK Tool.

Name Version Status

¥| Android SDK Build-Tools 32 Installed
NDK (Side by side) Not Installed
Android SDK Command-line Tools (latest) Not Installed
CMake Not Installed
Android Auto API Simulators Not installed
Android Auto Desktop Head Unit Emulator . Not installed
Android Emulator Installed
Android SDK Platform-Tools Installed
Google Play APK Expansion library Not installed
Google Play Instant Development SDK Not installed
Google Play Licensing Library Not installed
Google Play services Not installed
Google Web Driver Not installed
Intel x86 Emulator Accelerator (HAXM installer) Not installed
Layout Inspector image server for API 29-30 Not installed
Layout Inspector image server for API S Not installed

¥| Hide Obsolete Packages Show Package Details

iii. Cancel Apply
iv..  Click on Apply
d. To install Intel HAXM:
i.  Terminal -> brew install intel-haxm
ii.  This is required only for Intel processor
iii. [ have MacBook Air with M1 chip, so no need for this
Set Environment Variables
a. Terminal ->
i.  Navigate to home directory: ed ~/
ii.  Create zprofile file: touch .zprofile
iii. ~ Open zprofile file: open -e .zprofile
1. Add below entries:
a. export JAVA_HOME=$(/usr/libexec/java_home)
Important note: If above path doesn't work, try
/Library/Java/JavaVirtualMachines/your_jdk_version/Conte
nts/Home
Here, your_jdk_version can be jdk15.0.2.jdk for example.
b. export ANDROID_HOME=${HOME}/Library/Android/sdk



c. export
PATH="${JAVA_HOME}/bin:${ANDROID_HOME}/tools:${A
NDROID_HOME}/platform-tools:${PATH}"

2. Close this file to save
iv.  source .zprofile
b. Verify setup using below commands
i. echo $JAVA_HOME
ii. =~ echo $ANDROID_HOME
iii. = echo $PATH
Check Appium setup for Android
a. Terminal ->
i. appium-doctor --android
Emulator setup: Create AVD and start it
a. AVD - Android Virtual Device
b. Open Android Studio
i.  More actions -> AVD Manager
1. Category -> Phone
2. Name -> Pixel 3 -> Next
3. System Image -> Select Latest
c. AVD name: Pixel 3
Go to:
https://github.com/appium/appium/blob/master/sample-code/apps/ApiDemos-d
ebug.apk
Start Appium server
f.  Start Appium Inspector:


https://github.com/appium/appium/blob/master/sample-code/apps/ApiDemos-debug.apk
https://github.com/appium/appium/blob/master/sample-code/apps/ApiDemos-debug.apk

Appium Server Select Cloud Providers

Remote Host

Remote Path  fwd/hub

> Advanced Settings

Desired Capabilities Saved Capability Sets 2 Attach to Session...

platformName text
appium:deviceName text
appium:automationName text
appium:udid text
appium:app text

Automatically add necessary Appium vendor prefixes on start

L.

» Desired Capabilities Documentation

g. To get the udid (Unique Identifier):

i. Terminal -> adb devices

h.

android

Pixel 3

UlAutomator2

emulator-5554

IUsersrajatverma/Desktop,

+ o o o o o

Remote Port

JSON Representation

I

“platfornName": “android",
“appium:deviceName": "Pixel 3",
“appium:automationName": "UIAutomator2",
“appium:udid": “emulator-5554",
“appium:app": "/Users/rajatverma/Desktop/Work/OtherApps/ApiDenos-debug. apk"

Save As... Start Session

========Appium setup on Mac - Android - END==========




