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The following guide will explain how to take a model from any 3D program and placing it in an empty 

scene. It will also explain the principles behind collision models, lightmap models and level of detail 

models. This guide can be used for any Mafia version. 

What do you need? 

 A 3D modelling tool with a 3D model you want to export (obviously) 

 Zmodeler 1.07b (Download: http://mafiascene.com/modules.php?name=downloads&action=get_download&id=63) 

 Mafia World Editor v0.3.1 (Download: 

http://mafiascene.com/modules.php?name=downloads&action=get_download&id=124)  
 Clear Mission (Download: http://mafiascene.com/modules.php?name=downloads&action=get_download&id=126) 

 DCED (Download: http://mafiascene.com/modules.php?name=downloads&action=get_download&id=123)  

 Mafia Data Xtractor (Download: http://mafiascene.com/modules.php?name=downloads&action=get_download&id=54 

Or http://mafiascene.com/modules.php?name=downloads&action=get_download&id=55)  
 4ds Manager (Download: http://mafiascene.com/modules.php?name=downloads&action=get_download&id=125)  

 
You’ll need to be logged in on Mafiascene.com in order to download this. 
 
So, let’s begin! 
 

1. If you have a clean installation of Mafia, open up the Mafia Data Xtractor and it will pop up a 
message asking if you want to patch the RWdata.dll. Choose Yes and close the tool. 

2. Within the Mafia directory, create a folder named “Missions” and within this folder, another 
subfolder named “Intro” so you can navigate to Mafia/Missions/Intro 

3. Put the contents from within the Clear mission file within the Intro folder. Make sure you 
don’t copy any folders from the clear mission file. All files need to be copied without the root 
folder. 

4. If you now open up Mafia and choose Intro from the main menu, and empty scene will load 
with some Freeride instructions. Because the empty mission is made for Freeride City small, 
we’ll have to add a player character first before we can move in this mission. 

5. Open up the scene2.bin file that is located within the Intro folder using DCED. 
6. Click on the “add object” button. From the window that pops up, fill in as the object name 

“Tommy” and click on “Model Object” under the Objects tab. 
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Within the properties window, set the position, rotation and additional values all to 0 and set the 
scaling on all axes to 1. Under the model tab, fill in “Tommy.i3d”. This is the object of Tommy. 
IMPORTANT RULE: Even though Mafia uses .4ds models, they are all addressed as .i3d models 
within any editing software. NEVER fill in an object name with a .4ds extension or it could crash the 
game. 
 
As the sector, fill in “Primary Sector”. This is the scene’s default sector. If there are more sectors 
within the scene you can enter those as well but I won’t go into that area in this tutorial. 
 
Congratulations! You have inserted your first 3D model into the scene! But, you will notice if you load 
the scene that you still cannot walk. We need to give the model it’s playable character properties. 
You can do this in DCED. Again click on the Add Object button. This time, click on the “Object 
Definitions” tab and click on “Player”. Again, name the object “Tommy”. DCED will automatically link 
object definitions to objects that have matching names. 
 
Save your scene. If you load the game, you can now see an animated character that you can control. 
However, you have zero health and you are unable to move. Go back to DCED and double click on 
the object definition of Tommy.  
 

 
 



Be aware, DCED usually becomes very unstable while modifying these values. Save occasionally 
and prepare for a high dose of frustration. To lighten the frustration, I’ve set in Windows to 
automatically open .bin files with DCED when double clicking on it so I don’t need to manually load 
the file every time. 
 
Within the values, enter 1 everywhere and for the health enter 100. 
Again, save the scene and close DCED. You’ll likely be greeted by one of those annoying errors. If it 
happens, open the scene in DCED again. You will notice that the name of the Tommy object 
definition is a scrambled mess. Rename this mess back to “Tommy” and save and quit. 
 
Now you should have a working character where you can walk around with, congrats! 
 
Now it’s time to move on to converting a model from your 3D tool to a .4ds file and placing it ingame. 
 

 
Firstly, open your 3D tool and load your 3D model you wish to convert for Mafia. Make the following 
alterations to fit these guidelines: 
 

1. Separate each material from a mesh that uses multiple materials. E.G. if you’ve made a road 
model using three textures, one for the asphalt, one for the sidewalk, and one for let’s say, a 
gutter. You’ll need to split all polygons from the road that are using the sidewalk texture and 
split all polygons that use the gutter texture so you’ll end up having three models with each 
only one texture and UV map applied to it; a model of asphalt, a model of a sidewalk, and a 
model of a gutter. 

2. Make sure all textures are in .bmp format and have no more than 7 characters in the title. So 
a texture named “City_Asphalt_08.bmp” must be renamed to something like “CAsp08.bmp”. 
Otherwise, Zmodeler won’t automatically import the textures. 

3. Also check if all of your textures are in a power of two format like 256X256 or 512X512. So no 
320X403 pixels. Non-power of two textures can cause issues later on. If you need to bulk 
resize multiple images you can download Djbozkosz’ bulk image converter from Mafia’s tools 
section. 

4. Keep the polycount of models that need to be lightmapped below 8000 polygons. Split any 
objects that exceed this by far. 

5. It’s adviced to do any scaling within your 3D tool since Zmodeller can only scale on two axes 
the same time. The easiest trick is extracting the models folder using the Mafia Data Xtractor 
and importing one of the game’s models into zmodeler and exporting it to .3ds from there to 
import in your 3D tool. Mafia uses the Metric system. Depending on which tool you are 
using, 1 cm is 1 meter in Mafia. 

 
After you’ve made sure your model meets these guidelines it is ready for export. Export the model in 
a .3ds format. This is the only format Zmodeler supports. Just for convenience of importing in 
Zmodeler, it is adviced to save the exported file within the same folder as where the textures are 
located. This makes it easier for Zmodeler to associate them with the model. 
 
Now open up Zmodeler and click on File>Import and import your .3ds model. If it gives a filter error 
message, just click yes. It’s harmless. Your model should now appear within the viewport unless it’s 
oversized or located away from the scene pivot. It is adviced to disable the fog effect since it will only 
ruin your view on how the model looks. You can do this by clicking on Options>3D View>Enable Fog. 
You may also enable or disable the wireframe by clicking on the small cube in the top left corner of 
the 3D view and going to Settings>Shade Fill>Wireframe>Enabled. 
  



In pretty much all cases, the model is either black, weird shaded, or even sometimes invisible upon 
importing. That’s because the materials are always improperly imported. So we need to correct 
these. 
Click on the red ball button or press “E” to pay respects to open the material editor. 
 

 
 

You’ll need to put the RGB & Shine slider to the max. The RGB values won’t affect the game but for 
good practice and easier viewing of the model it is advised to set them properly. 
The shine slider determines the visibility of the model. Putting it low will make it transparent and 
putting it to max will make it solid. If you are using any glow effects it needs to be set at max. If not, it 
can make the game crash. Always double check if it’s set at max since the slider can sometimes hang 
at around 95%. 
 
Then change the type from Glowing to Unused. Glowing is used to make materials transparent that 
use indexed colors like windows or alpha mapped objects. 
Another item in the list is color key. This makes the color black (0,0,0) appear transparent ingame. 
This one is recommended for alpha maps since it’s a lot easier to use. Although you can choose a 
different color for the color key effect, Mafia only supports pitch black color keying. 
 
If you want to apply an environment reflection map, just check the reflection map channel and load 
the texture you want to use for it. Keep the “Apply as:” function as “Light map”. 
 
After you’ve fixed all materials your model should now appear fine within the viewport. Maybe some 
transparent materials may not show up properly even if you set them up correctly, but that’s a 
Zmodeler bug. If the settings are correct it will show fine in Mafia. 
 
  



Lightmaps, Collisions, LOD’s 
 
There are three features that may be applicable to your model. For example if you are working on a 
road piece, it may need to be lightmapped within the game, serve as a collision for people and cars 
to walk or drive on, and may be visible in the distance. There are some quick preparations for all 
three features. 
 
Lightmaps 
As mentioned before, keep the polycount of an object that needs to be lightmapped as low as 
possible. NEVER merge loads of objects together with the intention to lightmap them all at once 
because that will result in a crash during the lightmap baking. That’s all there is to it. 
 
Collisions 
In Mafia you can generate collisions on an object’s polygons. A model for roads could therefore be 
used both for the visible representation and the collision mesh. Again, don’t overshoot the polycount 
of each object that needs to be collided. 
For objects that have complex shapes it is advised to create a separate lowpoly collision mesh 
without a material and use that for the collision generation. In Zmodeler, simply put the shine slider 
for the default material all the way to 0% so that any object without a material simply becomes 
invisible. 
A separate collision mesh may also be applicable for tight interiors where the player’s collision 
capsule would exceed the width of a doorway making the player unable to pass through in the game. 
In such case, a separate collision mesh is required with a broader doorway so that the player can pass 
through. 
 
LOD’s 
You can set various level of details for a model within Zmodeler if applicable. 
To do so, simply add a “:1” behind an object name and it will become visible after a certain distance 
ingame when the short distance models disappear.  
If your model doesn’t require an LOD, but you don’t want it to fade out in the distance, you’ll need to 
export your 3D model, then open it with the 4ds manager. 
 

 



Within the objects tab, click on your model. Then under the Geometry section, set the Lod ratio to 0. 
This will expand the object’s viewing distance to infinity. 
 
 
After you have made these changes your model is ready for export. 
Simply click on File>Export to export your model to a .4ds format. Complex models may take some 
time exporting, causing Zmodeler appear as if it’s frozen. 
 
After the export is complete, create two new folders within Mafia’s root directory named “Maps” 
and “Models”. Place your bitmaps within the maps folder and your models within the… you guessed 
it, models folder. 
 
 

Implementation 
 
Now your model is ready to be implemented ingame. Now we could use DCED for this, but there is a 
way better tool for it which is also visually based, called the Mafia World Editor. 
Install this editor in your Mafia root directory. Then open the intro mission with it. 
 
When the mission is loaded, click on Create>Model, and click in the viewport to place a model. A 
small window will pop up asking you to enter the object’s name. Give it a name and click on OK. The 
sector is per default set on “Primary Sector”. Again, click on OK. Lastly, enter the model filename. 
Remember! Enter .i3d as the file extension, not .4ds! 
 
The model is now spawned somewhere. To center its position, click on the location value within the 
property window and type in “0;0;0” to set it’s new coordinates. 
 

 
 

If you save your scene and load the game you’ll see your model ingame! 
 
To generate collisions or lightmaps, there are instructions included within the Mafia World Editor. It 
is quite basic. I’ve kept these instructions out since I want to focus this tutorial purely on the 
integration part and making a model “Mafia ready”. 
 
For any additional questions, feel free to make a topic on Mafiascene.com and I’ll try to assist you. 


