Skip to content

Commit

Permalink
pkgconf: revert commit causing issues with PKG_CONFIG_PATH
Browse files Browse the repository at this point in the history
Signed-off-by: Christopher Degawa <ccom@randomderp.com>
  • Loading branch information
1480c1 committed Sep 27, 2023
1 parent 99678f9 commit eb83999
Show file tree
Hide file tree
Showing 2 changed files with 30 additions and 3 deletions.
23 changes: 23 additions & 0 deletions mingw-w64-pkgconf/384ade5f316367f15da9dbf09853e06fe29bf2bf.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
From 384ade5f316367f15da9dbf09853e06fe29bf2bf Mon Sep 17 00:00:00 2001
From: Ariadne Conill <ariadne@dereferenced.org>
Date: Fri, 4 Aug 2023 08:24:32 +0000
Subject: [PATCH] path: prepend paths rather than append paths when processing
--with-path arguments

---
libpkgconf/path.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/libpkgconf/path.c b/libpkgconf/path.c
index e591298d..a48a226e 100644
--- a/libpkgconf/path.c
+++ b/libpkgconf/path.c
@@ -112,7 +112,7 @@ pkgconf_path_add(const char *text, pkgconf_list_t *dirlist, bool filter)
}
#endif

- pkgconf_node_insert_tail(&node->lnode, node, dirlist);
+ pkgconf_node_insert(&node->lnode, node, dirlist);
}

/*
10 changes: 7 additions & 3 deletions mingw-w64-pkgconf/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@ pkgbase=mingw-w64-${_realname}
pkgname="${MINGW_PACKAGE_PREFIX}-${_realname}"
epoch=1
pkgver=2.0.3
pkgrel=1
pkgrel=2
pkgdesc='pkg-config compatible utility which does not depend on glib'
url='https://github.com/pkgconf/pkgconf'
arch=('any')
Expand All @@ -19,11 +19,13 @@ groups=("${MINGW_PACKAGE_PREFIX}-toolchain")
source=("https://github.com/pkgconf/pkgconf/archive/refs/tags/$_realname-$pkgver.tar.gz"
0002-size-t-format.patch
0003-printf-format.patch
0004-default-pure-static.patch)
0004-default-pure-static.patch
384ade5f316367f15da9dbf09853e06fe29bf2bf.patch)
sha256sums=('d139baa5ea65e8bd9267f416c3bb88a91cf66f6bc84b1be0408cabfe886a4b3b'
'1db5975d6b1db946ba1d71cc3cf390dec567899a89d7ef53f56f24f0058cdbe3'
'a7efeef61b4af1c0813d9d8a211cde669a3e3fa2c97ed21e55487667769c567a'
'93a4aa1475122d16b6ac8a84f771e004e1a53e1df982d3dd069b262c9815ebb4')
'93a4aa1475122d16b6ac8a84f771e004e1a53e1df982d3dd069b262c9815ebb4'
'537b58772815bc04a4d2f51648f4e008e5172c9513ae2c684416eba744df725c')

prepare() {
mv "${_realname}-${_realname}-${pkgver}" "${_realname}-${pkgver}"
Expand All @@ -34,6 +36,8 @@ prepare() {

patch -p1 -i ${srcdir}/0002-size-t-format.patch
patch -p1 -i ${srcdir}/0003-printf-format.patch

patch -R -p1 -i ${srcdir}/384ade5f316367f15da9dbf09853e06fe29bf2bf.patch
}

build() {
Expand Down

0 comments on commit eb83999

Please sign in to comment.