Skip to content

Commit

Permalink
gis/proj: Updated for version 9.0.0
Browse files Browse the repository at this point in the history
- autotools phased out so using cmake instead
- patch to fix hardcoded mandir path and allow -DCMAKE_INSTALL_MANDIR
flag. Patch submitted upstream will be merged in the next version:
OSGeo/PROJ#3080

Signed-off-by: ArTourter <artourter@gmail.com>
  • Loading branch information
ArTourter committed Mar 2, 2022
1 parent fd486b1 commit ba7c8f5
Show file tree
Hide file tree
Showing 3 changed files with 34 additions and 25 deletions.
9 changes: 9 additions & 0 deletions gis/proj/fix_mandir.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,9 @@
diff -Naur proj-9.0.0/man/CMakeLists.txt proj-9.0.0-new/man/CMakeLists.txt
--- proj-9.0.0/man/CMakeLists.txt 2022-02-23 18:51:04.000000000 +0000
+++ proj-9.0.0-new/man/CMakeLists.txt 2022-03-02 16:22:14.979350892 +0000
@@ -6,4 +6,4 @@
man1/gie.1
man1/projinfo.1
man1/projsync.1
- DESTINATION share/man/man1)
+ DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)
44 changes: 22 additions & 22 deletions gis/proj/proj.SlackBuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
#!/bin/bash

# Slackware build script for proj
# Written by Kyle Guinn <elyk03@gmail.com>
# Originally written by Kyle Guinn <elyk03@gmail.com>
# Copyright 2014-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# Copyright 2021 Gregory J. L. Tourte <artourter@gmail.com>
# Copyright 2021-2022 Gregory J. L. Tourte <artourter@gmail.com>
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
Expand All @@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=proj
VERSION=${VERSION:-8.2.1}
VERSION=${VERSION:-9.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
Expand Down Expand Up @@ -74,27 +74,27 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--infodir=/usr/info \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--enable-shared \
--disable-static \
--build=$ARCH-slackware-linux

make
make install-strip DESTDIR=$PKG
patch -p1 < $CWD/fix_mandir.patch

mkdir -p build
( cd build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib${LIBDIRSUFFIX} \
-DCMAKE_INSTALL_MANDIR=/usr/man \
-DCMAKE_BUILD_TYPE=Release \
-DBUILD_TESTING=off \
..
make
make install/strip DESTDIR=$PKG
)

rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/*.la

Expand All @@ -103,7 +103,7 @@ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; r

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
AUTHORS COPYING ChangeLog INSTALL NEWS README \
AUTHORS CITATION COPYING ChangeLog INSTALL NEWS README README.md\
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

Expand Down
6 changes: 3 additions & 3 deletions gis/proj/proj.info
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
PRGNAM="proj"
VERSION="8.2.1"
VERSION="9.0.0"
HOMEPAGE="https://www.osgeo.org/projects/proj/"
DOWNLOAD="https://github.com/OSGeo/PROJ/releases/download/8.2.1/proj-8.2.1.tar.gz"
MD5SUM="03ed0375ba8c9dd245bdbbf40ed7a786"
DOWNLOAD="https://github.com/OSGeo/PROJ/releases/download/9.0.0/proj-9.0.0.tar.gz"
MD5SUM="180f9c60f74526690d059219fc7871e0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
Expand Down

0 comments on commit ba7c8f5

Please sign in to comment.