-
Notifications
You must be signed in to change notification settings - Fork 310
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
fix: Remove leveldb_store from stdlib_merkle_tree (AztecProtocol/barr…
- Loading branch information
Showing
9 changed files
with
10 additions
and
239 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1 @@ | ||
if(NOT WASM) | ||
link_libraries(leveldb) | ||
endif() | ||
add_subdirectory(proofs) |
42 changes: 0 additions & 42 deletions
42
barretenberg/cpp/src/aztec/stdlib/merkle_tree/CMakeLists.txt
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,43 +1 @@ | ||
barretenberg_module(stdlib_merkle_tree stdlib_primitives stdlib_blake3s stdlib_pedersen) | ||
|
||
if(NOT WASM) | ||
include(FetchContent) | ||
FetchContent_Declare( | ||
leveldb | ||
GIT_REPOSITORY https://github.com/google/leveldb.git | ||
GIT_TAG 1.22 | ||
FIND_PACKAGE_ARGS | ||
) | ||
|
||
# Disable some leveldb targets before we call FetchContent_MakeAvailable | ||
# so they are configured correctly if it needs to fetch | ||
set(LEVELDB_BUILD_TESTS OFF CACHE BOOL "LevelDB tests off") | ||
set(LEVELDB_BUILD_BENCHMARKS OFF CACHE BOOL "LevelDB benchmarks off") | ||
|
||
FetchContent_MakeAvailable(leveldb) | ||
|
||
if (leveldb_FOUND) | ||
# Globally installed leveldb needs Threads available as Threads::Threads as discovered by `find_package` | ||
find_package(Threads REQUIRED) | ||
|
||
foreach(target IN LISTS stdlib_merkle_tree_lib_targets stdlib_merkle_tree_exe_targets) | ||
target_link_libraries(${target} PRIVATE leveldb::leveldb) | ||
endforeach() | ||
else() | ||
# FetchContent_MakeAvailable calls FetchContent_Populate if `find_package` is unsuccessful | ||
# so these variables will be available if we reach this case | ||
set_property(DIRECTORY ${leveldb_SOURCE_DIR} PROPERTY EXCLUDE_FROM_ALL) | ||
set_property(DIRECTORY ${leveldb_BINARY_DIR} PROPERTY EXCLUDE_FROM_ALL) | ||
|
||
# Silence all compiler warnings from LevelDB | ||
target_compile_options( | ||
leveldb | ||
PRIVATE | ||
-w | ||
) | ||
|
||
foreach(target IN LISTS stdlib_merkle_tree_lib_targets stdlib_merkle_tree_exe_targets) | ||
target_link_libraries(${target} PRIVATE leveldb) | ||
endforeach() | ||
endif() | ||
endif() |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
105 changes: 0 additions & 105 deletions
105
barretenberg/cpp/src/aztec/stdlib/merkle_tree/leveldb_store.hpp
This file was deleted.
Oops, something went wrong.
1 change: 0 additions & 1 deletion
1
barretenberg/cpp/src/aztec/stdlib/merkle_tree/membership.test.cpp
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,3 @@ | ||
#include "leveldb_store.hpp" | ||
#include "merkle_tree.hpp" | ||
#include "membership.hpp" | ||
#include "memory_store.hpp" | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters