Skip to content

Commit

Permalink
oblogout: rebuild for Python 3.12
Browse files Browse the repository at this point in the history
  • Loading branch information
KF-Art committed Nov 13, 2023
1 parent 973a37f commit f89d04d
Show file tree
Hide file tree
Showing 2 changed files with 17 additions and 3 deletions.
13 changes: 13 additions & 0 deletions srcpkgs/oblogout/patches/deprecated-safeconfigparser-fix.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
diff --git a/oblogout/__init__.py b/oblogout/__init__.py
index 2202739..74115e5 100755
--- a/oblogout/__init__.py
+++ b/oblogout/__init__.py
@@ -190,7 +190,7 @@ class OpenboxLogout():
""" Load the configuration file and parse entries, when encountering a issue
change safe defaults """

- self.parser = configparser.SafeConfigParser()
+ self.parser = configparser.ConfigParser()
self.parser.read(config)

# Set some safe defaults
7 changes: 4 additions & 3 deletions srcpkgs/oblogout/template
Original file line number Diff line number Diff line change
@@ -1,19 +1,20 @@
# Template file for 'oblogout'
pkgname=oblogout
version=2021.06.26
revision=2
revision=3
wrksrc=oblogout-py3-master
conf_files="/etc/oblogout.conf"
build_style=python3-module
repository="cereus-extra"
makedepends="python3-distutils-extra intltool"
depends="python3-Pillow python3-cairo python3-gobject"
short_desc="Openbox Logout Menu, ported to Python 3"
maintainer="KF-Art <https://github.com/KF-Art>"
maintainer="Kevin Figueroa <kfdevart@disroot.org>"
license="GPL-2.0"
homepage="https://github.com/trizen/oblogout-py3"
distfiles="${homepage}/archive/refs/heads/master.zip"
checksum=e2ae4fdbc499fcb351d585666133abcff4cf0244e1cf46de42788c0401dac5ab

post_install() {
vinstall data/oblogout.conf 644 etc/
}
}

0 comments on commit f89d04d

Please sign in to comment.