-
Notifications
You must be signed in to change notification settings - Fork 25
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
Showing
3 changed files
with
46 additions
and
0 deletions.
There are no files selected for viewing
30 changes: 30 additions & 0 deletions
30
tests/ImportCommentsNoDuplicate/__snapshots__/ppsi.spec.ts.snap
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,30 @@ | ||
// Vitest Snapshot v1, https://vitest.dev/guide/snapshot.html | ||
|
||
exports[`import-comments-should-not-duplicate.ts - typescript-verify > import-comments-should-not-duplicate.ts 1`] = ` | ||
#!/usr/bin/env ts-node | ||
// ################################################ | ||
// ## Highlander comment: There can only be one! ## | ||
// ################################################ | ||
const someRandomGlobal = "stuff"; | ||
import * as fs from "fs"; | ||
import * as path from "path"; | ||
import shell from "shelljs"; | ||
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ | ||
#!/usr/bin/env ts-node | ||
// ################################################ | ||
// ## Highlander comment: There can only be one! ## | ||
// ################################################ | ||
import * as fs from "fs"; | ||
import * as path from "path"; | ||
import shell from "shelljs"; | ||
// ################################################ | ||
// ## Highlander comment: There can only be one! ## | ||
// ################################################ | ||
const someRandomGlobal = "stuff"; | ||
`; |
11 changes: 11 additions & 0 deletions
11
tests/ImportCommentsNoDuplicate/import-comments-should-not-duplicate.ts
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
#!/usr/bin/env ts-node | ||
// ################################################ | ||
// ## Highlander comment: There can only be one! ## | ||
// ################################################ | ||
|
||
const someRandomGlobal = "stuff"; | ||
|
||
import * as fs from "fs"; | ||
import * as path from "path"; | ||
import shell from "shelljs"; | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
import {run_spec} from '../../test-setup/run_spec'; | ||
|
||
run_spec(__dirname, ["typescript"], { | ||
importOrderParserPlugins : ['typescript'] | ||
}); |