-
Notifications
You must be signed in to change notification settings - Fork 25
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Browse files
Browse the repository at this point in the history
- Loading branch information
Showing
5 changed files
with
53 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
26 changes: 26 additions & 0 deletions
26
tests/ImportCommentsNoDuplicate/__snapshots__/ppsi.spec.ts.snap
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
// Vitest Snapshot v1, https://vitest.dev/guide/snapshot.html | ||
|
||
exports[`trailing-comments-on-interpreter.ts - typescript-verify > trailing-comments-on-interpreter.ts 1`] = ` | ||
#!/usr/bin/env ts-node | ||
// ################################################ | ||
// ## Highlander comment: There can only be one! ## | ||
// ################################################ | ||
const someRandomGlobal = "stuff"; | ||
import * as fs from "fs"; | ||
import * as path from "path"; | ||
import shell from "shelljs"; | ||
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ | ||
#!/usr/bin/env ts-node | ||
// ################################################ | ||
// ## Highlander comment: There can only be one! ## | ||
// ################################################ | ||
import * as fs from "fs"; | ||
import * as path from "path"; | ||
import shell from "shelljs"; | ||
const someRandomGlobal = "stuff"; | ||
`; |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
import {run_spec} from '../../test-setup/run_spec'; | ||
|
||
run_spec(__dirname, ["typescript"], { | ||
importOrderParserPlugins : ['typescript'] | ||
}); |
11 changes: 11 additions & 0 deletions
11
tests/ImportCommentsNoDuplicate/trailing-comments-on-interpreter.ts
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
#!/usr/bin/env ts-node | ||
// ################################################ | ||
// ## Highlander comment: There can only be one! ## | ||
// ################################################ | ||
|
||
const someRandomGlobal = "stuff"; | ||
|
||
import * as fs from "fs"; | ||
import * as path from "path"; | ||
import shell from "shelljs"; | ||
|