Skip to content

Commit

Permalink
Push up failing test for #87
Browse files Browse the repository at this point in the history
  • Loading branch information
fbartho committed May 16, 2023
1 parent 3c02cfa commit bbbf21c
Show file tree
Hide file tree
Showing 3 changed files with 42 additions and 0 deletions.
26 changes: 26 additions & 0 deletions tests/ImportCommentsNoDuplicate/__snapshots__/ppsi.spec.ts.snap
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
// Vitest Snapshot v1, https://vitest.dev/guide/snapshot.html

exports[`import-comments-should-not-duplicate.ts - typescript-verify > import-comments-should-not-duplicate.ts 1`] = `
#!/usr/bin/env ts-node
// ################################################
// ## Highlander comment: There can only be one! ##
// ################################################
const someRandomGlobal = "stuff";
import * as fs from "fs";
import * as path from "path";
import shell from "shelljs";
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
#!/usr/bin/env ts-node
// ################################################
// ## Highlander comment: There can only be one! ##
// ################################################
import * as fs from "fs";
import * as path from "path";
import shell from "shelljs";
const someRandomGlobal = "stuff";
`;
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
#!/usr/bin/env ts-node
// ################################################
// ## Highlander comment: There can only be one! ##
// ################################################

const someRandomGlobal = "stuff";

import * as fs from "fs";
import * as path from "path";
import shell from "shelljs";

5 changes: 5 additions & 0 deletions tests/ImportCommentsNoDuplicate/ppsi.spec.ts
Original file line number Diff line number Diff line change
@@ -0,0 +1,5 @@
import {run_spec} from '../../test-setup/run_spec';

run_spec(__dirname, ["typescript"], {
importOrderParserPlugins : ['typescript']
});

0 comments on commit bbbf21c

Please sign in to comment.