Skip to content

Commit

Permalink
ath79: support Ubiquiti Bullet M XW modded with 16MB Flash
Browse files Browse the repository at this point in the history
Signed-off-by: Lech Perczak <lech.perczak@gmail.com>
  • Loading branch information
Leo-PL committed Jan 30, 2024
1 parent b5fd4e4 commit ba40e73
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
46 changes: 46 additions & 0 deletions target/linux/ath79/dts/ar9342_ubnt_bullet-m-xw-16m.dts
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
// SPDX-License-Identifier: GPL-2.0-or-later OR MIT

#include "ar9342_ubnt_bullet-m-xw.dts"

/ {
model = "Ubiquiti Nanostation Loco M (XW) (16M)";
};


&spi {
status = "okay";

flash@0 {
partitions {
partition@50000 {
reg = <0x050000 0xf60000>;
};

/delete-node/ partition@7b0000;
partition@fb0000 {
label = "cfg";
reg = <0xfb0000 0x040000>;
read-only;
};

/delete-node/ partition@7f0000;
art: partition@ff0000 {
label = "art";
reg = <0xff0000 0x010000>;
read-only;

compatible = "nvmem-cells";
#address-cells = <1>;
#size-cells = <1>;

macaddr_art_0: macaddr@0 {
reg = <0x0 0x6>;
};

calibration_art_1000: calibration@1000 {
reg = <0x1000 0x440>;
};
};
};
};
};
9 changes: 9 additions & 0 deletions target/linux/ath79/image/generic-ubnt.mk
Original file line number Diff line number Diff line change
Expand Up @@ -36,6 +36,15 @@ define Device/ubnt_bullet-m-xw
endef
TARGET_DEVICES += ubnt_bullet-m-xw

define Device/ubnt_bullet-m-xw-16m
$(Device/ubnt_bullet-m-xw)
DEVICE_VARIANT := XW (16M)
DEVICE_ALT0_VARIANT := XW (16M)
SUPPORTED_DEVICES += ubnt,bullet-m-xw
IMAGE_SIZE := 15960k
endef
TARGET_DEVICES += ubnt_bullet-m-xw-16m

define Device/ubnt_edgeswitch-5xp
$(Device/ubnt-sw)
DEVICE_MODEL := EdgeSwitch 5XP
Expand Down

0 comments on commit ba40e73

Please sign in to comment.