Skip to content

Commit

Permalink
py-typing-extensions: updated to 4.10.0
Browse files Browse the repository at this point in the history
Release 4.10.0 (February 24, 2024)

This feature release adds support for PEP 728 (TypedDict with extra
items) and PEP 742 (``TypeIs``).

There are no changes since 4.10.0rc1.

Release 4.10.0rc1 (February 17, 2024)

- Add support for PEP 728, supporting the `closed` keyword argument and the
  special `__extra_items__` key for TypedDict. Patch by Zixuan James Li.
- Add support for PEP 742, adding `typing_extensions.TypeIs`. Patch
  by Jelle Zijlstra.
- Drop runtime error when a read-only `TypedDict` item overrides a mutable
  one. Type checkers should still flag this as an error. Patch by Jelle
  Zijlstra.
- Speedup `issubclass()` checks against simple runtime-checkable protocols by
  around 6% (backporting python/cpython#112717, by Alex
  Waygood).
- Fix a regression in the implementation of protocols where `typing.Protocol`
  classes that were not marked as `@runtime_checkable` would be unnecessarily
  introspected, potentially causing exceptions to be raised if the protocol had
  problematic members. Patch by Alex Waygood, backporting
  python/cpython#113401.
  • Loading branch information
adam committed Feb 25, 2024
1 parent 03f187e commit 141f6d4
Show file tree
Hide file tree
Showing 2 changed files with 6 additions and 6 deletions.
4 changes: 2 additions & 2 deletions devel/py-typing-extensions/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.20 2023/12/11 10:00:45 wiz Exp $
# $NetBSD: Makefile,v 1.21 2024/02/25 22:28:31 adam Exp $

DISTNAME= typing_extensions-4.9.0
DISTNAME= typing_extensions-4.10.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:S/_/-/}
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_PYPI:=t/typing-extensions/}
Expand Down
8 changes: 4 additions & 4 deletions devel/py-typing-extensions/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.18 2023/12/11 10:00:45 wiz Exp $
$NetBSD: distinfo,v 1.19 2024/02/25 22:28:31 adam Exp $

BLAKE2s (typing_extensions-4.9.0.tar.gz) = 52d735d43b4cc1cb8826aacd2c0d43a29bc048e349d843b9f5b567233ceb26bb
SHA512 (typing_extensions-4.9.0.tar.gz) = b4faea71d6d29b5d23f920c8865edc2a891887308aea984dbae0159b722da6ef0f4062e5d89bd96a0037391e91e87f213f789209dc1f8942e551979539d3ae11
Size (typing_extensions-4.9.0.tar.gz) = 74918 bytes
BLAKE2s (typing_extensions-4.10.0.tar.gz) = 2d5509fa4821f14073355c376bb0d16435ae1e7a12988d98d2f681570bb62cc0
SHA512 (typing_extensions-4.10.0.tar.gz) = d3d840719ed0cf1435a959f84a65df93f55fb4bfdda926cd74a34a8bb6ab0407108ee8941f40b6cb570e2f7c440abffb0bc1d0f0414814047de6e9c3eeb24093
Size (typing_extensions-4.10.0.tar.gz) = 77558 bytes

0 comments on commit 141f6d4

Please sign in to comment.