Skip to content

Commit

Permalink
(devel/R-pak) Updated 0.5.1 to 0.7.1
Browse files Browse the repository at this point in the history
# pak 0.7.1

* pak can now handle the case when `Config/Needs/*` dependencies
  are requested for package from a repository.

* pak uses safer `*printf()` format strings now.

# pak 0.7.0

* pak now correctly handles the latest GitHub release with
  the `@*release` notation (@pawelru,
  r-lib/pkgdepends#321)

* pak now correctly handles having multiple instances of the same
  package in the metadata, with different R version requirements
  (#534, #538, r-lib/pkgdepends#331).

* `git::` package references work better now for Azure DevOps
  (@jameslairdsmith, r-lib/pkgdepends#333,
  r-lib/pkgdepends#342).

* pak now does a better job at accepting installed packages, and
  avoids reinstalling more packages than needed when using a lock file
  (r-lib/actions#759,
  r-lib/pkgdepends#338).

# pak 0.6.0

* pak now requires R >= 3.5.0.

* Many improvements in system requirements support:
  - New functions:
    - `pkg_sysreqs()`: calculate system requirements of packages.
    - `sysreqs_db_list()`, `sysreqs_db_match()`, `sysreqs_db_update()`:
      query the system requirements database.
    - `sysreqs_list_system_packages()`, `sysreqs_check_installed()`,
      `sysreqs_fix_installed()`: query and install missing system packages.
    - `sysreqs_platforms()`: list supported platforms.
  - The installation proposal, printed before installation, now includes
    required and missing system packages, on supported platforms.
  - New `sysreqs_platform` configuration option to override the auto-detected
    platform.
  - Faster, asynchronous system requirements lookup.
  - pak now does not reinstall system requirements by default,
    if they are already installed. (You can force a reinstall/upgrade
    with the `sysreqs_update` configuration option.)

* New `gitlab::` package source to install packages from GitLab
  (r-lib/pkgdepends#315).

* pak now correctly parses multiple `git::` packages at once
  (r-lib/pkgdepends#318).

* `git::` package sources now support version 1 of the git protocol.
  E.g. the Bioconductor git repositories now work:
  `git::https://git.bioconductor.org/packages/limma`
  (r-lib/pkgdepends#314).

* The `platforms` config parameter now works correctly with `deps::`
  package sources (#522).

* New `include_linkingto` config parameter to always include `LinkingTo`
  packages in the solution, even for binaries
  (https://github.com/r-lib/pkgdepends/issues/485).

* `pkg_name_check()` now does not include Acromine results, because the web
  site was unstable.

* In `repo_add()` and `repo_resolve()` the `MRAN@` prefix is now deprecated
  and resolves to PPM, because MRAN will be retired soon. See more at
  <https://posit.co/blog/migrating-from-mran-to-posit-package-manager/>.

* The metadata cache now has `SystemRequirements` information for Bioconductor
  packages.
  • Loading branch information
mef committed Jan 21, 2024
1 parent 1d76d45 commit 2c84873
Show file tree
Hide file tree
Showing 2 changed files with 12 additions and 8 deletions.
12 changes: 8 additions & 4 deletions devel/R-pak/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.6 2023/08/15 01:21:16 mef Exp $
# $NetBSD: Makefile,v 1.7 2024/01/21 14:19:57 mef Exp $

R_PKGNAME= pak
R_PKGVER= 0.5.1
R_PKGVER= 0.7.1
CATEGORIES= devel

MAINTAINER= pkgsrc-users@NetBSD.org
Expand Down Expand Up @@ -29,15 +29,19 @@ DEPENDS+= R-jsonlite>=1.7.1:../../textproc/R-jsonlite
DEPENDS+= R-curl>=3.2:../../www/R-curl

# Packages suggested but not available:
# 'distro', 'pkgdepends', 'pkgsearch'
# 'pkgdepends', 'pkgsearch'
TEST_DEPENDS+= R-covr-[0-9]*:../../devel/R-covr
TEST_DEPENDS+= R-gitcreds-[0-9]*:../../security/R-gitcreds
TEST_DEPENDS+= R-mockery-[0-9]*:../../devel/R-mockery
TEST_DEPENDS+= R-pingr-[0-9]*:../../net/R-pingr
TEST_DEPENDS+= R-rstudioapi-[0-9]*:../../math/R-rstudioapi
TEST_DEPENDS+= R-testthat-[0-9]*:../../devel/R-testthat

USE_LANGUAGES= # none
USE_LANGUAGES= c

REPLACE_R+= src/library/cli/inst/examples/apps/*.R
REPLACE_R+= src/library/cli/exec/*.R

.include "../../math/R/Makefile.extension"
.include "../../www/curl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
8 changes: 4 additions & 4 deletions devel/R-pak/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.7 2023/06/18 14:17:58 mef Exp $
$NetBSD: distinfo,v 1.8 2024/01/21 14:19:57 mef Exp $

BLAKE2s (R/pak_0.5.1.tar.gz) = 48e16ae0636e75ad43869bb02912cc06caa5539eb86f76dacb5815e090779672
SHA512 (R/pak_0.5.1.tar.gz) = 909587ee3dd7bb2ec81a43c41a529004827dc3f694511517b4093bdb97281ce62b670b7f82dd5ea08140637789d38a33f02239db2ab089a01d17aaec8491eb6d
Size (R/pak_0.5.1.tar.gz) = 146787 bytes
BLAKE2s (R/pak_0.7.1.tar.gz) = f9c515e9e83b3c98f730f786e0f0f65bf0e04b0b6ff397623ca4e36309be6cc4
SHA512 (R/pak_0.7.1.tar.gz) = fc41fb17bd09ea1f3c7a691c52f07055cdabcd8198f20d2c3ce0780569b8e9c7c6770ecc6cbdbac1af72ac51ec5bc4232db6e0ec790efcfa94c3d9ceed739636
Size (R/pak_0.7.1.tar.gz) = 2022732 bytes

0 comments on commit 2c84873

Please sign in to comment.