Skip to content

Commit

Permalink
py-asyncssh: updated to 2.13.0
Browse files Browse the repository at this point in the history
Release 2.13.0 (27 Dec 2022)
----------------------------

* Updated testing and coverage to drop Python 3.6 and add Python 3.11.
  Thanks go to GitHub user hexchain for maintaining the GitHub workflows
  supporting this!

* Added new "recv_eof" option to not pass an EOF from a channel to a
  redirected target, allowing output from multiple SSH sessions to be
  sent and mixed with other direct output to that target. This is meant
  to be similar to the existing "send_eof" option which controls whether
  EOF on a redirect source is passed through to the SSH channel. Thanks
  go to Stuart Reynolds for inspiring this idea.

* Added new methods to make it easy to perform forwarding between TCP
  ports and UNIX domain sockets. Thanks go to Alex Rogozhnikov for
  suggesting this use case.

* Added a workaround for a problem seen on a Huawei SFTP server where
  it sends an invalid combination of file attribute flags. In cases where
  the flags are otherwise valid and the right amount of attribute data is
  available, AsyncSSH will ignore the invalid flags and proceed.

* Fixed an issue with copying files to SFTP servers that don't support
  random access I/O. The potential to trigger this failyre goes back
  several releases, but a change in AsyncSSH 2.12 made out-of-order writes
  much more likely. This fix returns AsyncSSH to its previous behavior
  where out-of-order writes are unlikely even when taking advantage of
  parallel reads. Thanks go to Patrik Lindgren and Stefan Walkner for
  reporting this issue and helping to identify the source of the problem.

* Fixed an issue when requesting remote port forwarding on a dynamically
  allocated port. Thanks go to Daniel Shimon for reporting this and
  proposing a fix.

* Fixed an issue where readexactly could block indefinitely when a signal
  is delivered in the stream before the requested number of bytes are
  available. Thanks go to Artem Bezborodko for reporting this and
  providing a fix.

* Fixed an interoperability issue with OpenSSH when using SSH certificates
  with RSA keys with a SHA-2 signature. Thanks go to Łukasz Siudut for
  reporting this.

* Fixed an issue with handling "None" in ProxyCommand, GlobalKnownHostsFile,
  and UserKnownHostsFile config file options. Thanks go to GitHub user
  dtrifiro for reporting this issue and suggesting a fix.
  • Loading branch information
adam committed Jan 11, 2023
1 parent aa0d8fd commit 3bc680f
Show file tree
Hide file tree
Showing 2 changed files with 6 additions and 6 deletions.
4 changes: 2 additions & 2 deletions security/py-asyncssh/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.34 2022/11/28 19:08:42 nia Exp $
# $NetBSD: Makefile,v 1.35 2023/01/11 12:04:08 adam Exp $

DISTNAME= asyncssh-2.12.0
DISTNAME= asyncssh-2.13.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= security python
MASTER_SITES= ${MASTER_SITE_PYPI:=a/asyncssh/}
Expand Down
8 changes: 4 additions & 4 deletions security/py-asyncssh/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.33 2022/08/18 16:45:30 adam Exp $
$NetBSD: distinfo,v 1.34 2023/01/11 12:04:08 adam Exp $

BLAKE2s (asyncssh-2.12.0.tar.gz) = 8113a199e8203c913a0a67ad1399e70efe1c4b9a5302ae6777228709554c3462
SHA512 (asyncssh-2.12.0.tar.gz) = b7772fc7fe0a0d101ce1542b8e149e265dde0fdc3e824936f7b2db799f7580bbda5128501a6d51e6090c071014bac96897c2787442c53e333aa38bb231d66ccf
Size (asyncssh-2.12.0.tar.gz) = 488045 bytes
BLAKE2s (asyncssh-2.13.0.tar.gz) = 5cce76f2811ba75fa49dd187cfd3331736427926ff619a95c12d99e4305f678b
SHA512 (asyncssh-2.13.0.tar.gz) = 7575e6da247355ca229fc534f594a587922c1f371a5eb922723715ec1fa56340a644b5b5f47160b258d78edb7c922943e897c07918c0d986af9673820069471f
Size (asyncssh-2.13.0.tar.gz) = 497171 bytes

0 comments on commit 3bc680f

Please sign in to comment.