-
Notifications
You must be signed in to change notification settings - Fork 161
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
Showing
10 changed files
with
101 additions
and
29 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
15 changes: 15 additions & 0 deletions
15
databases/mariadb105-client/patches/patch-include_mysql_service__encryption.h
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
$NetBSD: patch-include_mysql_service__encryption.h,v 1.1 2023/03/07 10:28:02 jperkin Exp $ | ||
|
||
SunOS always needs alloca.h. | ||
|
||
--- include/mysql/service_encryption.h.orig 2022-11-02 12:37:17.000000000 +0000 | ||
+++ include/mysql/service_encryption.h | ||
@@ -36,7 +36,7 @@ extern "C" { | ||
#endif | ||
#else | ||
#include <stdlib.h> | ||
-#ifdef HAVE_ALLOCA_H | ||
+#if defined(HAVE_ALLOCA_H) || defined(__sun) | ||
#include <alloca.h> | ||
#endif | ||
#endif |
16 changes: 16 additions & 0 deletions
16
databases/mariadb105-client/patches/patch-plugin_auth__pam_testing_pam__mariadb__mtr.c
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,16 @@ | ||
$NetBSD: patch-plugin_auth__pam_testing_pam__mariadb__mtr.c,v 1.1 2023/03/07 10:28:02 jperkin Exp $ | ||
|
||
pam_appl.h must come before pam_modules.h. | ||
|
||
--- plugin/auth_pam/testing/pam_mariadb_mtr.c.orig 2022-11-02 12:37:20.000000000 +0000 | ||
+++ plugin/auth_pam/testing/pam_mariadb_mtr.c | ||
@@ -10,8 +10,8 @@ | ||
|
||
#include <stdlib.h> | ||
#include <string.h> | ||
-#include <security/pam_modules.h> | ||
#include <security/pam_appl.h> | ||
+#include <security/pam_modules.h> | ||
|
||
#define N 3 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
14 changes: 14 additions & 0 deletions
14
databases/mariadb105-client/patches/patch-storage_columnstore_CMakeLists.txt
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,14 @@ | ||
$NetBSD: patch-storage_columnstore_CMakeLists.txt,v 1.1 2023/03/07 10:28:02 jperkin Exp $ | ||
|
||
Support SunOS. | ||
|
||
--- storage/columnstore/CMakeLists.txt.orig 2022-11-02 12:37:21.000000000 +0000 | ||
+++ storage/columnstore/CMakeLists.txt | ||
@@ -12,6 +12,7 @@ macro(APPEND_FOR_CPACK V) | ||
endmacro() | ||
|
||
IF(CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" OR | ||
+ CMAKE_SYSTEM_NAME STREQUAL "SunOS" OR | ||
CMAKE_SYSTEM_PROCESSOR STREQUAL "amd64") | ||
add_subdirectory(columnstore) | ||
|
15 changes: 15 additions & 0 deletions
15
databases/mariadb105-client/patches/patch-storage_rocksdb_CMakeLists.txt
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
$NetBSD: patch-storage_rocksdb_CMakeLists.txt,v 1.1 2023/03/07 10:28:02 jperkin Exp $ | ||
|
||
Support SunOS. | ||
|
||
--- storage/rocksdb/CMakeLists.txt.orig 2022-11-02 12:37:22.000000000 +0000 | ||
+++ storage/rocksdb/CMakeLists.txt | ||
@@ -32,7 +32,7 @@ ENDIF() | ||
|
||
# We've had our builders hang during the build process. This prevents MariaRocks | ||
# to be built on 32 bit intel OS kernels. | ||
-IF(CMAKE_SYSTEM_PROCESSOR MATCHES "i[36]86") | ||
+IF(CMAKE_SYSTEM_PROCESSOR MATCHES "i[36]86" AND NOT CMAKE_SYSTEM_NAME STREQUAL "SunOS") | ||
SKIP_ROCKSDB_PLUGIN("Intel 32 bit not supported.") | ||
ENDIF() | ||
|
14 changes: 14 additions & 0 deletions
14
databases/mariadb105-client/patches/patch-storage_tokudb_CMakeLists.txt
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,14 @@ | ||
$NetBSD: patch-storage_tokudb_CMakeLists.txt,v 1.1 2023/03/07 10:28:02 jperkin Exp $ | ||
|
||
Support SunOS. | ||
|
||
--- storage/tokudb/CMakeLists.txt.orig 2022-11-02 12:37:23.000000000 +0000 | ||
+++ storage/tokudb/CMakeLists.txt | ||
@@ -16,6 +16,7 @@ ELSEIF(PLUGIN_PERFSCHEMA MATCHES "^NO$") | ||
MESSAGE(STATUS "Performance Schema is required by TokuDB") | ||
RETURN() | ||
ELSEIF(CMAKE_SYSTEM_PROCESSOR STREQUAL "x86_64" OR | ||
+ CMAKE_SYSTEM_NAME STREQUAL "SunOS" OR | ||
CMAKE_SYSTEM_PROCESSOR STREQUAL "amd64") | ||
# tokudb requires F_NOCACHE or O_DIRECT, and designated initializers | ||
CHECK_CXX_SOURCE_COMPILES( |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters