Skip to content

Commit

Permalink
Update php-xdebug to 2.7.0.
Browse files Browse the repository at this point in the history
From Michael Moll via github.
Closes #43.

  [2019-03-06] ? Xdebug 2.7.0

      Fixed Bugs

      Fixed bug #1520: Xdebug does not handle variables and properties with
      "-" in their name
      Fixed bug #1577: Code coverage path analysis with chained catch fails
      in PHP 7.3
      Fixed bug #1639: Compile warning/error on GCC 8 or Clang due to "break
      intentionally missing"
      Fixed bug #1642: Debugger gives: "Warning: Header may not contain NUL
      bytes"
  [2019-02-15] ? Xdebug 2.7.0RC2

      Fixed Bugs

      Fixed bug #1551: Property with value null is not represented well
      Fixed bug #1621: Xdebug fails to compile cleanly on 32-bit platforms
      Fixed bug #1625: Work around ABI conflicts in PHP 7.3.0/PHP 7.3.1
      Fixed bug #1628: The PHP function name being constructed to record when
      GC Collection runs, is not freed
      Fixed bug #1629: SOAP Client/Server detection code does not handle
      inherited classes
  [2019-02-01] ? Xdebug 2.7.0rc1

      Fixed Bugs

      Fixed bug #1571: File/line information is not shown for closures in
      namespaces.
      Fixed bug #1578: Compile error due to redefinition of "zif_handler"
      with old GCCs.
      Fixed bug #1583: Xdebug crashes when OPcache's compact literals
      optimisation is on.
      Fixed bug #1598: Make path/branch coverage work with OPcache loaded for
      PHP 7.3 and later.
      Fixed bug #1620: Division by zero when GC Stats Collection runs with
      memory manager disabled.
  [2018-09-20] ? Xdebug 2.7.0beta1

      Improvements

      Fixed bug #1519: PHP 7.3 support (with a contribution by Christoph M.
      Becker)
  • Loading branch information
bsiegert committed Mar 16, 2019
1 parent dcd540b commit 4750445
Show file tree
Hide file tree
Showing 2 changed files with 8 additions and 8 deletions.
6 changes: 3 additions & 3 deletions devel/php-xdebug/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.21 2019/01/14 13:06:11 taca Exp $
# $NetBSD: Makefile,v 1.22 2019/03/16 07:58:59 bsiegert Exp $
#

MODNAME= xdebug
PECL_VERSION= 2.6.1
PECL_VERSION= 2.7.0
CATEGORIES= devel
MASTER_SITES= http://xdebug.org/files/
EXTRACT_SUFX= .tgz
Expand All @@ -14,7 +14,7 @@ LICENSE= php

PHP_ZEND_EXTENSION= yes

PHP_VERSIONS_ACCEPTED= 71 72
PHP_VERSIONS_ACCEPTED= 71 72 73

.include "../../lang/php/ext.mk"
.include "../../mk/bsd.pkg.mk"
10 changes: 5 additions & 5 deletions devel/php-xdebug/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.14 2018/09/23 18:41:46 taca Exp $
$NetBSD: distinfo,v 1.15 2019/03/16 07:58:59 bsiegert Exp $

SHA1 (php-xdebug/xdebug-2.6.1.tgz) = 1fa563ed82d89978bbc87c1cde6ccec6f053edea
RMD160 (php-xdebug/xdebug-2.6.1.tgz) = 961b2d6abdd8d235f9d30e93cdcd25ddcdacd083
SHA512 (php-xdebug/xdebug-2.6.1.tgz) = 31f26e592b3888d7cc74c6a7c51e0cc1151cf8a32100dda78098fb5b3e307cf8d0445b97247986c75b303a787f89b3937bc042dc52f19ca995753a6843bbd80b
Size (php-xdebug/xdebug-2.6.1.tgz) = 283961 bytes
SHA1 (php-xdebug/xdebug-2.7.0.tgz) = e0bc7a86df8c29aa6c597e982754da6bab4cbc51
RMD160 (php-xdebug/xdebug-2.7.0.tgz) = 0664ae992dee55aa7ab51f59a783049fa69f864a
SHA512 (php-xdebug/xdebug-2.7.0.tgz) = 501ae544bb9d13a30e9d327583890ecba36f3b6764683d095d4988cb9b205adc6fb8ca21cca666620907e25ff50c00a8033194327d5cb4f67015e8c6d9104c18
Size (php-xdebug/xdebug-2.7.0.tgz) = 230326 bytes

0 comments on commit 4750445

Please sign in to comment.