Skip to content

Commit

Permalink
chat/matrix-synapse: Update to 1.66.0
Browse files Browse the repository at this point in the history
packaging changes:
  - Depend on pydantic

summary of upstream changes:

Synapse 1.66.0 (2022-08-31)
===========================

This release removes the ability for homeservers to delegate email
ownership verification and password reset confirmation to identity
servers. This removal was originally planned for Synapse 1.64, but was
later deferred until now. See the [upgrade
notes](https://matrix-org.github.io/synapse/v1.66/upgrade.html#upgrading-to-v1660)
for more details.

Deployments with multiple workers should note that the direct TCP
replication configuration was deprecated in Synapse v1.18.0 and will
be removed in Synapse v1.67.0. In particular, the TCP `replication`
[listener](https://matrix-org.github.io/synapse/v1.66/usage/configuration/config_documentation.html#listeners)
type (not to be confused with the `replication` resource on the `http`
listener type) and the `worker_replication_port` config option will be
removed .

To migrate to Redis, add the [`redis`
config](https://matrix-org.github.io/synapse/v1.66/workers.html#shared-configuration),
then remove the TCP `replication` listener from config of the master
and `worker_replication_port` from worker config. Note that a HTTP
listener with a `replication` resource is still required. See the
[worker
documentation](https://matrix-org.github.io/synapse/v1.66/workers.html)
for more details.
Features
--------

- Improve validation of request bodies for the following client-server
  -API endpoints:
  -[`/account/password`](https://spec.matrix.org/v1.3/client-server-api/#post_matrixclientv3accountpassword),
  -[`/account/password/email/requestToken`](https://spec.matrix.org/v1.3/client-server
  -api/#post_matrixclientv3accountpasswordemailrequesttoken),
  -[`/account/deactivate`](https://spec.matrix.org/v1.3/client-server-api/#post_matrixclientv3accountdeactivate)
  -and
  -[`/account/3pid/email/requestToken`](https://spec.matrix.org/v1.3/client-server-api/#post_matrixclientv3account3pidemailrequesttoken). ([\#13188](matrix-org/synapse#13188),
  -[\#13563](matrix-org/synapse#13563))

- Add forgotten status to [Room Details Admin
  API](https://matrix-org.github.io/synapse/latest/admin_api/rooms.html#room-details-api).
  ([\#13503](matrix-org/synapse#13503))

- Add an experimental implementation for [MSC3852 (Expose user agents
  on `Device`)](https://github.com/matrix-org/matrix-spec-proposals/pu
  ll/3852). ([\#13549](matrix-org/synapse#13549))

- Add `org.matrix.msc2716v4` experimental room version with updated
  content fields. Part of [MSC2716 (Importing
  history)](matrix-org/matrix-spec-proposals#2716).
  ([\#13551](matrix-org/synapse#13551))

- Add support for compression to federation
  responses. ([\#13537](matrix-org/synapse#13537))

- Improve performance of sending messages in rooms with thousands of
  local
  users. ([\#13522](matrix-org/synapse#13522),
  [\#13547](matrix-org/synapse#13547))
Deprecations and Removals
-------------------------

- Remove the ability for homeservers to delegate email ownership
  verification and password reset confirmation to identity
  servers. See [upgrade
  notes](https://matrix-org.github.io/synapse/v1.66/upgrade.html#upgrading-to-v1660)
  for more details.
  • Loading branch information
gdt committed Sep 4, 2022
1 parent 0b65fe1 commit 7faf2ab
Show file tree
Hide file tree
Showing 3 changed files with 13 additions and 7 deletions.
6 changes: 4 additions & 2 deletions chat/matrix-synapse/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.59 2022/09/04 12:24:21 gdt Exp $
# $NetBSD: Makefile,v 1.60 2022/09/04 14:16:29 gdt Exp $

DISTNAME= matrix-synapse-1.65.0
DISTNAME= matrix-synapse-1.66.0
CATEGORIES= chat
MASTER_SITES= ${MASTER_SITE_GITHUB:=matrix-org/}
GITHUB_PROJECT= synapse
Expand All @@ -15,8 +15,10 @@ LICENSE= apache-2.0
TOOL_DEPENDS+= ${PYPKGPREFIX}-poetry-[0-9]*:../../devel/py-poetry

# Dependencies as defined by synapse's build system (in theory):
# \todo Go over poetry.lock
DEPENDS+= ${PYPKGPREFIX}-asn1-modules>=0.0.7:../../security/py-asn1-modules
DEPENDS+= ${PYPKGPREFIX}-asn1>=0.1.9:../../security/py-asn1
DEPENDS+= ${PYPKGPREFIX}-pydantic>=1.9.1:../../devel/py-pydantic
DEPENDS+= ${PYPKGPREFIX}-attrs>=19.2.0:../../devel/py-attrs
DEPENDS+= ${PYPKGPREFIX}-bcrypt>=3.1.0:../../security/py-bcrypt
DEPENDS+= ${PYPKGPREFIX}-bleach>=1.4.3:../../www/py-bleach
Expand Down
6 changes: 5 additions & 1 deletion chat/matrix-synapse/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.30 2022/09/04 10:57:20 gdt Exp $
@comment $NetBSD: PLIST,v 1.31 2022/09/04 14:16:29 gdt Exp $
bin/export_signing_key
bin/generate_config
bin/generate_log_config
Expand Down Expand Up @@ -627,6 +627,8 @@ ${PYSITELIB}/synapse/rest/client/login.py
${PYSITELIB}/synapse/rest/client/login.pyc
${PYSITELIB}/synapse/rest/client/logout.py
${PYSITELIB}/synapse/rest/client/logout.pyc
${PYSITELIB}/synapse/rest/client/models.py
${PYSITELIB}/synapse/rest/client/models.pyc
${PYSITELIB}/synapse/rest/client/mutual_rooms.py
${PYSITELIB}/synapse/rest/client/mutual_rooms.pyc
${PYSITELIB}/synapse/rest/client/notifications.py
Expand Down Expand Up @@ -723,6 +725,8 @@ ${PYSITELIB}/synapse/rest/media/v1/thumbnailer.py
${PYSITELIB}/synapse/rest/media/v1/thumbnailer.pyc
${PYSITELIB}/synapse/rest/media/v1/upload_resource.py
${PYSITELIB}/synapse/rest/media/v1/upload_resource.pyc
${PYSITELIB}/synapse/rest/models.py
${PYSITELIB}/synapse/rest/models.pyc
${PYSITELIB}/synapse/rest/synapse/__init__.py
${PYSITELIB}/synapse/rest/synapse/__init__.pyc
${PYSITELIB}/synapse/rest/synapse/client/__init__.py
Expand Down
8 changes: 4 additions & 4 deletions chat/matrix-synapse/distinfo
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.43 2022/09/04 12:24:21 gdt Exp $
$NetBSD: distinfo,v 1.44 2022/09/04 14:16:29 gdt Exp $

BLAKE2s (matrix-synapse-1.65.0.tar.gz) = 83fc2900b2ea7c315e59b63095466906ab2fe0a9bf96c21256f6ec27c58c3ba6
SHA512 (matrix-synapse-1.65.0.tar.gz) = 3ba9751f707d41a9e18d9fe63f9652c36712451d42953e2bd4add8c142418a2a47a2ce75da893832af9225b944dd7b275f6d744f6e70d468b7f143dd5ccb9137
Size (matrix-synapse-1.65.0.tar.gz) = 7895758 bytes
BLAKE2s (matrix-synapse-1.66.0.tar.gz) = 3614c25e642c70c727505d04c8d5685d7d57c0be27e112c5422c74c852dce5e2
SHA512 (matrix-synapse-1.66.0.tar.gz) = ebe8ab787d72592b395226490414f7dce5c250173be654dc6ce63deec3a7d718f8400cdc81dfb73ae331632bed4dfb5c6f09c64538f4bda8546db8fb75d728b7
Size (matrix-synapse-1.66.0.tar.gz) = 7916982 bytes
SHA1 (patch-pyproject.toml) = 54f1ff3696bc7e1a873fde2347f8d5c8ef5df68d
SHA1 (patch-synapse_handlers_room.py) = f9a62add7171898ec0ea76360f0a4c9969609537

0 comments on commit 7faf2ab

Please sign in to comment.