Skip to content

Commit

Permalink
sysutils/fd-find: update to 8.3.1
Browse files Browse the repository at this point in the history
v8.3.1

Bugfixes
- Stop implying --no-ignore-parent when --no-vcs-ignore is supplied,
  see #907, #901, #908 (@tmccombs)
- fd no longer waits for the whole traversal if the only matches arrive within
  max_buffer_time, see #868 and #895 (@tavianator)
- --max-results=1 now immediately quits after the first result, see #867
- fd -h does not panic anymore when stdout is closed, see #897

Changes
- Disable jemalloc on FreeBSD, see #896 (@xanderio)
- Updated man page, see #912 (@rlue)
- Updated zsh completions, see #932 (@tmccombs)


v8.3.0

Performance improvements
- Colorized output is now significantly faster, see #720 and #853 (@tavianator)
- Writing to stdout is now buffered if the output does not go to a TTY. This
  increases performance when the output of fd is piped to another program or to
  a file, see #885 (@tmccombs, original implementation by @sourlemon207)
- File metadata is now cached between the different filters that require it
  (e.g. --owner, --size), reducing the number of stat syscalls when multiple
  filters are used; see #863 (@tavianator, original implementation by @alexmaco)

Features
- Don't buffer command output from --exec when using a single thread. See #522
- Add new -q, --quiet flag, see #303 (@Asha20)
- Add new --no-ignore-parent flag, see #787 (@will459)
- Add new --batch-size flag, see #410 (@devonhollowood)
- Add opposing command-line options, see #595 (@Asha20)
- Add support for more filesystem indicators in LS_COLORS, see
  sharkdp/lscolors#35 (@tavianator)

Bugfixes
- Always show the ./ prefix for search results unless the output is a TTY or
  --strip-cwd-prefix is set, see #760 and #861 (@jcaplan)
- Set default path separator to / in MSYS, see #537 and #730 (@aswild)
- fd cannot search files under a RAM disk, see #752
- fd doesn't show substituted drive on Windows, see #365
- Properly handle write errors to devices that are full, see #737
- Use local time zone for time functions (--change-newer-than,
  --change-older-than`), see #631 (@jacobmischka)
- Support --list-details on more platforms (like BusyBox), see #783
- The filters --owner, --size, and --changed-{within,before} now apply to
  symbolic links themselves, rather than the link target, except when
  --follow is specified; see #863
- Change time comparisons to be exclusive, see #794 (@jacobmischka)

Changes
- Apply custom --path-separator to commands run with --exec(-batch) and
  --list-details, see #697 (@aswild)

Other
- Many documentation updates
  • Loading branch information
0323pin committed Jan 13, 2022
1 parent 4364352 commit 85a30e9
Show file tree
Hide file tree
Showing 3 changed files with 260 additions and 222 deletions.
8 changes: 3 additions & 5 deletions sysutils/fd-find/Makefile
Original file line number Diff line number Diff line change
@@ -1,12 +1,10 @@
# $NetBSD: Makefile,v 1.4 2020/12/08 07:14:47 pin Exp $
# $NetBSD: Makefile,v 1.5 2022/01/13 21:59:08 pin Exp $

DISTNAME= fd-find-8.2.1
DISTNAME= fd-find-8.3.1
CATEGORIES= sysutils
GITHUB_PROJECT= fd
MASTER_SITES= ${MASTER_SITE_GITHUB:=sharkdp/}
GITHUB_PROJECT= fd
GITHUB_TAG= v${PKGVERSION_NOREV}
DIST_SUBDIR= ${PKGBASE}
EXTRACT_USING= bsdtar

MAINTAINER= milan@petabyte.dev
HOMEPAGE= https://github.com/sharkdp/fd/
Expand Down
76 changes: 43 additions & 33 deletions sysutils/fd-find/cargo-depends.mk
Original file line number Diff line number Diff line change
@@ -1,61 +1,71 @@
# $NetBSD: cargo-depends.mk,v 1.1 2020/12/08 07:14:47 pin Exp $
# $NetBSD: cargo-depends.mk,v 1.2 2022/01/13 21:59:08 pin Exp $

CARGO_CRATE_DEPENDS+= aho-corasick-0.7.15
CARGO_CRATE_DEPENDS+= ansi_term-0.11.0
CARGO_CRATE_DEPENDS+= aho-corasick-0.7.18
CARGO_CRATE_DEPENDS+= ansi_term-0.12.1
CARGO_CRATE_DEPENDS+= anyhow-1.0.35
CARGO_CRATE_DEPENDS+= anyhow-1.0.52
CARGO_CRATE_DEPENDS+= atty-0.2.14
CARGO_CRATE_DEPENDS+= autocfg-1.0.1
CARGO_CRATE_DEPENDS+= bitflags-1.2.1
CARGO_CRATE_DEPENDS+= bstr-0.2.14
CARGO_CRATE_DEPENDS+= cc-1.0.66
CARGO_CRATE_DEPENDS+= cfg-if-0.1.10
CARGO_CRATE_DEPENDS+= bitflags-1.3.2
CARGO_CRATE_DEPENDS+= bstr-0.2.17
CARGO_CRATE_DEPENDS+= cc-1.0.72
CARGO_CRATE_DEPENDS+= cfg-if-1.0.0
CARGO_CRATE_DEPENDS+= clap-2.33.3
CARGO_CRATE_DEPENDS+= crossbeam-utils-0.8.1
CARGO_CRATE_DEPENDS+= ctrlc-3.1.7
CARGO_CRATE_DEPENDS+= chrono-0.4.19
CARGO_CRATE_DEPENDS+= clap-2.34.0
CARGO_CRATE_DEPENDS+= crossbeam-utils-0.8.5
CARGO_CRATE_DEPENDS+= ctrlc-3.2.1
CARGO_CRATE_DEPENDS+= diff-0.1.12
CARGO_CRATE_DEPENDS+= dirs-next-2.0.0
CARGO_CRATE_DEPENDS+= dirs-sys-next-0.1.1
CARGO_CRATE_DEPENDS+= filetime-0.2.13
CARGO_CRATE_DEPENDS+= dirs-sys-next-0.1.2
CARGO_CRATE_DEPENDS+= filetime-0.2.15
CARGO_CRATE_DEPENDS+= fnv-1.0.7
CARGO_CRATE_DEPENDS+= fs_extra-1.2.0
CARGO_CRATE_DEPENDS+= fuchsia-cprng-0.1.1
CARGO_CRATE_DEPENDS+= getrandom-0.1.15
CARGO_CRATE_DEPENDS+= globset-0.4.6
CARGO_CRATE_DEPENDS+= hermit-abi-0.1.17
CARGO_CRATE_DEPENDS+= humantime-2.0.1
CARGO_CRATE_DEPENDS+= ignore-0.4.17
CARGO_CRATE_DEPENDS+= getrandom-0.2.3
CARGO_CRATE_DEPENDS+= globset-0.4.8
CARGO_CRATE_DEPENDS+= hermit-abi-0.1.19
CARGO_CRATE_DEPENDS+= humantime-2.1.0
CARGO_CRATE_DEPENDS+= ignore-0.4.18
CARGO_CRATE_DEPENDS+= jemalloc-sys-0.3.2
CARGO_CRATE_DEPENDS+= jemallocator-0.3.2
CARGO_CRATE_DEPENDS+= lazy_static-1.4.0
CARGO_CRATE_DEPENDS+= libc-0.2.80
CARGO_CRATE_DEPENDS+= log-0.4.11
CARGO_CRATE_DEPENDS+= lscolors-0.7.1
CARGO_CRATE_DEPENDS+= memchr-2.3.4
CARGO_CRATE_DEPENDS+= nix-0.18.0
CARGO_CRATE_DEPENDS+= num_cpus-1.13.0
CARGO_CRATE_DEPENDS+= libc-0.2.112
CARGO_CRATE_DEPENDS+= log-0.4.14
CARGO_CRATE_DEPENDS+= lscolors-0.8.1
CARGO_CRATE_DEPENDS+= memchr-2.4.1
CARGO_CRATE_DEPENDS+= memoffset-0.6.4
CARGO_CRATE_DEPENDS+= nix-0.23.1
CARGO_CRATE_DEPENDS+= normpath-0.3.1
CARGO_CRATE_DEPENDS+= num-integer-0.1.44
CARGO_CRATE_DEPENDS+= num-traits-0.2.14
CARGO_CRATE_DEPENDS+= num_cpus-1.13.1
CARGO_CRATE_DEPENDS+= once_cell-1.9.0
CARGO_CRATE_DEPENDS+= proc-macro2-1.0.32
CARGO_CRATE_DEPENDS+= quote-1.0.10
CARGO_CRATE_DEPENDS+= rand-0.4.6
CARGO_CRATE_DEPENDS+= rand_core-0.3.1
CARGO_CRATE_DEPENDS+= rand_core-0.4.2
CARGO_CRATE_DEPENDS+= rdrand-0.4.0
CARGO_CRATE_DEPENDS+= redox_syscall-0.1.57
CARGO_CRATE_DEPENDS+= redox_users-0.3.5
CARGO_CRATE_DEPENDS+= regex-1.4.2
CARGO_CRATE_DEPENDS+= regex-syntax-0.6.21
CARGO_CRATE_DEPENDS+= redox_syscall-0.2.10
CARGO_CRATE_DEPENDS+= redox_users-0.4.0
CARGO_CRATE_DEPENDS+= regex-1.5.4
CARGO_CRATE_DEPENDS+= regex-syntax-0.6.25
CARGO_CRATE_DEPENDS+= remove_dir_all-0.5.3
CARGO_CRATE_DEPENDS+= same-file-1.0.6
CARGO_CRATE_DEPENDS+= strsim-0.8.0
CARGO_CRATE_DEPENDS+= syn-1.0.82
CARGO_CRATE_DEPENDS+= tempdir-0.3.7
CARGO_CRATE_DEPENDS+= term_size-0.3.2
CARGO_CRATE_DEPENDS+= test-case-1.2.1
CARGO_CRATE_DEPENDS+= textwrap-0.11.0
CARGO_CRATE_DEPENDS+= thread_local-1.0.1
CARGO_CRATE_DEPENDS+= unicode-width-0.1.8
CARGO_CRATE_DEPENDS+= thread_local-1.1.3
CARGO_CRATE_DEPENDS+= time-0.1.43
CARGO_CRATE_DEPENDS+= unicode-width-0.1.9
CARGO_CRATE_DEPENDS+= unicode-xid-0.2.2
CARGO_CRATE_DEPENDS+= users-0.11.0
CARGO_CRATE_DEPENDS+= vec_map-0.8.2
CARGO_CRATE_DEPENDS+= version_check-0.9.2
CARGO_CRATE_DEPENDS+= walkdir-2.3.1
CARGO_CRATE_DEPENDS+= wasi-0.9.0+wasi-snapshot-preview1
CARGO_CRATE_DEPENDS+= version_check-0.9.4
CARGO_CRATE_DEPENDS+= walkdir-2.3.2
CARGO_CRATE_DEPENDS+= wasi-0.10.2+wasi-snapshot-preview1
CARGO_CRATE_DEPENDS+= winapi-0.3.9
CARGO_CRATE_DEPENDS+= winapi-i686-pc-windows-gnu-0.4.0
CARGO_CRATE_DEPENDS+= winapi-util-0.1.5
Expand Down
Loading

0 comments on commit 85a30e9

Please sign in to comment.