Skip to content

Commit

Permalink
py-irclib: update to 20.4.0.
Browse files Browse the repository at this point in the history
v20.4.0
=======

Features
--------

- Replace deprecated ssl.wrap_socket with SSLContext.wrap_socket and update examples in connection.py docs. (#216)


v20.3.1
=======

No significant changes.


v20.3.0
=======

Features
--------

- Added support for SASL login. (#195)


Bugfixes
--------

- Better handling of escape sequences in message tags. (#205)


v20.2.0
=======

Features
--------

- Require Python 3.8 or later.


v20.1.1
=======

* #213: Pinned against jaraco.text 3.10 due to change in interface.

v20.1.0
=======

* #196: In irc.bot, avoid hanging idle when the first connection
  attempt fails.

v20.0.0
=======

* ``SingleServerIRCBot`` no longer accepts ``reconnection_interval``
  as a parameter.

* Added server support for NOTICE commands.

* Require Python 3.7 or later.

v19.0.1
=======

* #176: Fix issues with version number reporting. Restored version
  version number reporting in bot and client.

v19.0.0
=======

* ``irc.client`` no longer exposes a ``VERSION`` or ``VERSION_STRING``.
  To get the version, call ``importlib.metadata.version('irc')`` directly.

v18.0.0
=======

* Require Python 3.6 or later.

17.1
====

* Rely on
  `importlib_metadata <https://pypi.org/project/importlib_metadata/>`_
  for loading version from metadata. Removes implicit dependency on
  setuptools and pkg_resources.

* #158: The AsyncIO server now accepts a connection factory to
  enable features like SSL and IPv6 support.

* #155: ``SimpleIRCClient`` now has a ``dcc`` method for initiating
  and associating a DCCConnection object with the client.
  ``DCCConnection.listen`` now accepts a ``address`` parameter.
  Deprecated ``SimpleIRCClient.dcc_listen`` and
  ``SimpleIRCClient.dcc_connect`` in favor of the better separation
  of concerns. Clients should replace::

    client.dcc_connect(addr, port, type)
    client.dcc_listen(type)

  with::

    client.dcc(type).connect(addr, port)
    client.dcc(type).listen()


17.0
====

* Removed ``irc.buffer`` module, deprecated in 14.2.
* #153: Drop support for Python 3.3 and 2.7.

16.4
====

* Long Term Service release for Python 2.7.
* #149: ``AioConnection.connect`` moved to coroutine, added
  disconnect handling for AsyncIO.

16.3
====

* #140: Methods now use 'connection' and 'event' for parameter names.

* #135 via #144: Added AsyncIO implementation.

16.2.1
======

* Package refresh and cleanup.

16.2
====

* #133: In ``irc.server``, add support for ISON.

16.1
====

* #131: Add ``Connection.encode`` and ``Connection.transmit_encoding``
  to enable encodings other than UTF-8 to be used when transmitting
  text.

16.0
====

* Removed deprecated ``execute_*`` methods on ``Connection``
  and ``Reactor`` as introduced in 15.0.

* Fixed link in README.

15.1.1
======

* New ``send_items`` method takes star args for simplicity
  in the syntax and usage.

15.1
====

* Introduce ``ServerConnection.send_items``, consolidating
  common behavior across many methods previously calling
  ``send_raw``.

15.0.6
======

* Now publish `documentation <https://python-irc.readthedocs.io/>`_
  to Read The Docs.

15.0.5
======

* #119: Handle broken pipe exception in IRCClient _send() (server.py).

15.0.4
======

* #116: Correct invocation of execute_every.

15.0.3
======

* #115: Fix AttributeError in ``execute_at`` in scheduling
  support.

15.0.2
======

* #113: Use preferred scheduler in the bot implementation.

15.0.1
======

* Deprecated calls to Connection.execute_*
  and Reactor.execute_*. Instead, call the
  equivalently-named methods on the reactor's
  scheduler.

15.0
====

* The event scheduling functionality has been decoupled
  from the client.Reactor object. Now the reactor will
  construct a Scheduler from the scheduler_class property,
  which must be an instance of irc.schedule.IScheduler.

  The ``_on_schedule`` parameter is no longer accepted
  to the Reactor class. Implementations requiring a
  signal during scheduling should hook into the ``add``
  method of the relevant scheduler class.

* Moved the underlying scheduler implementation to
  `tempora <https://pypi.org/project/tempora>`_, allowing
  it to be re-used for other purposes.

14.2.2
======

* Issue #98: Add an ugly hack to force ``build_sphinx``
  command to have the requisite libraries to build
  module documentation.

14.2.1
======

* Issue #97: Restore ``irc.buffer`` module for
  compatibility.
* Issue #95: Update docs to remove missing or
  deprecated modules.
* Issue #96: Declare Gitter support as a badge in the
  docs.

14.2
====

* Moved buffer module to `jaraco.stream
  <https://pypi.python.org/pypi/jaraco.stream>`_ for
  use in other packages.

14.1
====

* ``SingleServerIRCBot`` now accepts a ``recon``
  parameter implementing a ReconnectStrategy. The new
  default strategy is ExponentialBackoff, implementing an
  exponential backoff with jitter.
  The ``reconnection_interval`` parameter is now deprecated
  but retained for compatibility. To customize the minimum
  time before reconnect, create a custom ExponentialBackoff
  instance or create another ReconnectStrategy object and
  pass that as the ``recon`` parameter. The
  ``reconnection_interval`` parameter will be removed in
  future versions.
* Issue #82: The ``ExponentialBackoff`` implementation
  now protects from multiple scheduled reconnects, avoiding
  the issue where reconnect attempts accumulate
  exponentially when the bot is immediately disconnected
  by the server.

14.0
====

* Dropped deprecated constructor
  ``connection.Factory.from_legacy_params``. Use the
  natural constructor instead.
* Issue #83: ``connection.Factory`` no longer attempts
  to bind before connect unless a bind address is specified.

13.3.1
======

* Now remove mode for owners, halfops, and admins when the user
  is removed from a channel.
* Refactored the Channel class implementation for cleaner, less
  repetitive code.
* Expanded tests coverage for Channel class.

13.3
====

* Issue #75: In ``irc.bot``, add support for tracking admin
  status (mode 'a') in channels. Use ``channel.is_admin``
  or ``channel.admins`` to identify admin users for a channel.

* Removed deprecated irc.logging module.

13.2
====

* Moved hosting to github.

13.1.1
======

* Issue #67: Fix infinite recursion for ``irc.strings.IRCFoldedCase``
  and ``irc.strings.lower``.

13.1
====

* Issue #64: ISUPPORT PREFIX now retains the order of
  permissions for each prefix.

13.0
====

* Updated ``schedule`` module to properly support timezone aware
  times and use them by default. Clients that rely on the timezone
  naïve datetimes may restore the old behavior by overriding the
  ``schedule.now`` and ``schedule.from_timestamp`` functions
  like so:

    schedule.from_timestamp = datetime.datetime.fromtimestamp
    schedule.now = datetime.datetime.now

  Clients that were previously patching
  ``schedule.DelayedCommand.now`` will need to instead patch
  the aforementioned module-global methods. The
  classmethod technique was a poor interface for effectively
  controlling timezone awareness, so was likely unused. Please
  file a ticket with the project for support with your client
  as needed.

12.4.2
======

* Bump to jaraco.functools 1.5 to throttler failures in Python 2.

12.4
====

* Moved ``Throttler`` class to `jaraco.functools
  <https://bitbucket.org/jaraco/jaraco.functools>`_ 1.4.

12.3
====

* Pull Request #33: Fix apparent escaping issue with IRCv3 tags.

12.2
====

* Pull Request #32: Add numeric for WHOX reply.
* Issue #62 and Pull Request #34: Add support for tags in message
  processing and ``Event`` class.

12.1.2
======

* Issue #59: Fixed broken references to irc.client members.
* Issue #60: Fix broken initialization of ``irc.server.IRCClient`` on
  Python 2.

12.1.1
======

* Issue #57: Better handling of Python 3 in testbot.py script.

12.1
====

* Remove changelog from package metadata.

12.0
====

* Remove dependency on jaraco.util. Instead depend on surgical packages.
* Deprecated ``irc.logging`` in favor of ``jaraco.logging``.
* Dropped support for Python 3.2.
  • Loading branch information
0-wiz-0 committed Apr 30, 2024
1 parent d600cd3 commit 9716985
Show file tree
Hide file tree
Showing 3 changed files with 39 additions and 38 deletions.
34 changes: 19 additions & 15 deletions net/py-irclib/Makefile
Original file line number Diff line number Diff line change
@@ -1,26 +1,30 @@
# $NetBSD: Makefile,v 1.19 2023/06/06 12:42:07 riastradh Exp $
# $NetBSD: Makefile,v 1.20 2024/04/30 13:22:13 wiz Exp $

DISTNAME= irc-11.1.1
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:S/irc/irclib/}
PKGREVISION= 1
CATEGORIES= net python
MASTER_SITES= ${MASTER_SITE_PYPI:=i/irc/}
EXTRACT_SUFX= .zip
EXTRACT_OPTS_ZIP= -aa -q -o
DISTNAME= irc-20.4.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:S/irc/irclib/}
CATEGORIES= net python
MASTER_SITES= ${MASTER_SITE_PYPI:=i/irc/}

MAINTAINER= imil@NetBSD.org
HOMEPAGE= http://python-irclib.sourceforge.net/
COMMENT= Internet Relay Chat (IRC) protocol client library
LICENSE= gnu-gpl-v2

USE_LANGUAGES= # none
TOOL_DEPENDS+= ${PYPKGPREFIX}-setuptools>=0:../../devel/py-setuptools
TOOL_DEPENDS+= ${PYPKGPREFIX}-setuptools_scm>=0:../../devel/py-setuptools_scm
TOOL_DEPENDS+= ${PYPKGPREFIX}-wheel>=0:../../devel/py-wheel
DEPENDS+= ${PYPKGPREFIX}-jaraco.collections>=0:../../devel/py-jaraco.collections
DEPENDS+= ${PYPKGPREFIX}-jaraco.text>=3.10:../../textproc/py-jaraco.text
DEPENDS+= ${PYPKGPREFIX}-jaraco.logging>=0:../../devel/py-jaraco.logging
DEPENDS+= ${PYPKGPREFIX}-jaraco.functools>=1.20:../../devel/py-jaraco.functools
DEPENDS+= ${PYPKGPREFIX}-jaraco.stream>=0:../../devel/py-jaraco.stream
DEPENDS+= ${PYPKGPREFIX}-pytz>=0:../../time/py-pytz
DEPENDS+= ${PYPKGPREFIX}-more-itertools>=0:../../devel/py-more-itertools
DEPENDS+= ${PYPKGPREFIX}-tempora>=1.6:../../time/py-tempora

DEPENDS+= ${PYPKGPREFIX}-six>=1.5.2:../../lang/py-six
DEPENDS+= ${PYPKGPREFIX}-jaraco_util>=10.0.2:../../devel/py-jaraco_util
TOOL_DEPENDS+= ${PYPKGPREFIX}-hgtools>=5:../../devel/py-hgtools
USE_LANGUAGES= # none

post-extract:
cd ${WRKSRC} && ${CHMOD} ${SHAREMODE} irc.egg-info/*
PYTHON_VERSIONS_INCOMPATIBLE= 27

.include "../../lang/python/egg.mk"
.include "../../lang/python/wheel.mk"
.include "../../mk/bsd.pkg.mk"
34 changes: 16 additions & 18 deletions net/py-irclib/PLIST
Original file line number Diff line number Diff line change
@@ -1,21 +1,21 @@
@comment $NetBSD: PLIST,v 1.7 2022/01/04 19:23:01 wiz Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
@comment $NetBSD: PLIST,v 1.8 2024/04/30 13:22:13 wiz Exp $
${PYSITELIB}/${WHEEL_INFODIR}/LICENSE
${PYSITELIB}/${WHEEL_INFODIR}/METADATA
${PYSITELIB}/${WHEEL_INFODIR}/RECORD
${PYSITELIB}/${WHEEL_INFODIR}/WHEEL
${PYSITELIB}/${WHEEL_INFODIR}/top_level.txt
${PYSITELIB}/irc/__init__.py
${PYSITELIB}/irc/__init__.pyc
${PYSITELIB}/irc/__init__.pyo
${PYSITELIB}/irc/bot.py
${PYSITELIB}/irc/bot.pyc
${PYSITELIB}/irc/bot.pyo
${PYSITELIB}/irc/buffer.py
${PYSITELIB}/irc/buffer.pyc
${PYSITELIB}/irc/buffer.pyo
${PYSITELIB}/irc/client.py
${PYSITELIB}/irc/client.pyc
${PYSITELIB}/irc/client.pyo
${PYSITELIB}/irc/client_aio.py
${PYSITELIB}/irc/client_aio.pyc
${PYSITELIB}/irc/client_aio.pyo
${PYSITELIB}/irc/connection.py
${PYSITELIB}/irc/connection.pyc
${PYSITELIB}/irc/connection.pyo
Expand All @@ -31,18 +31,16 @@ ${PYSITELIB}/irc/events.pyo
${PYSITELIB}/irc/features.py
${PYSITELIB}/irc/features.pyc
${PYSITELIB}/irc/features.pyo
${PYSITELIB}/irc/functools.py
${PYSITELIB}/irc/functools.pyc
${PYSITELIB}/irc/functools.pyo
${PYSITELIB}/irc/logging.py
${PYSITELIB}/irc/logging.pyc
${PYSITELIB}/irc/logging.pyo
${PYSITELIB}/irc/message.py
${PYSITELIB}/irc/message.pyc
${PYSITELIB}/irc/message.pyo
${PYSITELIB}/irc/modes.py
${PYSITELIB}/irc/modes.pyc
${PYSITELIB}/irc/modes.pyo
${PYSITELIB}/irc/rfc.py
${PYSITELIB}/irc/rfc.pyc
${PYSITELIB}/irc/rfc.pyo
${PYSITELIB}/irc/rfc2812.txt
${PYSITELIB}/irc/schedule.py
${PYSITELIB}/irc/schedule.pyc
${PYSITELIB}/irc/schedule.pyo
Expand All @@ -61,6 +59,6 @@ ${PYSITELIB}/irc/tests/test_bot.pyo
${PYSITELIB}/irc/tests/test_client.py
${PYSITELIB}/irc/tests/test_client.pyc
${PYSITELIB}/irc/tests/test_client.pyo
${PYSITELIB}/irc/tests/test_schedule.py
${PYSITELIB}/irc/tests/test_schedule.pyc
${PYSITELIB}/irc/tests/test_schedule.pyo
${PYSITELIB}/irc/tests/test_client_aio.py
${PYSITELIB}/irc/tests/test_client_aio.pyc
${PYSITELIB}/irc/tests/test_client_aio.pyo
9 changes: 4 additions & 5 deletions net/py-irclib/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.10 2021/10/26 11:06:38 nia Exp $
$NetBSD: distinfo,v 1.11 2024/04/30 13:22:13 wiz Exp $

BLAKE2s (irc-11.1.1.zip) = db6bd1cb6bff1fe0c4ea2e596c9b6470e3bf6ed1e239ea4f75b305d86320318e
SHA512 (irc-11.1.1.zip) = 30804737d9f7d760361c7cb739fb4ff87ceb6404be41d09fff4d9286bad6124f3fbd1568653282f3ee181b62e1083ba6dd68f9a72656307e1cd4f4146fa5878a
Size (irc-11.1.1.zip) = 121371 bytes
SHA1 (patch-setup.py) = beba108237c5fdc0cf72a64cee741d8924a7ee47
BLAKE2s (irc-20.4.0.tar.gz) = 2508e1e9192a95cbb7343135329c5ed65e533735885ac14fc1b41959b11e5317
SHA512 (irc-20.4.0.tar.gz) = ff75593cf9606c724232517c8340beb115ceda254acb5989c043bd0653f215b928b663570c98c27b845cc7431ea142514c85968e3e3b9bda0406ce799a2b1d2e
Size (irc-20.4.0.tar.gz) = 91215 bytes

0 comments on commit 9716985

Please sign in to comment.