Skip to content

Commit

Permalink
Update chat/matrix-synapse to 1.20.0
Browse files Browse the repository at this point in the history
Synapse 1.20.0 (2020-09-22)
===========================

No significant changes since v1.20.0rc5.

Removal warning
---------------

Historically, the [Synapse Admin
API](https://github.com/matrix-org/synapse/tree/master/docs) has been
accessible under the `/_matrix/client/api/v1/admin`,
`/_matrix/client/unstable/admin`, `/_matrix/client/r0/admin` and
`/_synapse/admin` prefixes. In a future release, we will be dropping support
for accessing Synapse's Admin API using the `/_matrix/client/*` prefixes. This
makes it easier for homeserver admins to lock down external access to the Admin
API endpoints.

Synapse 1.20.0rc5 (2020-09-18)
==============================

In addition to the below, Synapse 1.20.0rc5 also includes the bug fix that was included in 1.19.3.

Features
--------

- Add flags to the `/versions` endpoint for whether new rooms default to using E2EE. ([\#8343](matrix-org/synapse#8343))


Bugfixes
--------

- Fix rate limiting of federation `/send` requests. ([\#8342](matrix-org/synapse#8342))
- Fix a longstanding bug where back pagination over federation could get stuck if it failed to handle a received event. ([\#8349](matrix-org/synapse#8349))


Internal Changes
----------------

- Blacklist [MSC2753](matrix-org/matrix-spec-proposals#2753) SyTests until it is implemented. ([\#8285](matrix-org/synapse#8285))


Synapse 1.20.0rc4 (2020-09-16)
==============================

Synapse 1.20.0rc4 is identical to 1.20.0rc3, with the addition of the security fix that was included in 1.19.2.


Synapse 1.20.0rc3 (2020-09-11)
==============================

Bugfixes
--------

- Fix a bug introduced in v1.20.0rc1 where the wrong exception was raised when invalid JSON data is encountered. ([\#8291](matrix-org/synapse#8291))


Synapse 1.20.0rc2 (2020-09-09)
==============================

Bugfixes
--------

- Fix a bug introduced in v1.20.0rc1 causing some features related to notifications to misbehave following the implementation of unread counts. ([\#8280](matrix-org/synapse#8280))


Synapse 1.20.0rc1 (2020-09-08)
==============================

Removal warning
---------------

Some older clients used a [disallowed character](https://matrix.org/docs/spec/client_server/r0.6.1#post-matrix-client-r0-register-email-requesttoken) (`:`) in the `client_secret` parameter of various endpoints. The incorrect behaviour was allowed for backwards compatibility, but is now being removed from Synapse as most users have updated their client. Further context can be found at [\#6766](matrix-org/synapse#6766).

Features
--------

- Add an endpoint to query your shared rooms with another user as an implementation of [MSC2666](matrix-org/matrix-spec-proposals#2666). ([\#7785](matrix-org/synapse#7785))
- Iteratively encode JSON to avoid blocking the reactor. ([\#8013](matrix-org/synapse#8013), [\#8116](matrix-org/synapse#8116))
- Add support for shadow-banning users (ignoring any message send requests). ([\#8034](matrix-org/synapse#8034), [\#8092](matrix-org/synapse#8092), [\#8095](matrix-org/synapse#8095), [\#8142](matrix-org/synapse#8142), [\#8152](matrix-org/synapse#8152), [\#8157](matrix-org/synapse#8157), [\#8158](matrix-org/synapse#8158), [\#8176](matrix-org/synapse#8176))
- Use the default template file when its equivalent is not found in a custom template directory. ([\#8037](matrix-org/synapse#8037), [\#8107](matrix-org/synapse#8107), [\#8252](matrix-org/synapse#8252))
- Add unread messages count to sync responses, as specified in [MSC2654](matrix-org/matrix-spec-proposals#2654). ([\#8059](matrix-org/synapse#8059), [\#8254](matrix-org/synapse#8254), [\#8270](matrix-org/synapse#8270), [\#8274](matrix-org/synapse#8274))
- Optimise `/federation/v1/user/devices/` API by only returning devices with encryption keys. ([\#8198](matrix-org/synapse#8198))


Bugfixes
--------

- Fix a memory leak by limiting the length of time that messages will be queued for a remote server that has been unreachable. ([\#7864](matrix-org/synapse#7864))
- Fix `Re-starting finished log context PUT-nnnn` warning when event persistence failed. ([\#8081](matrix-org/synapse#8081))
- Synapse now correctly enforces the valid characters in the `client_secret` parameter used in various endpoints. ([\#8101](matrix-org/synapse#8101))
- Fix a bug introduced in v1.7.2 impacting message retention policies that would allow federated homeservers to dictate a retention period that's lower than the configured minimum allowed duration in the configuration file. ([\#8104](matrix-org/synapse#8104))
- Fix a long-standing bug where invalid JSON would be accepted by Synapse. ([\#8106](matrix-org/synapse#8106))
- Fix a bug introduced in Synapse v1.12.0 which could cause `/sync` requests to fail with a 404 if you had a very old outstanding room invite. ([\#8110](matrix-org/synapse#8110))
- Return a proper error code when the rooms of an invalid group are requested. ([\#8129](matrix-org/synapse#8129))
- Fix a bug which could cause a leaked postgres connection if synapse was set to daemonize. ([\#8131](matrix-org/synapse#8131))
- Clarify the error code if a user tries to register with a numeric ID. This bug was introduced in v1.15.0. ([\#8135](matrix-org/synapse#8135))
- Fix a bug where appservices with ratelimiting disabled would still be ratelimited when joining rooms. This bug was introduced in v1.19.0. ([\#8139](matrix-org/synapse#8139))
- Fix logging in via OpenID Connect with a provider that uses integer user IDs. ([\#8190](matrix-org/synapse#8190))
- Fix a longstanding bug where user directory updates could break when unexpected profile data was included in events. ([\#8223](matrix-org/synapse#8223))
- Fix a longstanding bug where stats updates could break when unexpected profile data was included in events. ([\#8226](matrix-org/synapse#8226))
- Fix slow start times for large servers by removing a table scan of the `users` table from startup code. ([\#8271](matrix-org/synapse#8271))


Updates to the Docker image
---------------------------

- Fix builds of the Docker image on non-x86 platforms. ([\#8144](matrix-org/synapse#8144))
- Added curl for healthcheck support and readme updates for the change. Contributed by @maquis196. ([\#8147](matrix-org/synapse#8147))


Improved Documentation
----------------------

- Link to matrix-synapse-rest-password-provider in the password provider documentation. ([\#8111](matrix-org/synapse#8111))
- Updated documentation to note that Synapse does not follow `HTTP 308` redirects due to an upstream library not supporting them. Contributed by Ryan Cole. ([\#8120](matrix-org/synapse#8120))
- Explain better what GDPR-erased means when deactivating a user. ([\#8189](matrix-org/synapse#8189))


Internal Changes
----------------

- Add filter `name` to the `/users` admin API, which filters by user ID or displayname. Contributed by Awesome Technologies Innovationslabor GmbH. ([\#7377](matrix-org/synapse#7377), [\#8163](matrix-org/synapse#8163))
- Reduce run times of some unit tests by advancing the reactor a fewer number of times. ([\#7757](matrix-org/synapse#7757))
- Don't fail `/submit_token` requests on incorrect session ID if `request_token_inhibit_3pid_errors` is turned on. ([\#7991](matrix-org/synapse#7991))
- Convert various parts of the codebase to async/await. ([\#8071](matrix-org/synapse#8071), [\#8072](matrix-org/synapse#8072), [\#8074](matrix-org/synapse#8074), [\#8075](matrix-org/synapse#8075), [\#8076](matrix-org/synapse#8076), [\#8087](matrix-org/synapse#8087), [\#8100](matrix-org/synapse#8100), [\#8119](matrix-org/synapse#8119), [\#8121](matrix-org/synapse#8121), [\#8133](matrix-org/synapse#8133), [\#8156](matrix-org/synapse#8156), [\#8162](matrix-org/synapse#8162), [\#8166](matrix-org/synapse#8166), [\#8168](matrix-org/synapse#8168), [\#8173](matrix-org/synapse#8173), [\#8191](matrix-org/synapse#8191), [\#8192](matrix-org/synapse#8192), [\#8193](matrix-org/synapse#8193), [\#8194](matrix-org/synapse#8194), [\#8195](matrix-org/synapse#8195), [\#8197](matrix-org/synapse#8197), [\#8199](matrix-org/synapse#8199), [\#8200](matrix-org/synapse#8200), [\#8201](matrix-org/synapse#8201), [\#8202](matrix-org/synapse#8202), [\#8207](matrix-org/synapse#8207), [\#8213](matrix-org/synapse#8213), [\#8214](matrix-org/synapse#8214))
- Remove some unused database functions. ([\#8085](matrix-org/synapse#8085))
- Add type hints to various parts of the codebase. ([\#8090](matrix-org/synapse#8090), [\#8127](matrix-org/synapse#8127), [\#8187](matrix-org/synapse#8187), [\#8241](matrix-org/synapse#8241), [\#8140](matrix-org/synapse#8140), [\#8183](matrix-org/synapse#8183), [\#8232](matrix-org/synapse#8232), [\#8235](matrix-org/synapse#8235), [\#8237](matrix-org/synapse#8237), [\#8244](matrix-org/synapse#8244))
- Return the previous stream token if a non-member event is a duplicate. ([\#8093](matrix-org/synapse#8093), [\#8112](matrix-org/synapse#8112))
- Separate `get_current_token` into two since there are two different use cases for it. ([\#8113](matrix-org/synapse#8113))
- Remove `ChainedIdGenerator`. ([\#8123](matrix-org/synapse#8123))
- Reduce the amount of whitespace in JSON stored and sent in responses. ([\#8124](matrix-org/synapse#8124))
- Update the test federation client to handle streaming responses. ([\#8130](matrix-org/synapse#8130))
- Micro-optimisations to `get_auth_chain_ids`. ([\#8132](matrix-org/synapse#8132))
- Refactor `StreamIdGenerator` and `MultiWriterIdGenerator` to have the same interface. ([\#8161](matrix-org/synapse#8161))
- Add functions to `MultiWriterIdGen` used by events stream. ([\#8164](matrix-org/synapse#8164), [\#8179](matrix-org/synapse#8179))
- Fix tests that were broken due to the merge of 1.19.1. ([\#8167](matrix-org/synapse#8167))
- Make `SlavedIdTracker.advance` have the same interface as `MultiWriterIDGenerator`. ([\#8171](matrix-org/synapse#8171))
- Remove unused `is_guest` parameter from, and add safeguard to, `MessageHandler.get_room_data`. ([\#8174](matrix-org/synapse#8174), [\#8181](matrix-org/synapse#8181))
- Standardize the mypy configuration. ([\#8175](matrix-org/synapse#8175))
- Refactor some of `LoginRestServlet`'s helper methods, and move them to `AuthHandler` for easier reuse. ([\#8182](matrix-org/synapse#8182))
- Fix `wait_for_stream_position` to allow multiple waiters on same stream ID. ([\#8196](matrix-org/synapse#8196))
- Make `MultiWriterIDGenerator` work for streams that use negative values. ([\#8203](matrix-org/synapse#8203))
- Refactor queries for device keys and cross-signatures. ([\#8204](matrix-org/synapse#8204), [\#8205](matrix-org/synapse#8205), [\#8222](matrix-org/synapse#8222), [\#8224](matrix-org/synapse#8224), [\#8225](matrix-org/synapse#8225), [\#8231](matrix-org/synapse#8231), [\#8233](matrix-org/synapse#8233), [\#8234](matrix-org/synapse#8234))
- Fix type hints for functions decorated with `@cached`. ([\#8240](matrix-org/synapse#8240))
- Remove obsolete `order` field from federation send queues. ([\#8245](matrix-org/synapse#8245))
- Stop sub-classing from object. ([\#8249](matrix-org/synapse#8249))
- Add more logging to debug slow startup. ([\#8264](matrix-org/synapse#8264))
- Do not attempt to upgrade database schema on worker processes. ([\#8266](matrix-org/synapse#8266), [\#8276](matrix-org/synapse#8276))
  • Loading branch information
Midar committed Sep 22, 2020
1 parent f1f44d3 commit b9a5c7d
Show file tree
Hide file tree
Showing 3 changed files with 18 additions and 11 deletions.
4 changes: 2 additions & 2 deletions chat/matrix-synapse/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.6 2020/09/18 23:18:39 js Exp $
# $NetBSD: Makefile,v 1.7 2020/09/22 21:21:51 js Exp $

DISTNAME= matrix-synapse-1.19.3
DISTNAME= matrix-synapse-1.20.0
CATEGORIES= chat
MASTER_SITES= ${MASTER_SITE_GITHUB:=matrix-org/}
EGG_NAME= matrix_synapse-${PKGVERSION_NOREV}
Expand Down
15 changes: 11 additions & 4 deletions chat/matrix-synapse/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1 2020/09/04 20:34:11 js Exp $
@comment $NetBSD: PLIST,v 1.2 2020/09/22 21:21:51 js Exp $
bin/export_signing_key
bin/generate_config
bin/generate_log_config
Expand Down Expand Up @@ -42,6 +42,9 @@ ${PYSITELIB}/synapse/api/errors.pyo
${PYSITELIB}/synapse/api/filtering.py
${PYSITELIB}/synapse/api/filtering.pyc
${PYSITELIB}/synapse/api/filtering.pyo
${PYSITELIB}/synapse/api/presence.py
${PYSITELIB}/synapse/api/presence.pyc
${PYSITELIB}/synapse/api/presence.pyo
${PYSITELIB}/synapse/api/ratelimiting.py
${PYSITELIB}/synapse/api/ratelimiting.pyc
${PYSITELIB}/synapse/api/ratelimiting.pyo
Expand Down Expand Up @@ -879,6 +882,9 @@ ${PYSITELIB}/synapse/rest/client/v2_alpha/room_upgrade_rest_servlet.pyo
${PYSITELIB}/synapse/rest/client/v2_alpha/sendtodevice.py
${PYSITELIB}/synapse/rest/client/v2_alpha/sendtodevice.pyc
${PYSITELIB}/synapse/rest/client/v2_alpha/sendtodevice.pyo
${PYSITELIB}/synapse/rest/client/v2_alpha/shared_rooms.py
${PYSITELIB}/synapse/rest/client/v2_alpha/shared_rooms.pyc
${PYSITELIB}/synapse/rest/client/v2_alpha/shared_rooms.pyo
${PYSITELIB}/synapse/rest/client/v2_alpha/sync.py
${PYSITELIB}/synapse/rest/client/v2_alpha/sync.pyc
${PYSITELIB}/synapse/rest/client/v2_alpha/sync.pyo
Expand Down Expand Up @@ -1364,14 +1370,18 @@ ${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/05cache_instance.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/06dlols_unique_idx.py
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/06dlols_unique_idx.pyc
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/06dlols_unique_idx.pyo
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/07persist_ui_auth_ips.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/08_media_safe_from_quarantine.sql.postgres
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/08_media_safe_from_quarantine.sql.sqlite
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/09shadow_ban.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/10drop_local_rejections_stream.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/10federation_pos_instance_name.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/11user_id_seq.py
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/11user_id_seq.pyc
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/11user_id_seq.pyo
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/12room_stats.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/13remove_presence_allow_inbound.sql
${PYSITELIB}/synapse/storage/databases/main/schema/delta/58/15unread_count.sql
${PYSITELIB}/synapse/storage/databases/main/schema/full_schemas/16/application_services.sql
${PYSITELIB}/synapse/storage/databases/main/schema/full_schemas/16/event_edges.sql
${PYSITELIB}/synapse/storage/databases/main/schema/full_schemas/16/event_signatures.sql
Expand Down Expand Up @@ -1465,9 +1475,6 @@ ${PYSITELIB}/synapse/storage/persist_events.pyo
${PYSITELIB}/synapse/storage/prepare_database.py
${PYSITELIB}/synapse/storage/prepare_database.pyc
${PYSITELIB}/synapse/storage/prepare_database.pyo
${PYSITELIB}/synapse/storage/presence.py
${PYSITELIB}/synapse/storage/presence.pyc
${PYSITELIB}/synapse/storage/presence.pyo
${PYSITELIB}/synapse/storage/purge_events.py
${PYSITELIB}/synapse/storage/purge_events.pyc
${PYSITELIB}/synapse/storage/purge_events.pyo
Expand Down
10 changes: 5 additions & 5 deletions chat/matrix-synapse/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.3 2020/09/18 23:18:39 js Exp $
$NetBSD: distinfo,v 1.4 2020/09/22 21:21:51 js Exp $

SHA1 (matrix-synapse-1.19.3.tar.gz) = 5c1abfc5dc2ba085509124c703ed7d6906c2d778
RMD160 (matrix-synapse-1.19.3.tar.gz) = 928906c029bfe3f530a980c28fe87e6936ec722b
SHA512 (matrix-synapse-1.19.3.tar.gz) = fd5d62024ace47b26ac646c5a57a2f6186bee89b1eb9402e02f4112d385dc8b97545e8c59444ea79d52c5dc9134f92c469738527dd8086e820d799db49baf6e7
Size (matrix-synapse-1.19.3.tar.gz) = 6778524 bytes
SHA1 (matrix-synapse-1.20.0.tar.gz) = 59499616a366c195dbef01ed455b0819849e087a
RMD160 (matrix-synapse-1.20.0.tar.gz) = f9a34c25c0b4b1a05200a7410fc891eee8bddacd
SHA512 (matrix-synapse-1.20.0.tar.gz) = 9aa6e74b7ad59ddb9423173eafbc94a4a1454301c0aa73a5a476e35a1dfaa1e7423f94849c830fa86d358e9b2f274bd16f2a5596143699d3db10a4222bc1f3c3
Size (matrix-synapse-1.20.0.tar.gz) = 6806325 bytes

0 comments on commit b9a5c7d

Please sign in to comment.