-
Notifications
You must be signed in to change notification settings - Fork 164
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
inkscape: fix build with poppler 22.03.0
- Loading branch information
Showing
2 changed files
with
26 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,7 +1,8 @@ | ||
$NetBSD: distinfo,v 1.87 2022/03/02 02:28:04 ryoon Exp $ | ||
$NetBSD: distinfo,v 1.88 2022/03/09 09:10:16 wiz Exp $ | ||
|
||
BLAKE2s (inkscape-1.1.2.tar.xz) = 4f7f3cad6faa377e25671a22bd156453b7d74cb7f0d8ecbc1e2ed6fcb2b540d3 | ||
SHA512 (inkscape-1.1.2.tar.xz) = 55884f34e6fcc604027e7ea60f67702a658d3838332c1f3b56ec2cb05ab44992df0651ed741d6e7e807848366b24ee7415d0908ed1143b0bfb33ddbf26ae5c16 | ||
Size (inkscape-1.1.2.tar.xz) = 34222832 bytes | ||
SHA1 (patch-CMakeScripts_DefineDependsandFlags.cmake) = 26351c300629e28f6523fe2167a2eed5802435cf | ||
SHA1 (patch-src_extension_implementation_script.cpp) = da46549f688da5c9c0ecbeaeac7962e4f261cae4 | ||
SHA1 (patch-src_extension_internal_pdfinput_pdf-input.cpp) = f3d7874690a099d6cdc47bf776caf6bb6c84cd44 |
24 changes: 24 additions & 0 deletions
24
graphics/inkscape/patches/patch-src_extension_internal_pdfinput_pdf-input.cpp
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,24 @@ | ||
$NetBSD: patch-src_extension_internal_pdfinput_pdf-input.cpp,v 1.6 2022/03/09 09:10:17 wiz Exp $ | ||
|
||
Fix build with poppler 22.03. | ||
https://gitlab.com/inkscape/inkscape/-/merge_requests/4116/diffs?commit_id=15ab83e02b07018c3ffd4952a2623393187659e0 | ||
|
||
--- src/extension/internal/pdfinput/pdf-input.cpp.orig 2022-02-05 01:21:47.000000000 +0000 | ||
+++ src/extension/internal/pdfinput/pdf-input.cpp | ||
@@ -666,10 +666,13 @@ PdfInput::open(::Inkscape::Extension::In | ||
// PDFDoc is from poppler. PDFDoc is used for preview and for native import. | ||
std::shared_ptr<PDFDoc> pdf_doc; | ||
|
||
- // poppler does not use glib g_open. So on win32 we must use unicode call. code was copied from | ||
- // glib gstdio.c | ||
+ | ||
+#if POPPLER_CHECK_VERSION(22, 3, 0) | ||
+ pdf_doc = std::make_shared<PDFDoc>(std::make_unique<GooString>(uri)); // TODO: Could ask for password | ||
+#else | ||
GooString *filename_goo = new GooString(uri); | ||
- pdf_doc = std::make_shared<PDFDoc>(filename_goo, nullptr, nullptr, nullptr); // TODO: Could ask for password | ||
+ pdf_doc = std::make_shared<PDFDoc>(filename_goo, nullptr, nullptr, nullptr); // TODO: Could ask for password | ||
+#endif | ||
|
||
if (!pdf_doc->isOk()) { | ||
int error = pdf_doc->getErrorCode(); |