-
Notifications
You must be signed in to change notification settings - Fork 164
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Pullup ticket #5849 - requested by bsiegert
devel/ncurses: security patch devel/ncursesw: security patch Revisions pulled up: - devel/ncurses/Makefile 1.100 - devel/ncurses/distinfo 1.35 - devel/ncurses/patches/patch-ncurses_tinfo_parse__entry.c 1.3 - devel/ncursesw/Makefile 1.17 ------------------------------------------------------------------- Module Name: pkgsrc Committed By: leot Date: Thu Oct 18 19:42:50 UTC 2018 Modified Files: pkgsrc/devel/ncurses: Makefile distinfo pkgsrc/devel/ncursesw: Makefile Added Files: pkgsrc/devel/ncurses/patches: patch-ncurses_tinfo_parse__entry.c Log Message: ncurses{,w}: Backport patch for CVE-2018-10754 Patch provided by Attila Fülöp via #34, thanks! Bump PKGREVISION To generate a diff of this commit: cvs rdiff -u -r1.99 -r1.100 pkgsrc/devel/ncurses/Makefile cvs rdiff -u -r1.34 -r1.35 pkgsrc/devel/ncurses/distinfo cvs rdiff -u -r0 -r1.3 \ pkgsrc/devel/ncurses/patches/patch-ncurses_tinfo_parse__entry.c cvs rdiff -u -r1.16 -r1.17 pkgsrc/devel/ncursesw/Makefile
- Loading branch information
Showing
4 changed files
with
29 additions
and
4 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,23 @@ | ||
$NetBSD: patch-ncurses_tinfo_parse__entry.c,v 1.3.2.2 2018/10/20 16:24:02 spz Exp $ | ||
|
||
- Fixes CVE-2018-10754 | ||
|
||
--- ncurses/tinfo/parse_entry.c.orig 2018-10-09 21:41:29.020445746 +0000 | ||
+++ ncurses/tinfo/parse_entry.c | ||
@@ -543,11 +543,12 @@ _nc_parse_entry(ENTRY * entryp, int lite | ||
* Otherwise, look for a base entry that will already | ||
* have picked up defaults via translation. | ||
*/ | ||
- for (i = 0; i < entryp->nuses; i++) | ||
- if (!strchr((char *) entryp->uses[i].name, '+')) | ||
- has_base_entry = TRUE; | ||
+ for (i = 0; i < entryp->nuses; i++) { | ||
+ if (entryp->uses[i].name != 0 | ||
+ && !strchr(entryp->uses[i].name, '+')) | ||
+ has_base_entry = TRUE; | ||
+ } | ||
} | ||
- | ||
postprocess_termcap(&entryp->tterm, has_base_entry); | ||
} else | ||
postprocess_terminfo(&entryp->tterm); |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters