Skip to content

Commit

Permalink
gopls: update to 0.15.1.
Browse files Browse the repository at this point in the history
0.15.1

This release fixes golang/go#65952, a crash in document highlighting when the cursor is in a return value for a function that has no results, such as the following example:

func f() { // <-- no results
   return 0| // <-- cursor at '|'
}

Thanks very much to @patrickpichler who both reported and fixed this bug!

We're hopeful that once Go 1.23 is released, the opt-in automated crash reporting added in gopls v0.15.0 will increase the likelihood that these types of crashes are caught before they are released.

0.15.0

This release introduces "zero config" gopls workspaces, which is a set of heuristics allowing gopls to Do The Right Thing when you open a Go file. We believe this addresses two of the largest pain points we hear about from our users: difficulty configuring multi-module repositories, and working on multiple GOOS/GOARCH combinations. However, this is a large change to the way gopls models your workspace, and the dynamic loading/unloading of builds may be surprising in some cases. Your feedback on this new feature is greatly appreciated. See below for more details.

New Features

Simpler workspace configuration and improved build tag support
Preview refactoring edits
Analysis & diagnostics
Automated crash reporting (off by default)
Housekeeping

and Bug Fixes.
  • Loading branch information
wiz committed Mar 3, 2024
1 parent b595086 commit eff7efb
Show file tree
Hide file tree
Showing 3 changed files with 91 additions and 156 deletions.
5 changes: 2 additions & 3 deletions devel/gopls/Makefile
Original file line number Diff line number Diff line change
@@ -1,10 +1,9 @@
# $NetBSD: Makefile,v 1.85 2024/02/07 14:50:48 bsiegert Exp $
# $NetBSD: Makefile,v 1.86 2024/03/03 11:39:22 wiz Exp $
#
# Release notes:
# https://github.com/golang/tools/releases

DISTNAME= gopls-0.14.2
PKGREVISION= 3
DISTNAME= gopls-0.15.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GITHUB:=golang/}
GITHUB_PROJECT= tools
Expand Down
Loading

0 comments on commit eff7efb

Please sign in to comment.