Skip to content

Commit

Permalink
fix(app-admin/yaml-vault): rewrite ebuild
Browse files Browse the repository at this point in the history
  • Loading branch information
SpiderX committed Jan 12, 2025
1 parent 26c37ab commit a246b9f
Show file tree
Hide file tree
Showing 5 changed files with 15 additions and 21 deletions.
3 changes: 1 addition & 2 deletions README.md
Original file line number Diff line number Diff line change
Expand Up @@ -98,7 +98,7 @@ This overlay consists of an [Gentoo Portage](https://www.gentoo.org/) ebuilds fo
* app-admin/[vcd-cli](https://github.com/vmware/vcd-cli) | Utility to check AWS resource limits and usage
* app-admin/[vector-bin](https://github.com/vectordotdev/vector) | High performance logs, metrics, and events router
* app-admin/[whatfiles](https://github.com/spieglt/whatfiles) | Log what files are accessed by any Linux process
* app-admin/[yaml-vault](https://github.com/Jimdo/yaml-vault) | Utility to import/export data from HashiCorp Vault
* app-admin/[yaml-vault](https://github.com/jimdo/yaml-vault) | Utility to import/export data from HashiCorp Vault
* app-backup/[clickhouse-backup](https://github.com/AlexAkulov/clickhouse-backup) | Tool for easy ClickHouse backup and restore
* app-backup/[hashget](https://github.com/yaroslaff/hashget) | Deduplication tool for archiving data with extremely high ratio
* app-backup/[pgbackrest](https://pgbackrest.org) | Reliable PostgreSQL Backup & Restore
Expand Down Expand Up @@ -1246,4 +1246,3 @@ This overlay consists of an [Gentoo Portage](https://www.gentoo.org/) ebuilds fo
* x11-themes/[WhiteSur-icon-theme](https://github.com/vinceliuice/WhiteSur-icon-theme) | comes in both light and dark variants

</details>

2 changes: 1 addition & 1 deletion app-admin/yaml-vault/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1 @@
DIST yaml-vault-1.1.1_p1.tar.gz 174674 BLAKE2B c68aa4d3dd2e98212c8694b2a8637161df5eca753ad5ffbde603a358366550efe0ba5ef48e07bf61dd5d071c7ffc8923352ca6e175552ea3a103a55b3031d87b SHA512 66f87ed43e3913b7eb6b290cd9358b5aa7d50ad13bb10f9e396d5dd78c96eced2f10ba9c256ea9544059c91a9e5269316dcefb5c3cfd53bf7e68c683ba4b37d7
DIST yaml-vault-1.1.1_p1.gh.tar.gz 174739 BLAKE2B 9eabcb2f26a2fe36f927e103574f281ca50349c60139d3c2f51244048d43a23b3da5cce6e87f6c182514efebdc22e9b9b3780e4cb2da80d2a3c7ea912afa2a70 SHA512 2b56f0bb44b4cac73a9a54bfd3322809f630ed62d773bc06d648b4e6a8f0362c036700abca03af6adeef016b07ff8f7f6935537905675a427c3047e03b8f6628
2 changes: 1 addition & 1 deletion app-admin/yaml-vault/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -15,6 +15,6 @@
a YAML file.
</longdescription>
<upstream>
<remote-id type="github">Jimdo/yaml-vault</remote-id>
<remote-id type="github">jimdo/yaml-vault</remote-id>
</upstream>
</pkgmetadata>
15 changes: 7 additions & 8 deletions app-admin/yaml-vault/yaml-vault-1.1.1_p1.ebuild
Original file line number Diff line number Diff line change
@@ -1,31 +1,30 @@
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit go-module

COMMIT="a696961003ab9bca89129f08f56dd02541065a16"

DESCRIPTION="Utility to import/export data from HashiCorp Vault"
HOMEPAGE="https://github.com/Jimdo/yaml-vault"
SRC_URI="https://api.github.com/repos/Jimdo/${PN}/tarball/a696961 -> ${P}.tar.gz"
SRC_URI="https://github.com/Jimdo/${PN}/archive/${COMMIT}.tar.gz -> ${P}.gh.tar.gz"
S="${WORKDIR}/${PN}-${COMMIT}"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"

S="${WORKDIR}/Jimdo-${PN}-a696961"

DOCS=( {README,History}.md )

src_compile() {
LDFLAGS="-X main.version=${PV}"
GOFLAGS="-v -x -mod=vendor" \
go build -ldflags "$LDFLAGS" || die "build failed"
GOFLAGS="-v -x -mod=vendor" ego build -ldflags "$LDFLAGS"
}

src_test() {
GOFLAGS="-v -x -mod=vendor" \
go test -work || die "test failed"
GOFLAGS="-v -x -mod=vendor" ego test -work
}

src_install() {
Expand Down
14 changes: 5 additions & 9 deletions app-admin/yaml-vault/yaml-vault-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,19 +1,17 @@
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

EGIT_REPO_URI="https://github.com/luhring/${PN}.git"
EGIT_REPO_URI="https://github.com/jimdo/${PN}.git"

inherit git-r3 go-module

DESCRIPTION="Utility to import/export data from HashiCorp Vault"
HOMEPAGE="https://github.com/Jimdo/yaml-vault"
SRC_URI=""
HOMEPAGE="https://github.com/jimdo/yaml-vault"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS=""

DOCS=( {README,History}.md )

Expand All @@ -24,13 +22,11 @@ src_unpack() {

src_compile() {
LDFLAGS="-X main.version=${PV}"
GOFLAGS="-v -x -mod=vendor" \
go build -ldflags "$LDFLAGS" || die "build failed"
GOFLAGS="-v -x -mod=vendor" ego build -ldflags "$LDFLAGS"
}

src_test() {
GOFLAGS="-v -x -mod=vendor" \
go test -work || die "test failed"
GOFLAGS="-v -x -mod=vendor" ego test -work || die "test failed"
}

src_install() {
Expand Down

0 comments on commit a246b9f

Please sign in to comment.