Skip to content

Commit

Permalink
Update ruby-kramdown to 1.12.0.
Browse files Browse the repository at this point in the history
kramdown 1.12.0 released		Published on Monday, 15 August 2016

This release features two enhancements for definition lists:

1. IALs can now be applied to definition terms:

	{:.classy} term
	: and its definition

2. IDs for definition terms can now be created automatically (similar to
   header IDs) and optionally assigned a prefix:

	{:auto_ids}
	term1
	: definition

	term2
	: definition

	^

	{:auto_ids-prefix}
	term1
	: definition

	term2
	: definition

   Furthermore, compatibility of the GFM parser has been improved in regards
   to list/blockquotes/codeblocks that are used directly after a paragraph
   (i.e. without a blank line).

Changes

* 4 minor change:

  - Allow using an IAL for definition terms (<dt>) as is already possible with
    definitions themselves (<dd>)
  - Added automatic generation of IDs (with optional prefix) for terms of
    definition lists (fixes #355, requested by Greg Wilson)
  - Removed obfuscation for e-mail links (fixes #343, requested by Anton
    Tsyganenko)
  - New option ¡Ægfm_quirks¡Ç for enabling/disabling parsing differences of
    the GFM parser with respect to the kramdown parser

* 4 bug fixes:

  - Added support for HTML5 element <main> (fixes #334, reported by
    Jean-Michel Lacroix)
  - Fixed math element output for HTML converter when no math engine is set
    (fixes #342, reported by Adrian Sampson)
  - Fixed problem when using custom HTML formatter for syntax highlighter
    rouge (fixes #356, patch by Alexey Vasiliev)
  - Better compatibility with GFM when lists/blockquotes/codeblocks are used
    directly after a paragraph (fixes #336 (reported by Shuanglei Tao), #359
    (reported by Matti Schneider) via the patch #358 by Shuanglei Tao)

* 3 other fixes and enhancements:

  - Added some more examples for how list indentation works (fixes #353,
    requested by Robbert Brak)
  - Using RbConfig instead of deprecated Config for determining data directory
    (fixes #345, patch by C�«±dric Boutillier)
  - JRuby is now also tested via TravisCI (fixes #363, patch by Shuanglei Tao)

kramdown 1.11.1 released		Published on Sunday, 01 May 2016

This release fixes an emphasis parsing regression introduced in the last
version.

Changes

* 1 bug fix:

  - Fixed emphasis parsing regression (fixes #333, reported by Marcus
    Stollsteimer)

kramdown 1.11.0 released		Published on Sunday, 01 May 2016

This release fixes some bugs and includes one minor change in regards to HTML
syntax highlighting.

Changes

* 1 minor change:

  - The syntax highlighting language is now always included in the output as
    class name even if a syntax highlighter is used (fixes #328, requested by
    SLaks)

* 3 bug fixes:

  - Fixed the GFM fenced code block parser to correctly split a provided
    highlighter name into language name and options parts
  - Fixed problem with underscores being processed even if inside a word
    (fixes #323, reported by Haruki Kirigaya)
  - Fixed HTML/XML parser to correctly, case sensitively parse XML (fixes
    #310, reported by cabo)

* 2 other fixes:

  - Updated copyright year (fixes #331, reported by Oscar Bj�«Órkman)
  - Updated supported Ruby version on installation page (reported by cabo)
  • Loading branch information
taca committed Oct 18, 2016
1 parent ca289f4 commit 6cacd89
Show file tree
Hide file tree
Showing 3 changed files with 29 additions and 8 deletions.
4 changes: 2 additions & 2 deletions textproc/ruby-kramdown/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.15 2016/03/15 15:43:28 taca Exp $
# $NetBSD: Makefile,v 1.16 2016/10/18 14:34:01 taca Exp $

DISTNAME= kramdown-1.10.0
DISTNAME= kramdown-1.12.0
CATEGORIES= textproc

MAINTAINER= pkgsrc-users@NetBSD.org
Expand Down
23 changes: 22 additions & 1 deletion textproc/ruby-kramdown/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.12 2016/03/15 15:43:28 taca Exp $
@comment $NetBSD: PLIST,v 1.13 2016/10/18 14:34:01 taca Exp $
bin/kramdown${RUBY_SUFFIX}
${GEM_HOME}/cache/${GEM_NAME}.gem
${GEM_LIBDIR}/AUTHORS
Expand Down Expand Up @@ -186,6 +186,9 @@ ${GEM_LIBDIR}/test/testcases/block/06_codeblock/normal.text
${GEM_LIBDIR}/test/testcases/block/06_codeblock/rouge/disabled.html
${GEM_LIBDIR}/test/testcases/block/06_codeblock/rouge/disabled.options
${GEM_LIBDIR}/test/testcases/block/06_codeblock/rouge/disabled.text
${GEM_LIBDIR}/test/testcases/block/06_codeblock/rouge/multiple.html
${GEM_LIBDIR}/test/testcases/block/06_codeblock/rouge/multiple.options
${GEM_LIBDIR}/test/testcases/block/06_codeblock/rouge/multiple.text
${GEM_LIBDIR}/test/testcases/block/06_codeblock/rouge/simple.html
${GEM_LIBDIR}/test/testcases/block/06_codeblock/rouge/simple.options
${GEM_LIBDIR}/test/testcases/block/06_codeblock/rouge/simple.text
Expand Down Expand Up @@ -312,6 +315,8 @@ ${GEM_LIBDIR}/test/testcases/block/09_html/simple.options
${GEM_LIBDIR}/test/testcases/block/09_html/simple.text
${GEM_LIBDIR}/test/testcases/block/09_html/textarea.html
${GEM_LIBDIR}/test/testcases/block/09_html/textarea.text
${GEM_LIBDIR}/test/testcases/block/09_html/xml.html
${GEM_LIBDIR}/test/testcases/block/09_html/xml.text
${GEM_LIBDIR}/test/testcases/block/10_ald/simple.html
${GEM_LIBDIR}/test/testcases/block/10_ald/simple.text
${GEM_LIBDIR}/test/testcases/block/11_ial/auto_id_and_ial.html
Expand All @@ -335,6 +340,8 @@ ${GEM_LIBDIR}/test/testcases/block/12_extension/options2.html
${GEM_LIBDIR}/test/testcases/block/12_extension/options2.text
${GEM_LIBDIR}/test/testcases/block/12_extension/options3.html
${GEM_LIBDIR}/test/testcases/block/12_extension/options3.text
${GEM_LIBDIR}/test/testcases/block/13_definition_list/auto_ids.html
${GEM_LIBDIR}/test/testcases/block/13_definition_list/auto_ids.text
${GEM_LIBDIR}/test/testcases/block/13_definition_list/definition_at_beginning.html
${GEM_LIBDIR}/test/testcases/block/13_definition_list/definition_at_beginning.text
${GEM_LIBDIR}/test/testcases/block/13_definition_list/deflist_ial.html
Expand Down Expand Up @@ -393,6 +400,9 @@ ${GEM_LIBDIR}/test/testcases/block/15_math/mathjaxnode_notexhints.text
${GEM_LIBDIR}/test/testcases/block/15_math/mathjaxnode_semantics.html.19
${GEM_LIBDIR}/test/testcases/block/15_math/mathjaxnode_semantics.options
${GEM_LIBDIR}/test/testcases/block/15_math/mathjaxnode_semantics.text
${GEM_LIBDIR}/test/testcases/block/15_math/no_engine.html
${GEM_LIBDIR}/test/testcases/block/15_math/no_engine.options
${GEM_LIBDIR}/test/testcases/block/15_math/no_engine.text
${GEM_LIBDIR}/test/testcases/block/15_math/normal.html
${GEM_LIBDIR}/test/testcases/block/15_math/normal.text
${GEM_LIBDIR}/test/testcases/block/15_math/ritex.html
Expand Down Expand Up @@ -439,6 +449,7 @@ ${GEM_LIBDIR}/test/testcases/span/02_emphasis/errors.text
${GEM_LIBDIR}/test/testcases/span/02_emphasis/nesting.html
${GEM_LIBDIR}/test/testcases/span/02_emphasis/nesting.text
${GEM_LIBDIR}/test/testcases/span/02_emphasis/normal.html
${GEM_LIBDIR}/test/testcases/span/02_emphasis/normal.options
${GEM_LIBDIR}/test/testcases/span/02_emphasis/normal.text
${GEM_LIBDIR}/test/testcases/span/03_codespan/empty.html
${GEM_LIBDIR}/test/testcases/span/03_codespan/empty.text
Expand Down Expand Up @@ -495,6 +506,8 @@ ${GEM_LIBDIR}/test/testcases/span/05_html/normal.html
${GEM_LIBDIR}/test/testcases/span/05_html/normal.text
${GEM_LIBDIR}/test/testcases/span/05_html/raw_span_elements.html
${GEM_LIBDIR}/test/testcases/span/05_html/raw_span_elements.text
${GEM_LIBDIR}/test/testcases/span/05_html/xml.html
${GEM_LIBDIR}/test/testcases/span/05_html/xml.text
${GEM_LIBDIR}/test/testcases/span/abbreviations/abbrev.html
${GEM_LIBDIR}/test/testcases/span/abbreviations/abbrev.text
${GEM_LIBDIR}/test/testcases/span/abbreviations/abbrev_defs.html
Expand Down Expand Up @@ -522,6 +535,9 @@ ${GEM_LIBDIR}/test/testcases/span/math/itex2mml.text
${GEM_LIBDIR}/test/testcases/span/math/mathjaxnode.html.19
${GEM_LIBDIR}/test/testcases/span/math/mathjaxnode.options
${GEM_LIBDIR}/test/testcases/span/math/mathjaxnode.text
${GEM_LIBDIR}/test/testcases/span/math/no_engine.html
${GEM_LIBDIR}/test/testcases/span/math/no_engine.options
${GEM_LIBDIR}/test/testcases/span/math/no_engine.text
${GEM_LIBDIR}/test/testcases/span/math/normal.html
${GEM_LIBDIR}/test/testcases/span/math/normal.text
${GEM_LIBDIR}/test/testcases/span/math/ritex.html
Expand Down Expand Up @@ -562,6 +578,11 @@ ${GEM_LIBDIR}/test/testcases_gfm/hard_line_breaks.text
${GEM_LIBDIR}/test/testcases_gfm/hard_line_breaks_off.html
${GEM_LIBDIR}/test/testcases_gfm/hard_line_breaks_off.options
${GEM_LIBDIR}/test/testcases_gfm/hard_line_breaks_off.text
${GEM_LIBDIR}/test/testcases_gfm/paragraph_end-disabled.html
${GEM_LIBDIR}/test/testcases_gfm/paragraph_end-disabled.options
${GEM_LIBDIR}/test/testcases_gfm/paragraph_end-disabled.text
${GEM_LIBDIR}/test/testcases_gfm/paragraph_end.html
${GEM_LIBDIR}/test/testcases_gfm/paragraph_end.text
${GEM_LIBDIR}/test/testcases_gfm/strikethrough.html
${GEM_LIBDIR}/test/testcases_gfm/strikethrough.html.19
${GEM_LIBDIR}/test/testcases_gfm/strikethrough.text
Expand Down
10 changes: 5 additions & 5 deletions textproc/ruby-kramdown/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.14 2016/03/15 15:43:28 taca Exp $
$NetBSD: distinfo,v 1.15 2016/10/18 14:34:01 taca Exp $

SHA1 (kramdown-1.10.0.gem) = a12a1f7f5bfcb4c6652f6f3f10f77dd99e966859
RMD160 (kramdown-1.10.0.gem) = 48b46ac26a074b3e8bf483380b99709d138ccdb2
SHA512 (kramdown-1.10.0.gem) = fa0c8f1de6ea7306c7ca47a99f0d3e4a2e720e8d7d00f85a811b0ddd7f533960d583f94dee59f1d04900069163dd583c70520bedeeada77d673ff1b3d8b3782e
Size (kramdown-1.10.0.gem) = 240128 bytes
SHA1 (kramdown-1.12.0.gem) = a18bc212eedb921a346e334cb26ed115f2e52b25
RMD160 (kramdown-1.12.0.gem) = c72e19ee9bdeb88bb84364e0949c566ff0441d62
SHA512 (kramdown-1.12.0.gem) = 43d9e4b5fd2cd0e496f725b14c0a55b1f0db9274340909e01fd106ede3d3d5f2ec1ac1f3690a8951f7726bcc111e281ff3d28c0f488d2b4c508dc895af4c88af
Size (kramdown-1.12.0.gem) = 243712 bytes

0 comments on commit 6cacd89

Please sign in to comment.