Skip to content

Commit

Permalink
Updated devel/byacc from 20141128 to 20160606, Sorry for long CHANGES:
Browse files Browse the repository at this point in the history
---------------------------------------------
2016-06-06  Thomas E. Dickey  <tom@invisible-island.net>

	* configure: regen

	* aclocal.m4: improved autoconf macros:
	CF_CC_ENV_FLAGS - don't limit the check to -I, -U and -D options, since the
		added options can include various compiler options before and after
		preprocessor options.
	CF_PROG_LINT - add cpplint to programs to use; drop ad hoc tdlint and alint.

	* VERSION, package/byacc.spec, package/debian/changelog, package/mingw-byacc.spec, package/pkgsrc/Makefile:
	bump

	* lalr.c: indented

	* btyaccpar.c: regen

	* skel2c:
	adjust whitespace so that generated skeleton will follow the same format
	as other code

	* mkpar.c, verbose.c, lr0.c, reader.c, error.c, output.c: indented

	* reader.c: fix two compiler warnings

	* test/btyacc/inherit2.tab.c,
	test/btyacc/ok_syntax1.tab.c,
	test/btyacc/pure_calc.tab.c,
	test/btyacc/pure_error.tab.c,
	test/btyacc/quote_calc-s.tab.c,
	test/btyacc/quote_calc.tab.c,
	test/btyacc/quote_calc2-s.tab.c,
	test/btyacc/quote_calc2.tab.c,
	test/btyacc/quote_calc3-s.tab.c,
	test/btyacc/quote_calc3.tab.c,
	test/btyacc/quote_calc4-s.tab.c,
	test/btyacc/quote_calc4.tab.c,
	test/btyacc/varsyntax_calc1.tab.c,
	test/btyacc/err_syntax12.tab.c,
	test/btyacc/err_syntax18.tab.c,
	test/btyacc/err_syntax20.tab.c,
	test/btyacc/error.tab.c, test/btyacc/grammar.tab.c,
	test/btyacc/inherit0.tab.c,
	test/btyacc/inherit1.tab.c,
	test/btyacc/btyacc_calc1.tab.c,
	test/btyacc/btyacc_demo.tab.c,
	test/btyacc/btyacc_destroy1.tab.c,
	test/btyacc/btyacc_destroy2.tab.c,
	test/btyacc/btyacc_destroy3.tab.c,
	test/btyacc/calc.tab.c, test/btyacc/calc1.tab.c,
	test/btyacc/calc2.tab.c, test/btyacc/calc3.tab.c,
	test/btyacc/code_calc.code.c,
	test/btyacc/code_error.code.c,
	test/btyacc/empty.tab.c,
	test/btyacc/err_inherit3.tab.c,
	test/btyacc/err_inherit4.tab.c,
	test/btyacc/err_syntax10.tab.c,
	test/btyacc/err_syntax11.tab.c,
	test/btyacc/rename_debug.c, btyaccpar.c,
	test/yacc/quote_calc2-s.tab.c,
	test/yacc/quote_calc2.tab.c,
	test/yacc/quote_calc3-s.tab.c,
	test/yacc/quote_calc3.tab.c,
	test/yacc/quote_calc4-s.tab.c,
	test/yacc/quote_calc4.tab.c,
	test/yacc/varsyntax_calc1.tab.c,
	test/yacc/err_syntax20.tab.c, test/yacc/error.tab.c,
	test/yacc/grammar.tab.c, test/yacc/ok_syntax1.tab.c,
	test/yacc/pure_calc.tab.c, test/yacc/pure_error.tab.c,
	test/yacc/quote_calc-s.tab.c,
	test/yacc/quote_calc.tab.c, test/yacc/calc.tab.c,
	test/yacc/calc1.tab.c, test/yacc/calc2.tab.c,
	test/yacc/calc3.tab.c, test/yacc/code_calc.code.c,
	test/yacc/code_error.code.c, test/yacc/empty.tab.c,
	test/yacc/err_syntax10.tab.c,
	test/yacc/err_syntax11.tab.c,
	test/yacc/err_syntax12.tab.c,
	test/yacc/err_syntax18.tab.c,
	test/yacc/rename_debug.c, yaccpar.c: regen

2016-06-06  Tom.Shields

	* btyaccpar.skel, yaccpar.skel:
	small fix for an edge case of initialized data in Chris Dodd's btyacc changes:
	"Avoid crash when input pops up an Action error at the first token"

2016-06-01  Thomas E. Dickey  <tom@invisible-island.net>

	* test/yacc/quote_calc2-s.tab.c,
	test/yacc/quote_calc3-s.tab.c,
	test/yacc/quote_calc3.tab.c,
	test/yacc/quote_calc4-s.tab.c,
	test/yacc/quote_calc4.tab.c,
	test/yacc/varsyntax_calc1.tab.c,
	test/yacc/err_syntax18.tab.c,
	test/yacc/err_syntax20.tab.c,
	test/yacc/err_syntax24.error, test/yacc/error.tab.c,
	test/yacc/grammar.tab.c, test/yacc/ok_syntax1.tab.c,
	test/yacc/pure_calc.tab.c, test/yacc/pure_error.tab.c,
	test/yacc/quote_calc-s.tab.c,
	test/yacc/quote_calc.tab.c,
	test/yacc/quote_calc2.tab.c, test/yacc/calc.tab.c,
	test/yacc/calc1.tab.c, test/yacc/calc2.tab.c,
	test/yacc/calc3.tab.c, test/yacc/code_calc.code.c,
	test/yacc/code_calc.tab.c, test/yacc/code_calc.tab.h,
	test/yacc/code_error.code.c, test/yacc/empty.tab.c,
	test/yacc/err_syntax10.tab.c,
	test/yacc/err_syntax11.tab.c,
	test/yacc/err_syntax12.tab.c,
	test/yacc/rename_debug.c, yaccpar.c,
	test/btyacc/quote_calc-s.tab.c,
	test/btyacc/quote_calc.tab.c,
	test/btyacc/quote_calc2-s.tab.c,
	test/btyacc/quote_calc2.tab.c,
	test/btyacc/quote_calc3-s.tab.c,
	test/btyacc/quote_calc3.tab.c,
	test/btyacc/quote_calc4-s.tab.c,
	test/btyacc/quote_calc4.tab.c,
	test/btyacc/varsyntax_calc1.tab.c,
	test/btyacc/err_syntax13.tab.c,
	test/btyacc/err_syntax14.tab.c,
	test/btyacc/err_syntax15.tab.c,
	test/btyacc/err_syntax16.tab.c,
	test/btyacc/err_syntax17.tab.c,
	test/btyacc/err_syntax18.tab.c,
	test/btyacc/err_syntax19.tab.c,
	test/btyacc/err_syntax2.tab.c,
	test/btyacc/err_syntax20.tab.c,
	test/btyacc/err_syntax21.tab.c,
	test/btyacc/err_syntax22.tab.c,
	test/btyacc/err_syntax23.tab.c,
	test/btyacc/err_syntax24.error,
	test/btyacc/err_syntax24.tab.c,
	test/btyacc/err_syntax25.tab.c,
	test/btyacc/err_syntax26.tab.c,
	test/btyacc/err_syntax27.tab.c,
	test/btyacc/err_syntax3.tab.c,
	test/btyacc/err_syntax4.tab.c,
	test/btyacc/err_syntax5.tab.c,
	test/btyacc/err_syntax6.tab.c,
	test/btyacc/err_syntax7.tab.c,
	test/btyacc/err_syntax7a.tab.c,
	test/btyacc/err_syntax7b.tab.c,
	test/btyacc/err_syntax8.tab.c,
	test/btyacc/err_syntax8a.tab.c,
	test/btyacc/err_syntax9.tab.c,
	test/btyacc/error.tab.c, test/btyacc/grammar.tab.c,
	test/btyacc/inherit0.tab.c,
	test/btyacc/inherit1.tab.c,
	test/btyacc/inherit2.output,
	test/btyacc/inherit2.tab.c,
	test/btyacc/ok_syntax1.tab.c,
	test/btyacc/pure_calc.tab.c,
	test/btyacc/pure_error.tab.c,
	test/btyacc/btyacc_calc1.tab.c,
	test/btyacc/btyacc_demo.error,
	test/btyacc/btyacc_demo.output,
	test/btyacc/btyacc_demo.tab.c,
	test/btyacc/btyacc_destroy1.tab.c,
	test/btyacc/btyacc_destroy2.tab.c,
	test/btyacc/btyacc_destroy3.tab.c,
	test/btyacc/calc.tab.c, test/btyacc/calc1.tab.c,
	test/btyacc/calc2.tab.c, test/btyacc/calc3.tab.c,
	test/btyacc/code_calc.code.c,
	test/btyacc/code_calc.tab.c,
	test/btyacc/code_calc.tab.h,
	test/btyacc/code_error.code.c,
	test/btyacc/empty.tab.c,
	test/btyacc/err_inherit1.tab.c,
	test/btyacc/err_inherit2.tab.c,
	test/btyacc/err_inherit3.output,
	test/btyacc/err_inherit3.tab.c,
	test/btyacc/err_inherit4.output,
	test/btyacc/err_inherit4.tab.c,
	test/btyacc/err_inherit5.tab.c,
	test/btyacc/err_syntax1.tab.c,
	test/btyacc/err_syntax10.tab.c,
	test/btyacc/err_syntax11.tab.c,
	test/btyacc/err_syntax12.tab.c,
	test/btyacc/rename_debug.c, btyaccpar.c: regen

2016-06-01  Tom.Shields

	* btyaccpar.skel, defs.h, error.c, output.c, reader.c, test/code_calc.y, test/err_inherit4.y, test/run_make.sh, yaccpar.skel:
	fixes for issues in btyacc (report by Francis Andre):

	+ correction to the placement of the #line directive for a %union specification

	+ recovery of a set of casts originally added into btyaccpar.c rather than into
	  btyaccpar.skel, and so are lost whenever building from scratch

	+ Chris Dodd's btyacc improved handling of inherited attributes to eliminate
	  implicit empty copy rules that are not necessary, and thereby avoiding the
	  introduction of extra parsing ambiguity

	+ Chris Dodd's added support for @-N syntax to reference inherited position
	  information

	+ correction to bad interaction between %token-table and YYDEBUG, where YYDEBUG
	  was required to be defined in order to compile the generated code

	+ correction to yyname[] access in code included with YYDEBUG defined for
	  single character symbols not recognized (e.g., input containing '&' character
	  where grammar doesn't define that as a symbol) - map to existing
	  "illegal-symbol" entry in byname[]

	+ fixes to test/run_make.sh:  skip test-err_* files; in the bison test phase
	  skip additional files that contain features not supported by bison and
	  inhibit new bison warning messages

	+ minor changes to btyaccpar.skel & yaccpar.skel so they are more similar in
	  their commonality; makes it easier to maintain the pair of files using
	  vimdiff

	+ changes to a couple of test cases for coverage of #3, #4 and #5 above

2016-06-01  Thomas E. Dickey  <tom@invisible-island.net>

	* VERSION, package/byacc.spec, package/debian/changelog, package/mingw-byacc.spec, package/pkgsrc/Makefile:
	bump

2016-03-24  Thomas E. Dickey  <tom@invisible-island.net>

	* reader.c: unused variable

	* package/pkgsrc/Makefile, package/debian/copyright: bump

2016-03-24  Jung-uk.Kim

	* main.c:
	correct logic for finding output suffix in the "-o" option, which matched
	the first occurrence of ".c" in the name in 2005-08-13 changes rather than
	at the end of the filename (patch by Jung-uk Kim)

2016-03-24  Thomas E. Dickey  <tom@invisible-island.net>

	* aclocal.m4:
	update CF_WITH_MAN2HTML to use configured shell rather than /bin/sh

	* VERSION, package/byacc.spec, package/debian/changelog, package/mingw-byacc.spec, package/pkgsrc/Makefile:
	bump

2016-01-25  Thomas E. Dickey  <tom@invisible-island.net>

	* config.guess, config.sub: 2016-01-01

2015-07-10  Thomas E. Dickey  <tom@invisible-island.net>

	* lr0.c: fix a duplicate-free in the leak-checking

	* VERSION, package/byacc.spec, package/debian/changelog, package/mingw-byacc.spec, package/pkgsrc/Makefile:
	bump

	* reader.c:
	make cache-size clearer (prompted by discussion with Pedro Giffuni,
	Oliver Pinter)

	* main.c:
	make relationship with format/size clearer (prompted by discussion
	with Pedro Giffuni, Oliver Pinter)

2015-07-05  Thomas E. Dickey  <tom@invisible-island.net>

	* configure: regen

	* package/pkgsrc/Makefile, package/mingw-byacc.spec, package/debian/copyright, package/debian/changelog, package/byacc.spec, VERSION:
	bump

	* aclocal.m4: resync with my-autoconf
	add configure option --with-man2html

	* makefile.in: add configure options --with-man2html

	* configure.in: add configure option --with-man2html

2015-05-02  Thomas E. Dickey  <tom@invisible-island.net>

	* config.guess: 2015-03-04

	* config.sub: 2015-03-08
  • Loading branch information
mef committed Jun 18, 2016
1 parent fe9b55c commit 92e8ab5
Show file tree
Hide file tree
Showing 2 changed files with 7 additions and 7 deletions.
4 changes: 2 additions & 2 deletions devel/byacc/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.13 2014/12/15 06:04:13 mef Exp $
# $NetBSD: Makefile,v 1.14 2016/06/18 08:03:41 mef Exp $
#

DISTNAME= byacc-20141128
DISTNAME= byacc-20160606
CATEGORIES= devel
MASTER_SITES= ftp://invisible-island.net/byacc/
EXTRACT_SUFX= .tgz
Expand Down
10 changes: 5 additions & 5 deletions devel/byacc/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.7 2015/11/03 03:27:17 agc Exp $
$NetBSD: distinfo,v 1.8 2016/06/18 08:03:41 mef Exp $

SHA1 (byacc-20141128.tgz) = 59ea0a166b10eaec99edacc4c38fcb006c6e84d3
RMD160 (byacc-20141128.tgz) = 246dece91262b8f1f8746b03a8a0b32249e47f84
SHA512 (byacc-20141128.tgz) = a41debde13d489e47c635bd61ce691e7b0a1470a91df3d16e43bd7c0985064708c4d69b8fabe2134ac4d06b17e484ea9c0b7efc7a624e7d8b7ed850e89afd71c
Size (byacc-20141128.tgz) = 710145 bytes
SHA1 (byacc-20160606.tgz) = 1e72f0f7c93a0aed96a558029bab2336174c2848
RMD160 (byacc-20160606.tgz) = 96b5c6b2d615104952b9bbc8faa375b17559e2fa
SHA512 (byacc-20160606.tgz) = b8d2e9523aa615399dd6c3ed0efe90b4ac943dc8039b655958db8fd4ebd0bd920af9a7a5a4c8e525a0f04e4bfd76474e39bbfa861068851d230e4b4726ca3fea
Size (byacc-20160606.tgz) = 706191 bytes

0 comments on commit 92e8ab5

Please sign in to comment.