Skip to content

Commit

Permalink
Update databases/py-peewee to 2.8.1.
Browse files Browse the repository at this point in the history
Bugs fixed
- #821 - issue warning if Cython is old
- #822 - better handling of MySQL connections point for advanced
  use-cases.
- #313 - support equality/inequality with generic foreign key
  queries, and ensure get_or_create works with GFKs.
- #834 - fixed Python3 incompatibilities in the PasswordField,
  thanks @mosquito.
- #836 - fix handling of last_insert_id() when using APSWDatabase.
- #845 - add connection hooks to APSWDatabase.
- #852 - check SQLite library version to avoid calls to missing
  APIs.
- #857 - allow database definition to be deferred when using the
  connection pool.
- #878 - formerly .limit(0) had no effect. Now adds LIMIT 0.
- #879 - implement a __hash__ method for Model
- #886 - fix count() for compound select queries.
- #895 - allow writing to the foreign_key_id descriptor to set the
  foreign key value.
- #893 - fix boolean logic bug in model_to_dict().
- #904 - fix side-effect in clean_prefetch_query, thanks to
  @p.kamayev
- #907 - package includes pskel now.
- #852 - fix sqlite version check in BerkeleyDB backend.
- #919 - add runtime check for sqlite3 library to match MySQL and
  Postgres. Thanks @M157q

New features
- Added a number of SQLite user-defined functions and aggregates.
- Use the DB-API2 Binary type for BlobField.
- Implemented the lucene scoring algorithm in the sqlite_ext
  Cython library.
- #825 - allow a custom base class for ModelOptions, providing an
  extension
- #830 - added SmallIntegerField type.
- #838 - allow using a custom descriptor class with
  ManyToManyField.
- #855 - merged change from @lez which included docs on using
  peewee with Pyramid.
- #858 - allow arguments to be passed on query-string when using
  the db_url module. Thanks @RealSalmon
- #862 - add support for truncate table, thanks @dev-zero for the
  sample code.
- Allow the related_name model Meta option to be a callable that
  accepts the foreign key field instance.
  • Loading branch information
fhajny committed May 6, 2016
1 parent 4f60d45 commit 9cee012
Show file tree
Hide file tree
Showing 3 changed files with 12 additions and 8 deletions.
4 changes: 2 additions & 2 deletions databases/py-peewee/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.10 2016/01/18 15:53:14 fhajny Exp $
# $NetBSD: Makefile,v 1.11 2016/05/06 09:45:09 fhajny Exp $

DISTNAME= peewee-2.8.0
DISTNAME= peewee-2.8.1
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_GITHUB:=coleifer/}
Expand Down
6 changes: 5 additions & 1 deletion databases/py-peewee/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.9 2016/01/18 15:53:14 fhajny Exp $
@comment $NetBSD: PLIST,v 1.10 2016/05/06 09:45:09 fhajny Exp $
bin/pwiz.py
${PYSITELIB}/peewee.py
${PYSITELIB}/peewee.pyc
Expand All @@ -8,6 +8,7 @@ ${PYSITELIB}/playhouse/__init__.pyc
${PYSITELIB}/playhouse/__init__.pyo
${PYSITELIB}/playhouse/_speedups.so
${PYSITELIB}/playhouse/_sqlite_ext.so
${PYSITELIB}/playhouse/_sqlite_udf.so
${PYSITELIB}/playhouse/apsw_ext.py
${PYSITELIB}/playhouse/apsw_ext.pyc
${PYSITELIB}/playhouse/apsw_ext.pyo
Expand Down Expand Up @@ -71,6 +72,9 @@ ${PYSITELIB}/playhouse/sqlcipher_ext.pyo
${PYSITELIB}/playhouse/sqlite_ext.py
${PYSITELIB}/playhouse/sqlite_ext.pyc
${PYSITELIB}/playhouse/sqlite_ext.pyo
${PYSITELIB}/playhouse/sqlite_udf.py
${PYSITELIB}/playhouse/sqlite_udf.pyc
${PYSITELIB}/playhouse/sqlite_udf.pyo
${PYSITELIB}/playhouse/test_utils.py
${PYSITELIB}/playhouse/test_utils.pyc
${PYSITELIB}/playhouse/test_utils.pyo
Expand Down
10 changes: 5 additions & 5 deletions databases/py-peewee/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.10 2016/01/18 15:53:14 fhajny Exp $
$NetBSD: distinfo,v 1.11 2016/05/06 09:45:09 fhajny Exp $

SHA1 (peewee-2.8.0.tar.gz) = ed4477aad9fe1bec628387319af36ef32ea8d289
RMD160 (peewee-2.8.0.tar.gz) = c8e69948394302501cfb67a96f00add320447dad
SHA512 (peewee-2.8.0.tar.gz) = 12a225dc6d40838d223a7396ed138d1a82393f79b0b666f019e0c6f07c58c99e0a50ecf1ad61c10176a3f184f00fcde0a753f7ea49aa5a8e2a0e69832b654622
Size (peewee-2.8.0.tar.gz) = 615679 bytes
SHA1 (peewee-2.8.1.tar.gz) = 4ca6e599588419cabd41faff7c898917c2efa707
RMD160 (peewee-2.8.1.tar.gz) = 59c372129585aa574f4062c1c4124cc1c840b614
SHA512 (peewee-2.8.1.tar.gz) = fd65001f6227f3b470046794f306def4a69b2637d916d4d7ee1057dab5671eaae88f32fe5345e3266829651e7529c53d9928516135af520832f34bfc0b1b9f39
Size (peewee-2.8.1.tar.gz) = 628870 bytes

0 comments on commit 9cee012

Please sign in to comment.