Skip to content

Commit

Permalink
update to 1.2.2
Browse files Browse the repository at this point in the history
changes:
-YUV conversion optimisation
-support for FLAC in Matroska
-support for BMP
-bugfixes
  • Loading branch information
drochner committed Jul 2, 2012
1 parent ed0cad9 commit d2b79ef
Show file tree
Hide file tree
Showing 5 changed files with 64 additions and 25 deletions.
3 changes: 1 addition & 2 deletions multimedia/xine-lib/Makefile
Original file line number Diff line number Diff line change
@@ -1,10 +1,9 @@
# $NetBSD: Makefile,v 1.100 2012/06/14 07:44:38 sbd Exp $
# $NetBSD: Makefile,v 1.101 2012/07/02 16:27:10 drochner Exp $

PKG_DESTDIR_SUPPORT= user-destdir

.include "Makefile.common"

PKGREVISION= 1
COMMENT= Multimedia player library

CONFLICTS+= xine-xcb-[0-9]*
Expand Down
10 changes: 5 additions & 5 deletions multimedia/xine-lib/Makefile.common
Original file line number Diff line number Diff line change
@@ -1,22 +1,22 @@
# $NetBSD: Makefile.common,v 1.77 2012/04/16 03:41:58 dholland Exp $
# $NetBSD: Makefile.common,v 1.78 2012/07/02 16:27:11 drochner Exp $
#
# used by audio/xine-alsa/Makefile
# used by audio/xine-esound/Makefile
# used by audio/xine-pulse/Makefile
# used by multimedia/xine-v4l/Makefile
# used by multimedia/xine-v4l2/Makefile

DISTNAME= xine-lib-1.2.1
XINE_PKGNAME= xine-lib-1.2.1
DISTNAME= xine-lib-1.2.2
XINE_PKGNAME= xine-lib-1.2.2
PKGNAME?= ${XINE_PKGNAME}
CATEGORIES?= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=xine/}
EXTRACT_SUFX= .tar.bz2
EXTRACT_SUFX= .tar.xz

MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://xinehq.de/

XINE_MOD_DIR_VER= 2.1
XINE_MOD_DIR_VER= 2.2
PLIST_SUBST+= XINE_MOD_DIR_VER=${XINE_MOD_DIR_VER:Q}

DISTINFO_FILE= ${.CURDIR}/../../multimedia/xine-lib/distinfo
Expand Down
10 changes: 5 additions & 5 deletions multimedia/xine-lib/distinfo
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.82 2012/05/18 18:53:31 marino Exp $
$NetBSD: distinfo,v 1.83 2012/07/02 16:27:11 drochner Exp $

SHA1 (xine-lib-1.2.1.tar.bz2) = c86591ff9fb6b073b8d115fa31b5a74a305e8628
RMD160 (xine-lib-1.2.1.tar.bz2) = eb6dab8418eebf0ee5f210efd085ae09367f624e
Size (xine-lib-1.2.1.tar.bz2) = 6197175 bytes
SHA1 (xine-lib-1.2.2.tar.xz) = a349cbb0b72256bb262377796a022dcf63829b4c
RMD160 (xine-lib-1.2.2.tar.xz) = 3f11df3fa8a8946bdcc9cdecd6952dc76b834d14
Size (xine-lib-1.2.2.tar.xz) = 4857248 bytes
SHA1 (patch-Makefile.am) = 3cfff7a6941015921c166f9a67159a5bb3ca0204
SHA1 (patch-ad) = 94aaac03f74c72a1ca753d1320aac07d1bb8a846
SHA1 (patch-ag) = 0bdd5910ad7c446bdec5abac3292bcab7a4147ee
Expand All @@ -11,7 +11,7 @@ SHA1 (patch-ak) = 987700e6526b5112ac66bd6a8f9ee41f338c3508
SHA1 (patch-ap) = d48fa83879895d4b1f56bfbcbe31087dd57d8a82
SHA1 (patch-as) = a0a93a256589e87a66eef31494441aa1b200f834
SHA1 (patch-at) = 15a810379ccb345aeeb374b0148096684f5f179b
SHA1 (patch-au) = 7f78d400ac606e2f73eb4caf347013f2b55f9430
SHA1 (patch-av) = 1b391773fb45340605987a32be4aaa8b053b082d
SHA1 (patch-cb) = db4ff27418e05e97bf30b554beecc24d6e578d15
SHA1 (patch-cd) = 192530e79568ea165b1fc675c7e794133a06c734
SHA1 (patch-fa) = 9312a3bab4ae8482a208948277f1d11fb7eaaf8c
Expand Down
13 changes: 0 additions & 13 deletions multimedia/xine-lib/patches/patch-au

This file was deleted.

53 changes: 53 additions & 0 deletions multimedia/xine-lib/patches/patch-av
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
$NetBSD: patch-av,v 1.10 2012/07/02 16:27:11 drochner Exp $

--- src/post/deinterlace/plugins/greedy2frame_template_sse2.c.orig 2012-06-26 15:57:44.000000000 +0000
+++ src/post/deinterlace/plugins/greedy2frame_template_sse2.c
@@ -170,10 +170,10 @@ static void DeinterlaceGreedy2Frame_SSE2
* See above for a description of the algorithm.
* weave if (weave(M) AND (weave(T) OR weave(B)))
*/
- "movdqa (%3), %%xmm1 \n\t" /* xmm1 = T1 */
- "movdqa (%4), %%xmm0 \n\t" /* xmm0 = T0 */
- "movdqa (%q5,%3), %%xmm3 \n\t" /* xmm3 = B1 */
- "movdqa (%q5,%4), %%xmm2 \n\t" /* xmm2 = B0 */
+ "movdqa (%2), %%xmm1 \n\t" /* xmm1 = T1 */
+ "movdqa (%3), %%xmm0 \n\t" /* xmm0 = T0 */
+ "movdqa (%q4,%2), %%xmm3 \n\t" /* xmm3 = B1 */
+ "movdqa (%q4,%3), %%xmm2 \n\t" /* xmm2 = B0 */

/* calculate |T1-T0| keep T1 put result in xmm5 */
"movdqa %%xmm1, %%xmm5 \n\t"
@@ -181,20 +181,19 @@ static void DeinterlaceGreedy2Frame_SSE2
"psubusb %%xmm1, %%xmm0 \n\t"
"por %%xmm0, %%xmm5 \n\t"

- "movdqa (%0), %%xmm0 \n\t" /* xmm0 = M1 */
/* T1 is data for line to copy */
- "movntdq %%xmm1, %2 \n\t"
+ "movntdq %%xmm1, %1 \n\t"

/* if |T1-T0| > Threshold we want 0 else dword minus one */
"psrlw $1, %%xmm5 \n\t"
"pand %%xmm6, %%xmm5 \n\t"
- "pcmpgtb %1, %%xmm5 \n\t"
+ "pcmpgtb %0, %%xmm5 \n\t"
"pcmpeqd %%xmm7, %%xmm5 \n\t"

- "prefetcht0 64(%q5,%3) \n\t"
- "prefetcht0 64(%q5,%4) \n\t"
+ "prefetcht0 64(%q4,%3) \n\t"
+ "prefetcht0 64(%q4,%4) \n\t"
:
- : "r" (M1), "m" (GreedyTwoFrameThreshold128),
+ : "m" (GreedyTwoFrameThreshold128),
"m" (*Destc), "r" (T1), "r" (T0), "r" (Pitch) );

asm volatile (
@@ -204,6 +203,7 @@ static void DeinterlaceGreedy2Frame_SSE2
"psubusb %%xmm3, %%xmm2 \n\t"
"por %%xmm2, %%xmm4 \n\t"

+ "movdqa (%0), %%xmm0 \n\t" /* xmm0 = M1 */
"movdqa (%1), %%xmm2 \n\t" /* xmm2 = M0 */

/* if |B1-B0| > Threshold we want 0 else dword minus one */

0 comments on commit d2b79ef

Please sign in to comment.