forked from NetBSD/pkgsrc
-
Notifications
You must be signed in to change notification settings - Fork 50
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
pkgsrc changes: - Fix a typo in DISTNAME/PKGNAME: it is now go-ffuf (instead of go-fuff) - Only installs bin/ffuf and its README - Reset MAINTAINERship, requested by <nikita> Changes: 1.1.0 ----- - Add unsupported arch/os to goreleaser ignore list (#267) - Release 1.1 (#266) - Fix crash with 3xx requests without location header (#265) - Update random seed logic (#262) - fix file get thing (#226) - Update CONTRIBUTORS.md to add bsysop (#258) - Fixed behavior of wordlist:keyword separator in Windows (#240) - Add Host information to JSON output file (#223) - Support outputting all file formats concurrently (#218) - Increase default rows per page on html report (#217) - Add the wordlists to the header information (#211) - Fix error with missing usage info (#195) - Feature178 (#186) - Fix for #193 (#194) - Fix for issue #179 (#180) - Prepare for 1.1.0-git (#176)
- Loading branch information
Showing
3 changed files
with
17 additions
and
61 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,19 +1,24 @@ | ||
# $NetBSD: Makefile,v 1.5 2020/09/03 07:29:33 bsiegert Exp $ | ||
# $NetBSD: Makefile,v 1.6 2020/09/03 11:01:38 leot Exp $ | ||
|
||
GITHUB_TAG= v${PKGVERSION_NOREV} | ||
DISTNAME= go-fuff-1.0.2 | ||
PKGREVISION= 4 | ||
DISTNAME= go-ffuf-1.1.0 | ||
CATEGORIES= www | ||
MASTER_SITES= ${MASTER_SITE_GITHUB:=ffuf/} | ||
GITHUB_PROJECT= ffuf | ||
GITHUB_TAG= v${PKGVERSION_NOREV} | ||
|
||
MAINTAINER= nikita@NetBSD.org | ||
MAINTAINER= pkgsrc-users@NetBSD.org | ||
HOMEPAGE= https://github.com/ffuf/ffuf/ | ||
COMMENT= Fast web fuzzer | ||
LICENSE= mit | ||
|
||
GO_SRCPATH= github.com/ffuf/ffuf | ||
GO_DIST_BASE= ffuf-${PKGVERSION_NOREV} | ||
|
||
INSTALLATION_DIRS+= bin share/doc/go-ffuf | ||
|
||
do-install: | ||
${INSTALL_PROGRAM} ${WRKDIR}/bin/ffuf ${DESTDIR}${PREFIX}/bin | ||
${INSTALL_DATA} ${WRKSRC}/README.md ${DESTDIR}${PREFIX}/share/doc/go-ffuf | ||
|
||
.include "../../lang/go/go-package.mk" | ||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,52 +1,3 @@ | ||
@comment $NetBSD: PLIST,v 1.1 2020/05/14 10:36:50 nikita Exp $ | ||
@comment $NetBSD: PLIST,v 1.2 2020/09/03 11:01:38 leot Exp $ | ||
bin/ffuf | ||
gopkg/pkg/${GO_PLATFORM}/github.com/ffuf/ffuf/pkg/ffuf.a | ||
gopkg/pkg/${GO_PLATFORM}/github.com/ffuf/ffuf/pkg/filter.a | ||
gopkg/pkg/${GO_PLATFORM}/github.com/ffuf/ffuf/pkg/input.a | ||
gopkg/pkg/${GO_PLATFORM}/github.com/ffuf/ffuf/pkg/output.a | ||
gopkg/pkg/${GO_PLATFORM}/github.com/ffuf/ffuf/pkg/runner.a | ||
gopkg/src/github.com/ffuf/ffuf/CHANGELOG.md | ||
gopkg/src/github.com/ffuf/ffuf/CONTRIBUTORS.md | ||
gopkg/src/github.com/ffuf/ffuf/LICENSE | ||
gopkg/src/github.com/ffuf/ffuf/README.md | ||
gopkg/src/github.com/ffuf/ffuf/go.mod | ||
gopkg/src/github.com/ffuf/ffuf/help.go | ||
gopkg/src/github.com/ffuf/ffuf/main.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/ffuf/config.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/ffuf/const.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/ffuf/interfaces.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/ffuf/job.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/ffuf/multierror.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/ffuf/optrange.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/ffuf/progress.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/ffuf/request.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/ffuf/response.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/ffuf/util.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/ffuf/valuerange.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/filter/filter.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/filter/filter_test.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/filter/lines.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/filter/lines_test.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/filter/regex.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/filter/regexp_test.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/filter/size.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/filter/size_test.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/filter/status.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/filter/status_test.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/filter/words.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/filter/words_test.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/input/command.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/input/const.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/input/const_windows.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/input/input.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/input/wordlist.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/output/const.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/output/const_windows.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/output/file_csv.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/output/file_html.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/output/file_json.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/output/file_md.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/output/output.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/output/stdout.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/runner/runner.go | ||
gopkg/src/github.com/ffuf/ffuf/pkg/runner/simple.go | ||
share/doc/go-ffuf/README.md |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,6 +1,6 @@ | ||
$NetBSD: distinfo,v 1.1 2020/05/14 10:36:50 nikita Exp $ | ||
$NetBSD: distinfo,v 1.2 2020/09/03 11:01:38 leot Exp $ | ||
|
||
SHA1 (go-fuff-1.0.2.tar.gz) = 92dd3053d36ff23e1b3be7439ec705a5a34ce904 | ||
RMD160 (go-fuff-1.0.2.tar.gz) = 3f54a0de6f9440afb9e66fb01da7d5de6cf4dfbe | ||
SHA512 (go-fuff-1.0.2.tar.gz) = ac5248b99c65ee30647585d95c70b270f4dfdfba6e392f5633f54c1c077d4c8fab7e9e04b76a589ce315371c975f1f055e3ad19baab80782ff453f01897b9d32 | ||
Size (go-fuff-1.0.2.tar.gz) = 30047 bytes | ||
SHA1 (go-ffuf-1.1.0.tar.gz) = d01dec10bc6e9c67bf56130bccab8379d9155cf8 | ||
RMD160 (go-ffuf-1.1.0.tar.gz) = 0bd203334a0d9763c5de30816f563140f291beb4 | ||
SHA512 (go-ffuf-1.1.0.tar.gz) = 759b9009f41cc55626c16b4002382c7bf61dd73df00c979cd5b1fa139efc1b8cf5a39207e8e01a51821da20a1b3ddcc7f27f65257eb43370d1b64f3037eb7081 | ||
Size (go-ffuf-1.1.0.tar.gz) = 31820 bytes |