Skip to content

Commit

Permalink
zig: update to today's (2019-02-27) snapshot of master.
Browse files Browse the repository at this point in the history
Allows us to drop all the local patches that were merged upstream.
lld is not a dependency, zig by default bundles lld and doesn't use
an external one. comment it.

Andrew Kelley (62):
      Merge pull request #1975 from BenoitJGirard/master
      Merge pull request #1963 from matthew-mcallister/dedup-compile-log-warning
      Merge pull request #1972 from coypoop/netbsd
      README: add NetBSD to support table
      pull request fixups
      Merge branch 'emekoi-fix-1711'
      export _mh_execute_header with weak linkage
      docs: note top level declarations are order-independent
      docs: shadowing
      zig fmt: fix infix operator before multiline string literal
      add test for 74bdc1d1f898705
      Merge branch 'kristate-zig-backport-issue1944'
      remove --no-rosegment workaround now that valgrind bug is fixed
      valgrind client requests for undefined values
      Merge branch 'slice-deref-failure' of https://github.com/matthew-mcallister/zig into matthew-mcallister-slice-deref-failure
      pull request fixups
      Merge branch 'matthew-mcallister-slice-deref-failure'
      deduplicate compile errors for undeclared identifiers
      packed structs support comptime bitcasting
      extern structs support comptime bitcasting
      `@sliceToBytes` works at comptime
      better handling of arrays in packed structs
      better field access of types which have one possible value
      fix `@bitCast` when src/dest types have mismatched handle_is_ptr
      docs for packed structs
      add regression test for bitcast to array
      implement vector negation
      better libc detection (#1996)
      introduce std.debug.captureStackTrace
      fix `zig fmt` arg0 handled incorrectly
      add `zig cc` command to act like a C compiler
      zig cc: remove "polly" which was an undefined symbol on macos
      zig cc: work around clang calling GetCommandLine on Windows
      Merge pull request #2003 from ziglang/zig-cc
      first class support for compiling C code
      building DLLs on Windows works better
      `@cImport` works with `--cache on`
      Merge pull request #2005 from ziglang/c-source
      zig build: 2 improvements
      fix infinite recursion in type_has_one_possible_value
      delete incorrect TODO comment
      add docs for zero bit types and pointers to zero bit types
      fix not finding libgcc_s when looking for native libc
      add a compile error note when C import fails and not linking libc
      better error message when forgetting to link against libc
      add a regression test for #704
      fix incorrectly trying to memset at comptime
      fix the libc compile error tests to only run on linux
      use -nobuiltininc when compiling c code
      use -nostdinc++ when compiling C code
      use -nostdinc and sometimes -nolibc when compiling C code
      breaking changes to the way targets work in zig
      fix regressions on Windows
      introduce sys_include_dir for when sys/* files are not with stdlib.h
      add builder.addFmt API and use it to test stage1 zig fmt
      fix .gitignore file and add commit missing std lib file
      add test coverage for binary OR on error sets
      add test coverage for type used as switch case
      fix handling when there are multiple externs and
      fix stage1 zig fmt on macos
      improve docs for unions and switching on tagged unions
      windows returns EINVAL for fopen when there is an asterisk in the name

Benoit Jauvin-Girard (1):
      Fix std.math.powi so powi(x, +-0) = 1 for any x.

BenoitJGirard (2):
      Merge pull request #1 from ziglang/master
      Merge pull request #2 from ziglang/master

Jimmi HC (1):
      Fixed std.testing.expectEqual

John Schmidt (2):
      Some function doc tweaks (#1961)
      Add priority queue

LemonBoy (4):
      Silence gcc8 class-memaccess warnings
      Add align attribute for params pointers
      Translate parameterless C functions (#1978)
      Prevent crash in tagged enums rendering (#1986)

Matthew McAllister (3):
      Fix lvalue dereference type checking
      Deduplicate compile log statement warnings
      Check for duped error messages in compile tests

Maya Rashish (3):
      Add NetBSD support
      Undo local, unneeded patch
      Don't provide a bogus definition of EVFILT_USER

Quetzal Bradley (1):
      fix openWriteNoClobber and add test

emekoi (1):
      make @enumToInt work on union(enum)

kristopher tate (1):
      src/analyze.cpp: default to using `param_node` upon callconv error;
  • Loading branch information
coypoop committed Feb 27, 2019
1 parent bdf788a commit 1cf7f3a
Show file tree
Hide file tree
Showing 25 changed files with 13 additions and 1,871 deletions.
15 changes: 5 additions & 10 deletions lang/zig/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.1 2019/02/17 12:33:40 maya Exp $
# $NetBSD: Makefile,v 1.2 2019/02/27 10:46:16 maya Exp $

DISTNAME= zig-0.3.0+8d2a9029
PKGNAME= zig-0.3.0.20190217
DISTNAME= zig-0.3.0+c59ce046
PKGNAME= zig-0.3.0.20190227
CATEGORIES= lang
MASTER_SITES= https://ziglang.org/builds/
EXTRACT_SUFX= .tar.xz
Expand All @@ -17,13 +17,8 @@ USE_LANGUAGES= c c++
CHECK_PORTABILITY_SKIP+= ci/azure/macos_script
BUILDLINK_TRANSFORM+= rm:-Werror

post-patch:
${CP} ${FILESDIR}/std_c_netbsd.zig ${WRKSRC}/std/c/netbsd.zig
${MKDIR} ${WRKSRC}/std/os/netbsd
${CP} ${FILESDIR}/std_os_netbsd_index.zig ${WRKSRC}/std/os/netbsd/index.zig
${CP} ${FILESDIR}/std_os_netbsd_errno.zig ${WRKSRC}/std/os/netbsd/errno.zig

.include "../../lang/clang/buildlink3.mk"
.include "../../lang/llvm/buildlink3.mk"
.include "../../devel/lld/buildlink3.mk"
# Using builtin lld
#.include "../../devel/lld/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
4 changes: 3 additions & 1 deletion lang/zig/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1 2019/02/17 12:33:40 maya Exp $
@comment $NetBSD: PLIST,v 1.2 2019/02/27 10:46:16 maya Exp $
bin/zig
lib/zig/include/__clang_cuda_builtin_vars.h
lib/zig/include/__clang_cuda_cmath.h
Expand Down Expand Up @@ -130,6 +130,7 @@ lib/zig/std/buf_map.zig
lib/zig/std/buf_set.zig
lib/zig/std/buffer.zig
lib/zig/std/build.zig
lib/zig/std/build/fmt.zig
lib/zig/std/c/darwin.zig
lib/zig/std/c/freebsd.zig
lib/zig/std/c/index.zig
Expand Down Expand Up @@ -291,6 +292,7 @@ lib/zig/std/os/windows/tls.zig
lib/zig/std/os/windows/util.zig
lib/zig/std/os/zen.zig
lib/zig/std/pdb.zig
lib/zig/std/priority_queue.zig
lib/zig/std/rand/index.zig
lib/zig/std/rand/ziggurat.zig
lib/zig/std/segmented_list.zig
Expand Down
29 changes: 5 additions & 24 deletions lang/zig/distinfo
Original file line number Diff line number Diff line change
@@ -1,25 +1,6 @@
$NetBSD: distinfo,v 1.1 2019/02/17 12:33:40 maya Exp $
$NetBSD: distinfo,v 1.2 2019/02/27 10:46:16 maya Exp $

SHA1 (zig-0.3.0+8d2a9029.tar.xz) = feb0fa613fe2618f3821c6da34a22f922eab320e
RMD160 (zig-0.3.0+8d2a9029.tar.xz) = 7389eba74fc0d4e22c62e6bb66d94124e96539f4
SHA512 (zig-0.3.0+8d2a9029.tar.xz) = 036f0499bbff5f0e55c27c151a1b0e028f895cd52683c664e227ff9875cf5989dbb6d0ea754744a47715a601cb9a9b06912bca911dc02e4195944f386e331995
Size (zig-0.3.0+8d2a9029.tar.xz) = 2407768 bytes
SHA1 (patch-CMakeLists.txt) = 550474426ed0db48da88331aab746b2c445010b9
SHA1 (patch-src-self-hosted_libc__installation.zig) = c38b2b0f5dfe879c660f1f148a0a9f765f0faa3f
SHA1 (patch-src_analyze.cpp) = 217f0f97e8f87cbc82800926b333bdd8b464a037
SHA1 (patch-src_codegen.cpp) = a931d048856fdd88bc874d488d06546d8c0b9ed5
SHA1 (patch-src_link.cpp) = 86c03aa8b51c3d2e3db2e894819ad9be063d57bc
SHA1 (patch-src_os.cpp) = 6cf8da29be026f2f27284366e22861a87e26941e
SHA1 (patch-src_os.hpp) = 0b79d1ec64b3d7c38a9b2a11ec109c0221e59871
SHA1 (patch-src_target.cpp) = ff482758b378e0be8060d3b61e94420609de41ac
SHA1 (patch-std_c_index.zig) = f9de821e37c0e8ae0393c6ac1570c74c4ac6faac
SHA1 (patch-std_debug_index.zig) = 0abd1b5c7cc6bdfed7afc2cf6b30fa45856af566
SHA1 (patch-std_event_fs.zig) = 2e00bc3091414620813ef980ce0e4ffd15fd19c3
SHA1 (patch-std_event_loop.zig) = 93cb9faddf3235d1a521e6691231bbca0d9a9c47
SHA1 (patch-std_heap.zig) = 3fc05b17612b7d54e1bdfdfcaecff87756bde74d
SHA1 (patch-std_os_file.zig) = e24a5bc859dfe570ee1113670877384eb2826225
SHA1 (patch-std_os_get__app__data__dir.zig) = 0da532e6d1d6d8c832c3b7e5f996df7923079f28
SHA1 (patch-std_os_get__user__id.zig) = 432dc624afca19932138bf4a2c9234749dd48423
SHA1 (patch-std_os_index.zig) = 84eb9d8ec5c85865a8ad86c0e1891866bfbe4173
SHA1 (patch-std_os_path.zig) = 63616b927b611f0e26e157e4c51630e7155977ba
SHA1 (patch-std_os_time.zig) = c13daf2e8e0f5a6c1a68a9cabe098de673df21a3
SHA1 (zig-0.3.0+c59ce046.tar.xz) = c1a5a262fef10ed12fec379ef209f55bfbd8bde7
RMD160 (zig-0.3.0+c59ce046.tar.xz) = cc2dbc20e860484eab291a722715db017c49a8be
SHA512 (zig-0.3.0+c59ce046.tar.xz) = 285d14ac073b9b054170b9e58cd532d4e56741c3bf25e86615bacf333e5050b3f9f46b967e7742c61e79fe867ef2e7466445450acd8da78f522c1c59b1966607
Size (zig-0.3.0+c59ce046.tar.xz) = 2433064 bytes
116 changes: 0 additions & 116 deletions lang/zig/files/std_c_netbsd.zig

This file was deleted.

134 changes: 0 additions & 134 deletions lang/zig/files/std_os_netbsd_errno.zig

This file was deleted.

Loading

0 comments on commit 1cf7f3a

Please sign in to comment.