forked from NetBSD/pkgsrc
-
Notifications
You must be signed in to change notification settings - Fork 50
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
What's Changed Fix building without duktape by @mattst88 in #180 Fix WITH_GNOME2 documentation by @mattst88 in #181 bindings: perl: Use ccflags from %Config for libproxy module compilation by @Vogtinator in #183 Use XDG_CURRENT_DESKTOP to detect GNOME desktop like systems by @janbrummer in #192 Enable the use of ducktape in Windows systems by @illera88 in #194 Enable static builds for libproxy by @illera88 in #195 Fix build on macOS by @wegank in #189 Complete rewrite by @janbrummer in #201 kde: Remove line breaks in values by @janbrummer in #203 Add man page for proxy tool by @janbrummer in #204 Add PX_FORCE_CONFIG env by @janbrummer in #205 add alert function to pacrunners by @multiSnow in #196 Update architecture documentation by @janbrummer in #206 Check for valid uri_host in ignore_ip() by @janbrummer in #210 Remove line break in debug output by @janbrummer in #211 Improve GNOME/KDE get_config() execution by @janbrummer in #212
- Loading branch information
Showing
8 changed files
with
142 additions
and
63 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,39 +1,42 @@ | ||
# $NetBSD: Makefile,v 1.39 2023/02/27 10:44:34 jperkin Exp $ | ||
# $NetBSD: Makefile,v 1.40 2023/05/22 20:28:28 wiz Exp $ | ||
|
||
DISTNAME= libproxy-0.4.18 | ||
DISTNAME= libproxy-0.5.0 | ||
CATEGORIES= www gnome | ||
MASTER_SITES= ${MASTER_SITE_GITHUB:=libproxy/} | ||
GITHUB_RELEASE= ${PKGVERSION_NOREV} | ||
EXTRACT_SUFX= .tar.xz | ||
GITHUB_TAG= ${DISTNAME} | ||
|
||
MAINTAINER= pkgsrc-users@NetBSD.org | ||
HOMEPAGE= https://libproxy.github.io/libproxy/ | ||
COMMENT= Library that provides automatic proxy configuration management | ||
LICENSE= gnu-lgpl-v2.1 | ||
|
||
USE_LANGUAGES= c99 c++11 | ||
USE_TOOLS+= pkg-config | ||
USE_TOOLS+= bash:build pkg-config | ||
|
||
CMAKE_ARGS+= -DWITH_PERL:BOOL=OFF | ||
CMAKE_ARGS+= -DWITH_PYTHON2:BOOL=OFF | ||
CMAKE_ARGS+= -DWITH_PYTHON3:BOOL=OFF | ||
CMAKE_ARGS+= -DWITH_KDE:BOOL=OFF | ||
PKGCONFIG_OVERRIDE+= output/meson-private/libproxy-1.0.pc | ||
PKGCONFIG_OVERRIDE_STAGE= post-configure | ||
|
||
# Need socket libraries on SunOS for both the shared library and test programs. | ||
CMAKE_ARGS.SunOS+= -DCMAKE_EXE_LINKER_FLAGS:STRING="-lnsl -lsocket -L${PREFIX}/lib ${COMPILER_RPATH_FLAG}${PREFIX}/lib" | ||
CMAKE_ARGS.SunOS+= -DCMAKE_SHARED_LINKER_FLAGS:STRING="-lnsl -lsocket -L${PREFIX}/lib ${COMPILER_RPATH_FLAG}${PREFIX}/lib" | ||
|
||
BUILDLINK_TRANSFORM.SunOS+= rm:-Wl,--no-as-needed | ||
BUILDLINK_TRANSFORM.SunOS+= rm:-Wl,--version-script | ||
BUILDLINK_TRANSFORM.SunOS+= rm:-Wl,${WRKSRC}/libproxy/libproxy.map | ||
TEST_TARGET= test | ||
|
||
PKGCONFIG_OVERRIDE+= bindings/csharp/libproxy-sharp-1.0.pc.cmake | ||
PKGCONFIG_OVERRIDE+= libproxy/libproxy-1.0.pc.in | ||
REPLACE_BASH+= data/check-code-style | ||
REPLACE_BASH+= data/install-git-hook.sh | ||
REPLACE_BASH+= data/pre-commit-hook | ||
|
||
TEST_TARGET= test | ||
# see libsoup comment below | ||
MESON_ARGS+= -Dtests=false | ||
|
||
.include "../../devel/cmake/build.mk" | ||
.include "../../devel/meson/build.mk" | ||
.include "../../devel/glib2/buildlink3.mk" | ||
.include "../../devel/gobject-introspection/buildlink3.mk" | ||
.include "../../devel/py-gi-docgen/buildlink3.mk" | ||
.include "../../devel/zlib/buildlink3.mk" | ||
.include "../../lang/libduktape/buildlink3.mk" | ||
.include "../../lang/vala/buildlink3.mk" | ||
# needed for tests, but causes dependency loop via | ||
# libsoup3 -> glib-networking -> libproxy | ||
#.include "../../net/libsoup3/buildlink3.mk" | ||
.include "../../sysutils/gsettings-desktop-schemas/buildlink3.mk" | ||
.include "../../www/curl/buildlink3.mk" | ||
.include "../../mk/dlopen.buildlink3.mk" | ||
.include "../../mk/pthread.buildlink3.mk" | ||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,8 +1,70 @@ | ||
@comment $NetBSD: PLIST,v 1.4 2013/05/24 18:22:57 wiz Exp $ | ||
@comment $NetBSD: PLIST,v 1.5 2023/05/22 20:28:28 wiz Exp $ | ||
bin/proxy | ||
include/proxy.h | ||
include/libproxy/proxy.h | ||
lib/girepository-1.0/Libproxy-1.0.typelib | ||
lib/libproxy.so | ||
lib/libproxy.so.1 | ||
lib/libproxy.so.1.0.0 | ||
lib/libpxbackend-1.0.so | ||
lib/pkgconfig/libproxy-1.0.pc | ||
share/cmake/Modules/Findlibproxy.cmake | ||
man/man8/proxy.8 | ||
share/doc/libproxy-1.0/RedHatDisplay-Black.woff | ||
share/doc/libproxy-1.0/RedHatDisplay-Black.woff2 | ||
share/doc/libproxy-1.0/RedHatDisplay-BlackItalic.woff | ||
share/doc/libproxy-1.0/RedHatDisplay-BlackItalic.woff2 | ||
share/doc/libproxy-1.0/RedHatDisplay-Bold.woff | ||
share/doc/libproxy-1.0/RedHatDisplay-Bold.woff2 | ||
share/doc/libproxy-1.0/RedHatDisplay-BoldItalic.woff | ||
share/doc/libproxy-1.0/RedHatDisplay-BoldItalic.woff2 | ||
share/doc/libproxy-1.0/RedHatDisplay-Italic.woff | ||
share/doc/libproxy-1.0/RedHatDisplay-Italic.woff2 | ||
share/doc/libproxy-1.0/RedHatDisplay-Medium.woff | ||
share/doc/libproxy-1.0/RedHatDisplay-Medium.woff2 | ||
share/doc/libproxy-1.0/RedHatDisplay-MediumItalic.woff | ||
share/doc/libproxy-1.0/RedHatDisplay-MediumItalic.woff2 | ||
share/doc/libproxy-1.0/RedHatDisplay-Regular.woff | ||
share/doc/libproxy-1.0/RedHatDisplay-Regular.woff2 | ||
share/doc/libproxy-1.0/RedHatText-Bold.woff | ||
share/doc/libproxy-1.0/RedHatText-Bold.woff2 | ||
share/doc/libproxy-1.0/RedHatText-BoldItalic.woff | ||
share/doc/libproxy-1.0/RedHatText-BoldItalic.woff2 | ||
share/doc/libproxy-1.0/RedHatText-Italic.woff | ||
share/doc/libproxy-1.0/RedHatText-Italic.woff2 | ||
share/doc/libproxy-1.0/RedHatText-Medium.woff | ||
share/doc/libproxy-1.0/RedHatText-Medium.woff2 | ||
share/doc/libproxy-1.0/RedHatText-MediumItalic.woff | ||
share/doc/libproxy-1.0/RedHatText-MediumItalic.woff2 | ||
share/doc/libproxy-1.0/RedHatText-Regular.woff | ||
share/doc/libproxy-1.0/RedHatText-Regular.woff2 | ||
share/doc/libproxy-1.0/SourceCodePro-It.ttf.woff | ||
share/doc/libproxy-1.0/SourceCodePro-Regular.ttf.woff | ||
share/doc/libproxy-1.0/SourceCodePro-Semibold.ttf.woff | ||
share/doc/libproxy-1.0/applications.html | ||
share/doc/libproxy-1.0/architecture.html | ||
share/doc/libproxy-1.0/build-steps.html | ||
share/doc/libproxy-1.0/classes_hierarchy.html | ||
share/doc/libproxy-1.0/configuration-logic.html | ||
share/doc/libproxy-1.0/ctor.ProxyFactory.new.html | ||
share/doc/libproxy-1.0/fonts.css | ||
share/doc/libproxy-1.0/fzy.js | ||
share/doc/libproxy-1.0/go-up-symbolic.png | ||
share/doc/libproxy-1.0/index.html | ||
share/doc/libproxy-1.0/index.json | ||
share/doc/libproxy-1.0/libproxy-1.0.devhelp2 | ||
share/doc/libproxy-1.0/libproxy.svg | ||
share/doc/libproxy-1.0/main.js | ||
share/doc/libproxy-1.0/method.ProxyFactory.free.html | ||
share/doc/libproxy-1.0/method.ProxyFactory.get_proxies.html | ||
share/doc/libproxy-1.0/perl.html | ||
share/doc/libproxy-1.0/proxy-authentication.html | ||
share/doc/libproxy-1.0/python.html | ||
share/doc/libproxy-1.0/ruby.html | ||
share/doc/libproxy-1.0/search.js | ||
share/doc/libproxy-1.0/solarized-dark.css | ||
share/doc/libproxy-1.0/solarized-light.css | ||
share/doc/libproxy-1.0/struct.ProxyFactory.html | ||
share/doc/libproxy-1.0/style.css | ||
share/doc/libproxy-1.0/type_func.ProxyFactory.free_proxies.html | ||
share/doc/libproxy-1.0/vala.html | ||
share/gir-1.0/Libproxy-1.0.gir | ||
share/vala/vapi/libproxy-1.0.deps | ||
share/vala/vapi/libproxy-1.0.vapi |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,7 +1,7 @@ | ||
$NetBSD: distinfo,v 1.24 2023/02/20 09:22:07 adam Exp $ | ||
$NetBSD: distinfo,v 1.25 2023/05/22 20:28:28 wiz Exp $ | ||
|
||
BLAKE2s (libproxy-0.4.18.tar.xz) = 75018b45a53d7c93b13f48f6d4769aee769743c357c46d2866323f0f22f19b96 | ||
SHA512 (libproxy-0.4.18.tar.xz) = 0c6b138bc8da9abcf21e091b876527cfff0703800995363e5a46c29a2a9caa2946c45b299abed6129b314461123949dae387456a0cddcbb0b29a84b9b55f499c | ||
Size (libproxy-0.4.18.tar.xz) = 82020 bytes | ||
SHA1 (patch-libproxy_CMakeLists.txt) = fc283f97eebf0ef0cfbd81341a7db311755ab2ec | ||
SHA1 (patch-libproxy_cmake_pkgconfig.cmk) = 877584ca6df55bcebc3739d08dc7ae6a7ae79edf | ||
BLAKE2s (libproxy-0.5.0.tar.gz) = 4ed621c85760f691a47513b3b00515b370389d0f774a0c23da247d0c0629b4c9 | ||
SHA512 (libproxy-0.5.0.tar.gz) = 699d09d747c3e56247b1d0a8dee0cd7c122199cc4296aa61753a4e52b4346ad5d98d608f953d28a5779e7d49f64be639e22c696ac82d48bbdaa7b743501b18e6 | ||
Size (libproxy-0.5.0.tar.gz) = 58746 bytes | ||
SHA1 (patch-src_backend_plugins_pacrunner-duktape_pacrunner-duktape.c) = fb9a76af07848e2a3205a872cd7067e94653701b | ||
SHA1 (patch-src_libproxy_proxy.h) = 213e4496209521105cadbe95f85c6a03843907e4 |
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
16 changes: 16 additions & 0 deletions
16
www/libproxy/patches/patch-src_backend_plugins_pacrunner-duktape_pacrunner-duktape.c
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,16 @@ | ||
$NetBSD: patch-src_backend_plugins_pacrunner-duktape_pacrunner-duktape.c,v 1.1 2023/05/22 20:28:28 wiz Exp $ | ||
|
||
Fix build on NetBSD | ||
https://github.com/libproxy/libproxy/issues/219 | ||
|
||
--- src/backend/plugins/pacrunner-duktape/pacrunner-duktape.c.orig 2023-05-15 13:09:42.000000000 +0000 | ||
+++ src/backend/plugins/pacrunner-duktape/pacrunner-duktape.c | ||
@@ -28,6 +28,8 @@ | ||
#include <netdb.h> | ||
#endif | ||
|
||
+#include <netinet/in.h> | ||
+ | ||
#include "pacrunner-duktape.h" | ||
#include "pacutils.h" | ||
#include "px-plugin-pacrunner.h" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
$NetBSD: patch-src_libproxy_proxy.h,v 1.1 2023/05/22 20:28:28 wiz Exp $ | ||
|
||
Fix C++ usage of header. | ||
https://github.com/libproxy/libproxy/issues/226 | ||
|
||
Fix Use glib-object header instead of gio | ||
https://github.com/libproxy/libproxy/issues/230 | ||
|
||
--- src/libproxy/proxy.h.orig 2023-05-15 13:09:42.000000000 +0000 | ||
+++ src/libproxy/proxy.h | ||
@@ -22,12 +22,12 @@ | ||
|
||
#pragma once | ||
|
||
+#include <glib-object.h> | ||
+ | ||
#ifdef __cplusplus | ||
extern "C" { | ||
#endif | ||
|
||
-#include <gio/gio.h> | ||
- | ||
/** | ||
* SECTION:px-proxy | ||
* @short_description: A convient helper for using proxy servers |