Skip to content

Commit

Permalink
py-setuptools: update to 47.3.2.
Browse files Browse the repository at this point in the history
v47.3.2
-------

* #2071: Replaced references to the deprecated imp package with references to importlib


v47.3.1
-------

* #1973: Removed ``pkg_resources.py31compat.makedirs`` in favor of the stdlib. Use ``os.makedirs()`` instead.
* #2198: Restore ``__requires__`` directive in easy-install wrapper scripts.


v47.3.0
-------

* #2197: Console script wrapper for editable installs now has a unified template and honors importlib_metadata if present for faster script execution on older Pythons.
* #2195: Fix broken entry points generated by easy-install (pip editable installs).


v47.2.0
-------

* #2194: Editable-installed entry points now load significantly faster on Python versions 3.8+.


v47.1.1
-------

* #2156: Update mailing list pointer in developer docs

Incorporate changes from v44.1.1:

* #2158: Avoid loading working set during ``Distribution.finalize_options`` prior to invoking ``_install_setup_requires``, broken since v42.0.0.


v44.1.1
-------

* #2158: Avoid loading working set during ``Distribution.finalize_options`` prior to invoking ``_install_setup_requires``, broken since v42.0.0.


v47.1.0
-------

* #2070: In wheel-to-egg conversion, use simple pkg_resources-style namespace declaration for packages that declare namespace_packages.


v47.0.0
-------

* #2094: Setuptools now actively crashes under Python 2. Python 3.5 or later is required. Users of Python 2 should use ``setuptools<45``.
* #1700: Document all supported keywords by migrating the ones from distutils.


v46.4.0
-------

* #1753: ``attr:`` now extracts variables through rudimentary examination of the AST,
  thereby supporting modules with third-party imports. If examining the AST
  fails to find the variable, ``attr:`` falls back to the old behavior of
  importing the module. Works on Python 3 only.


v46.3.1
-------

No significant changes.


v46.3.0
-------

* #2089: Package index functionality no longer attempts to remove an md5 fragment from the index URL. This functionality, added for distribute #163 is no longer relevant.
* #2041: Preserve file modes during pkg files copying, but clear read only flag for target afterwards.
* #2105: Filter ``2to3`` deprecation warnings from ``TestDevelop.test_2to3_user_mode``.


v46.2.0
-------

* #2040: Deprecated the ``bdist_wininst`` command. Binary packages should be built as wheels instead.
* #2062: Change 'Mac OS X' to 'macOS' in code.
* #2075: Stop recognizing files ending with ``.dist-info`` as distribution metadata.
* #2086: Deprecate 'use_2to3' functionality. Packagers are encouraged to use single-source solutions or build tool chains to manage conversions outside of setuptools.
* #1698: Added documentation for ``build_meta`` (a bare minimum, not completed).
* #2082: Filter ``lib2to3`` ``PendingDeprecationWarning`` and ``DeprecationWarning`` in tests,
  because ``lib2to3`` is `deprecated in Python 3.9 <https://bugs.python.org/issue40360>`_.


v46.1.3
-------

No significant changes.


v46.1.2
-------

* #1458: Added template for reporting Python 2 incompatibilities.


v46.1.1
-------

No significant changes.


v46.1.0
-------

* #308: Allow version number normalization to be bypassed by wrapping in a 'setuptools.sic()' call.
* #1424: Prevent keeping files mode for package_data build. It may break a build if user's package data has read only flag.
* #1431: In ``easy_install.check_site_dir``, ensure the installation directory exists.
* #1563: In ``pkg_resources`` prefer ``find_spec`` (PEP 451) to ``find_module``.

Incorporate changes from v44.1.0:

* #1704: Set sys.argv[0] in setup script run by build_meta.__legacy__
* #1959: Fix for Python 4: replace unsafe six.PY3 with six.PY2
* #1994: Fixed a bug in the "setuptools.finalize_distribution_options" hook that lead to ignoring the order attribute of entry points managed by this hook.


v44.1.0
-------

* #1704: Set sys.argv[0] in setup script run by build_meta.__legacy__
* #1959: Fix for Python 4: replace unsafe six.PY3 with six.PY2
* #1994: Fixed a bug in the "setuptools.finalize_distribution_options" hook that lead to ignoring the order attribute of entry points managed by this hook.


v46.0.0
-------

* #65: Once again as in 3.0, removed the Features feature.
* #1890: Fix vendored dependencies so importing ``setuptools.extern.some_module`` gives the same object as ``setuptools._vendor.some_module``. This makes Metadata picklable again.
* #1899: Test suite now fails on warnings.
* #2011: Fix broken link to distutils docs on package_data
* #1991: Include pkg_resources test data in sdist, so tests can be executed from it.


v45.3.0
-------

* #1557: Deprecated eggsecutable scripts and updated docs.
* #1904: Update msvc.py to use CPython 3.8.0 mechanism to find msvc 14+


v45.2.0
-------

* #1905: Fixed defect in _imp, introduced in 41.6.0 when the 'tests' directory is not present.
* #1941: Improve editable installs with PEP 518 build isolation:

  * The ``--user`` option is now always available. A warning is issued if the user site directory is not available.
  * The error shown when the install directory is not in ``PYTHONPATH`` has been turned into a warning.
* #1981: Setuptools now declares its ``tests`` and ``docs`` dependencies in metadata (extras).
* #1985: Add support for installing scripts in environments where bdist_wininst is missing (i.e. Python 3.9).
* #1968: Add flake8-2020 to check for misuse of sys.version or sys.version_info.


v45.1.0
-------

* #1458: Add minimum sunset date and preamble to Python 2 warning.
* #1704: Set sys.argv[0] in setup script run by build_meta.__legacy__
* #1974: Add Python 3 Only Trove Classifier and remove universal wheel declaration for more complete transition from Python 2.


v45.0.0
-------

* #1458: Drop support for Python 2. Setuptools now requires Python 3.5 or later. Install setuptools using pip >=9 or pin to Setuptools <45 to maintain 2.7 support.
* #1959: Fix for Python 4: replace unsafe six.PY3 with six.PY2
  • Loading branch information
0-wiz-0 committed Aug 31, 2020
1 parent fa835ee commit 22c9680
Show file tree
Hide file tree
Showing 3 changed files with 23 additions and 24 deletions.
15 changes: 7 additions & 8 deletions devel/py-setuptools/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,8 @@
# $NetBSD: Makefile,v 1.177 2020/06/01 20:31:03 adam Exp $
# $NetBSD: Makefile,v 1.178 2020/08/31 23:06:02 wiz Exp $

DISTNAME= setuptools-44.1.1
# 48.0.0 and newer are broken on NetBSD
# https://github.com/pypa/setuptools/issues/2364
DISTNAME= setuptools-47.3.2
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_PYPI:=s/setuptools/}
Expand All @@ -13,21 +15,18 @@ LICENSE= python-software-foundation OR zpl-2.0

DEPENDS+= ${PYPKGPREFIX}-expat-[0-9]*:../../textproc/py-expat
TEST_DEPENDS+= ${PYPKGPREFIX}-mock-[0-9]*:../../devel/py-mock
TEST_DEPENDS+= ${PYPKGPREFIX}-paver-[0-9]*:../../lang/py-paver
TEST_DEPENDS+= ${PYPKGPREFIX}-test-fixture-config-[0-9]*:../../devel/py-test-fixture-config
TEST_DEPENDS+= ${PYPKGPREFIX}-test-runner-[0-9]*:../../devel/py-test-runner
TEST_DEPENDS+= ${PYPKGPREFIX}-test-virtualenv-[0-9]*:../../devel/py-test-virtualenv
TEST_DEPENDS+= ${PYPKGPREFIX}-wheel-[0-9]*:../../devel/py-wheel

.include "../../lang/python/distutils.mk"
.if ${_PYTHON_VERSION:M3[6-9]}
TEST_DEPENDS+= ${PYPKGPREFIX}-paver-[0-9]*:../../lang/py-paver
.else
TEST_DEPENDS+= ${PYPKGPREFIX}-pathlib2-[0-9]*:../../devel/py-pathlib2
.endif
PYTHON_VERSIONS_INCOMPATIBLE= 27

REPLACE_PYTHON+= setuptools/command/easy_install.py

PYSETUPTESTTARGET= pytest

.include "../../lang/python/application.mk"
.include "../../lang/python/distutils.mk"
.include "../../mk/bsd.pkg.mk"
22 changes: 11 additions & 11 deletions devel/py-setuptools/PLIST
Original file line number Diff line number Diff line change
@@ -1,12 +1,5 @@
@comment $NetBSD: PLIST,v 1.49 2019/11/26 12:41:36 wiz Exp $
@comment $NetBSD: PLIST,v 1.50 2020/08/31 23:06:02 wiz Exp $
bin/easy_install-${PYVERSSUFFIX}
${PYSITELIB}/${EGG_FILE}/PKG-INFO
${PYSITELIB}/${EGG_FILE}/SOURCES.txt
${PYSITELIB}/${EGG_FILE}/dependency_links.txt
${PYSITELIB}/${EGG_FILE}/entry_points.txt
${PYSITELIB}/${EGG_FILE}/requires.txt
${PYSITELIB}/${EGG_FILE}/top_level.txt
${PYSITELIB}/${EGG_FILE}/zip-safe
${PYSITELIB}/easy_install.py
${PYSITELIB}/easy_install.pyc
${PYSITELIB}/easy_install.pyo
Expand Down Expand Up @@ -55,9 +48,16 @@ ${PYSITELIB}/pkg_resources/_vendor/six.pyo
${PYSITELIB}/pkg_resources/extern/__init__.py
${PYSITELIB}/pkg_resources/extern/__init__.pyc
${PYSITELIB}/pkg_resources/extern/__init__.pyo
${PYSITELIB}/pkg_resources/py31compat.py
${PYSITELIB}/pkg_resources/py31compat.pyc
${PYSITELIB}/pkg_resources/py31compat.pyo
${PYSITELIB}/pkg_resources/py2_warn.py
${PYSITELIB}/pkg_resources/py2_warn.pyc
${PYSITELIB}/pkg_resources/py2_warn.pyo
${PYSITELIB}/${EGG_FILE}/PKG-INFO
${PYSITELIB}/${EGG_FILE}/SOURCES.txt
${PYSITELIB}/${EGG_FILE}/dependency_links.txt
${PYSITELIB}/${EGG_FILE}/entry_points.txt
${PYSITELIB}/${EGG_FILE}/requires.txt
${PYSITELIB}/${EGG_FILE}/top_level.txt
${PYSITELIB}/${EGG_FILE}/zip-safe
${PYSITELIB}/setuptools/__init__.py
${PYSITELIB}/setuptools/__init__.pyc
${PYSITELIB}/setuptools/__init__.pyo
Expand Down
10 changes: 5 additions & 5 deletions devel/py-setuptools/distinfo
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.155 2020/06/01 20:31:03 adam Exp $
$NetBSD: distinfo,v 1.156 2020/08/31 23:06:02 wiz Exp $

SHA1 (setuptools-44.1.1.zip) = d1ba6f62520e09956bc3163291a26b185fdff2c6
RMD160 (setuptools-44.1.1.zip) = f8af333dabae2df9fba6f02dc2d22249b15d83e8
SHA512 (setuptools-44.1.1.zip) = ef19bfbbab4d1fb31156c6820f3469304193d8bc76bb0a2260094e2e724af8af89a5845179275f37f8edd807074145c1e79f7e3e3e5e48a2cac6744af1bf3db2
Size (setuptools-44.1.1.zip) = 858770 bytes
SHA1 (setuptools-47.3.2.zip) = 3fafd8bd0bd38ca7583b42c9a44c9ba562af4be6
RMD160 (setuptools-47.3.2.zip) = 0fa7da65cf1f562f32a91dc08e5999ace1b44c8d
SHA512 (setuptools-47.3.2.zip) = 9efe296b08f98a3b38e0650bf67f6ef6f6d2f41b88c2646c2f3e45ba4ab76e2171bd220979c3002cf08cf0d2dab135b13d0a38181102ed3f579ca88f84f59038
Size (setuptools-47.3.2.zip) = 869998 bytes
SHA1 (patch-setup.py) = dd94c9a4e15b8b0dc428515f73369ed168b8c7b2

0 comments on commit 22c9680

Please sign in to comment.