Skip to content

Commit

Permalink
Update to yaml-0.11.2.0
Browse files Browse the repository at this point in the history
0.11.2.0
* Reduces some of the code duplication between the encode and
  encodePretty functions
* The output of encodePretty has been improved:
  * Multiline strings now use Literal style instead of SingleQuoted
  * Special keys are now quoted in mappings #179
* Support for complex keys in mappings: #182
  * Adds complexMapping function to Data.Yaml.Builder
  * Decode functions now return a NonStringKey error when attempting
    to decode a mapping with a complex key as it is not possible to
    decode these to an Aeson Value
* Adds missing ToYaml instances

0.11.1.2
* Compiles with GHC 8.8.1 (MonadFail split)

0.11.1.1
* Use the appropriate Scientific rendering function to avoid a memory
  overflow when rendering. The previously used function from aeson
  would not use scientific notation, and could use large amounts of
  memory for values such as 1e9999999999999.

0.11.1.0
* Better error messages in the Data.Yaml.Config module #168
* Add LoadSettingsException exception and remove error printing from
  loadYamlSettings #172

0.11.0.0
* Split out the libyaml and Text.Libyaml code into its own
  package. #145

0.10.4.0
* Add decodeMarked and decodeFileMarked functions to Text.Libyaml, and
  extend native bindings to extract mark information. #157

0.10.3.0
* Add support for anchors and aliases to Data.Yaml.Builder #155
* Fix test suite for 32 bit machines #158

0.10.2.0
* Add EncodeOptions and FormatOptions to control the style of the
  encoded YAML. #153
* Default to using literal style for multiline strings #152

0.10.1.1
* Correctly declare libyaml dependency on system-libyaml flag #151

0.10.1
* Avoid incurring a semigroups dependency on recent GHCs.
* Fix a space leak that was introduced with 0.10.0 #147

0.10.0
* Add decodeFileWithWarnings which returns warnings for duplicate
  fields

0.9.0
* Expose style and tags on mappings and sequences in Text.Libyaml #141

0.8.32

* Escape keys as necessary #137
* Support hexadecimal and octal number values #135
* More resilient isNumeric (should reduce cases of unneeded quoting)
* hpackify
* src subdir

0.8.31.1
* Add a workaround for a cabal bug haskell-infra/hackage-trustees#165

0.8.31
* Add decodeThrow and decodeFileThrow convenience functions.
* Upgrade libyaml versions
* Deprecate decode and decodeEither
  • Loading branch information
depressed-pho committed Jan 11, 2020
1 parent fe1478a commit 2b9c047
Show file tree
Hide file tree
Showing 3 changed files with 12 additions and 20 deletions.
11 changes: 3 additions & 8 deletions textproc/hs-yaml/Makefile
Original file line number Diff line number Diff line change
@@ -1,23 +1,18 @@
# $NetBSD: Makefile,v 1.1 2020/01/03 08:03:05 pho Exp $
# $NetBSD: Makefile,v 1.2 2020/01/11 11:08:49 pho Exp $

DISTNAME= yaml-0.8.30
DISTNAME= yaml-0.11.2.0
CATEGORIES= textproc

MAINTAINER= szptvlfn@NetBSD.org
COMMENT= Support for parsing and rendering YAML document
LICENSE= modified-bsd

CONFIGURE_ARGS+= -f system-libyaml

.include "../../mk/haskell.mk"
.include "../../converters/hs-aeson/buildlink3.mk"
.include "../../textproc/hs-attoparsec/buildlink3.mk"
.include "../../devel/hs-conduit/buildlink3.mk"
.include "../../textproc/hs-libyaml/buildlink3.mk"
.include "../../devel/hs-resourcet/buildlink3.mk"
.include "../../math/hs-scientific/buildlink3.mk"
.include "../../math/hs-semigroups/buildlink3.mk"
.include "../../devel/hs-text/buildlink3.mk"
.include "../../devel/hs-unordered-containers/buildlink3.mk"
.include "../../devel/hs-vector/buildlink3.mk"
.include "../../textproc/libyaml/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
11 changes: 4 additions & 7 deletions textproc/hs-yaml/buildlink3.mk
Original file line number Diff line number Diff line change
@@ -1,24 +1,21 @@
# $NetBSD: buildlink3.mk,v 1.1 2020/01/03 08:03:05 pho Exp $
# $NetBSD: buildlink3.mk,v 1.2 2020/01/11 11:08:49 pho Exp $

BUILDLINK_TREE+= hs-yaml

.if !defined(HS_YAML_BUILDLINK3_MK)
HS_YAML_BUILDLINK3_MK:=

BUILDLINK_API_DEPENDS.hs-yaml+= hs-yaml>=0.8.30
BUILDLINK_ABI_DEPENDS.hs-yaml+= hs-yaml>=0.8.30
BUILDLINK_API_DEPENDS.hs-yaml+= hs-yaml>=0.11.2
BUILDLINK_ABI_DEPENDS.hs-yaml+= hs-yaml>=0.11.2.0
BUILDLINK_PKGSRCDIR.hs-yaml?= ../../textproc/hs-yaml

.include "../../converters/hs-aeson/buildlink3.mk"
.include "../../textproc/hs-attoparsec/buildlink3.mk"
.include "../../devel/hs-conduit/buildlink3.mk"
.include "../../textproc/hs-libyaml/buildlink3.mk"
.include "../../devel/hs-resourcet/buildlink3.mk"
.include "../../math/hs-scientific/buildlink3.mk"
.include "../../math/hs-semigroups/buildlink3.mk"
.include "../../devel/hs-text/buildlink3.mk"
.include "../../devel/hs-unordered-containers/buildlink3.mk"
.include "../../devel/hs-vector/buildlink3.mk"
.include "../../textproc/libyaml/buildlink3.mk"
.endif # HS_YAML_BUILDLINK3_MK

BUILDLINK_TREE+= -hs-yaml
10 changes: 5 additions & 5 deletions textproc/hs-yaml/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.1 2020/01/03 08:03:05 pho Exp $
$NetBSD: distinfo,v 1.2 2020/01/11 11:08:49 pho Exp $

SHA1 (yaml-0.8.30.tar.gz) = df6be741ae033aa42929558b5d3b93a45edb4f2e
RMD160 (yaml-0.8.30.tar.gz) = fd75559e36811fb81f58b05916d787934f4a7986
SHA512 (yaml-0.8.30.tar.gz) = 15ec8fcde602f42ca4622f3ffec03ab5b7712fc558519bf37c1b3fa7c3c969b5a4dfbcf5008fbda158ab952b36bb8dce666c70bf5727acdd2188ae42f8691668
Size (yaml-0.8.30.tar.gz) = 82706 bytes
SHA1 (yaml-0.11.2.0.tar.gz) = ecdab5d66b3a6dd819bdf1f29b3a46645a50545b
RMD160 (yaml-0.11.2.0.tar.gz) = 850998cf5f5d86634f177dd51e4732b3affe8406
SHA512 (yaml-0.11.2.0.tar.gz) = b90580ca37066401558c1a19148f70f6153a7f44f65ade99827adf20a4ba04edb8a9d6101b507014b92970d4bbe89c0fd89792a62206a2fbdc7ae5ff08915885
Size (yaml-0.11.2.0.tar.gz) = 29254 bytes

0 comments on commit 2b9c047

Please sign in to comment.