Skip to content

Commit

Permalink
audio/termusic: update to 0.9.0
Browse files Browse the repository at this point in the history
[v0.9.0] - Released on: March 24, 2024.
 - Big thanks to the contribution of hasezoey. A lot of improvements and refactors in this release. Especially now you can change backends without recompile.
 - Change: updated MSRV to 1.74.
 - Change: better Error messages if the server binary cannot be started.
 - Change: small optimizations.
 - Change: change almost all eprintln to be log::error.
 - Change: change almost all println to be appropriate log levels.
 - Feat: change logger to be flexi_logger, including logging to file.
 - Feat: add cli arguments to the server binary.
 - Feat: add a lot more metadata to media controls, like cover art, duration, seek, volume(RW), quit.
 - Feat: support mkv & webm in backend rusty (no metadata, support depends on codec).
 - Feat: in backend rusty, buffer files in 4Mb chunks.
 - Feat: better version via --version.
 - Feat: allow specifiying which interface (ip) to run on.
 - Feat(server): allow compiling multiple backends via features and select at binary start (via --backend or TMS_BACKEND).
 - Feat(server): for backend mpv, switch to use libmpv-sirno and use mpv API 2.0.
 - Feat(server): for backend mpv and gstreamer, speed change without changing pitch is great for podcasts.
 - Feat(tui): add a "currently playing" symbol to active track in playlist.
 - Feat(tui): add search function for Podcast Episodes.
 - Feat(tui): allow confirming quit-confirm choices with Y or N.
 - Feat(tui): allow confirming config save confirm choices with Y or N.
 - Fix: try to find the server binary adjacent to the TUI binary.
 - Fix: change many panics to be results instead.
 - Fix: dont panic if "music_dir" value is empty when entering config editor, fixes #161.
 - Fix: log something if a file is not going to be added to the playlist.
 - Fix: in backend rusty, skip all tracks (and packets) that are not the selected track in backend in decode.
 - Fix: in backend rusty, correctly select a audio track (instead of symphonia's default which might be something else).
 - Fix: in backend rusty, when using radio, always use overwrite the last radio title instead of appending.
 - Fix: in backend rusty, when using radio, parse until '; instead of just ', now things like Don't actually work correctly.
 - Fix: in backend rusty, when using radio, dont infinitely save the stream.
 - Fix: in backend rusty, when using radio, now only use 1 stream to get audio and metadata (instead of 2).
 - Fix: in backend gst, fix gapless track change not being tracked correctly, fixes #192.
 - Fix(tui): add panic hook to reset screen before printing backtrace.
 - Fix(tui): dont extra clear screen on quit.
 - Fix(tui): reset screen if a Error(Result) happens and exit properly.
 - Fix(tui): wait until tonic is connected instead of static sleeps.
 - Fix(tui): only display ueberzug "Not found" errors once.
 - Fix(tui): blanket disable ueberzug for windows.
 - Fix(tui): in Database -> Tracks view, display track title instead of filename.
 - Fix(server): log port used.
 - Fix(server): log on quit.
 - Fix(server): properly exit on player thread crash (instead of being pseudo-zombie).
 - Fix(server): potentially fix media display in windows.
 - Fix(server): in backend rusty, fix radio not starting if gapless is enabled and the track changes to be radio (from something else).
 - Fix(server): in backend rusty, fix radio streams not being stopped once they have been skipped.
 - Fix(build): install to $CARGO_HOME/bin instead of always into a static path.
 - a bunch of internal refactors.

[v0.8.0] - Released on: March 23, 2024
 - Yanked as it had been a broken release, see v0.9.0 instead.
  • Loading branch information
0323pin committed Mar 25, 2024
1 parent 9a8bff0 commit 53f95f5
Show file tree
Hide file tree
Showing 3 changed files with 1,495 additions and 1,216 deletions.
5 changes: 2 additions & 3 deletions audio/termusic/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.54 2024/01/30 18:29:16 adam Exp $
# $NetBSD: Makefile,v 1.55 2024/03/25 13:17:59 pin Exp $

DISTNAME= termusic-0.7.11
PKGREVISION= 4
DISTNAME= termusic-0.9.0
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_GITHUB:=tramhao/}
GITHUB_TAG= v${PKGVERSION_NOREV}
Expand Down
Loading

0 comments on commit 53f95f5

Please sign in to comment.