Skip to content

Commit

Permalink
lua-penlight: Update to 1.9.1
Browse files Browse the repository at this point in the history
## 1.9.1 (2020-09-27)

 - fix: dir.walk [#350](lunarmodules/Penlight#350)


## 1.9.1 (2020-09-24)

 - released to superseed the 1.9.0 version which was retagged in git after some
   distro's already had picked it up. This version is identical to 1.8.1.

## 1.8.1 (2020-09-24) (replacing a briefly released but broken 1.9.0 version)

## Fixes

  - In `pl.class`, `_init` can now be inherited from grandparent (or older ancestor) classes. [#289](lunarmodules/Penlight#289)
  - Fixes `dir`, `lexer`, and `permute` to no longer use coroutines. [#344](lunarmodules/Penlight#344)

## 1.8.0 (2020-08-05)

### New features

  - `pretty.debug` quickly dumps a set of values to stdout for debug purposes

### Changes

  - `pretty.write`: now also sorts non-string keys [#319](lunarmodules/Penlight#319)
  - `stringx.count` has an extra option to allow overlapping matches
    [#326](lunarmodules/Penlight#326)
  - added an extra changelog entry for `types.is_empty` on the 1.6.0 changelog, due
    to additional fixed behaviour not called out appropriately [#313](lunarmodules/Penlight#313)
  - `path.packagepath` now returns a proper error message with names tried if
    it fails

### Fixes

  - Fix: `stringx.rfind` now properly works with overlapping matches
    [#314](lunarmodules/Penlight#314)
  - Fix: `package.searchpath` (in module `pl.compat`)
    [#328](lunarmodules/Penlight#328)
  - Fix: `path.isabs` now reports drive + relative-path as `false`, eg. "c:some/path" (Windows only)
  - Fix: OpenResty coroutines, used by `dir.dirtree`, `pl.lexer`, `pl.permute`. If
    available the original coroutine functions are now used [#329](lunarmodules/Penlight#329)
  - Fix: in `pl.strict` also predefine global `_PROMPT2`
  - Fix: in `pl.strict` apply `tostring` to the given name, in case it is not a string.
  - Fix: the lexer would not recognize numbers without leading zero; "-.123".
    See [#315](lunarmodules/Penlight#315)
  • Loading branch information
alarixnia committed Nov 23, 2020
1 parent 7bd4a0f commit 78dd5c5
Show file tree
Hide file tree
Showing 2 changed files with 14 additions and 12 deletions.
16 changes: 9 additions & 7 deletions devel/lua-penlight/Makefile
Original file line number Diff line number Diff line change
@@ -1,33 +1,35 @@
# $NetBSD: Makefile,v 1.16 2020/07/02 10:26:17 nia Exp $
# $NetBSD: Makefile,v 1.17 2020/11/23 20:06:46 nia Exp $
#

DISTNAME= penlight-${PL_VERSION}
PKGNAME= ${DISTNAME:S/penlight/${LUA_PKGPREFIX}-penlight/}
DISTNAME= penlight-1.9.2
PKGNAME= ${LUA_PKGPREFIX}-${DISTNAME}
CATEGORIES= devel lua
MASTER_SITES= ${MASTER_SITE_GITHUB:=stevedonovan/}
GITHUB_TAG= ${PKGVERSION}
GITHUB_PROJECT= ${DISTNAME:S/-${PKGVERSION}//}
GITHUB_TAG= ${PKGVERSION_NOREV}
GITHUB_PROJECT= Penlight

MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://stevedonovan.github.com/Penlight/
COMMENT= Lua libraries for functional programming, OS path management, etc
LICENSE= mit

PL_VERSION= 1.7.0
DIST_SUBDIR= lua-penlight

NO_BUILD= yes
USE_TOOLS+= pax

DEPENDS+= ${LUA_PKGPREFIX}-filesystem-[0-9]*:../../devel/lua-filesystem

WRKSRC= ${WRKDIR}/Penlight-${PL_VERSION}
WRKSRC= ${WRKDIR}/Penlight-${PKGVERSION_NOREV}
INSTALLATION_DIRS+= ${LUA_LDIR}

# XXX Generate documentation with Markdown.
do-install:
cd ${WRKSRC}/lua && find pl ! -type d | \
pax -rw ${DESTDIR}${PREFIX}/${LUA_LDIR}

do-test:
cd ${WRKSRC} && ${LUA_INTERPRETER} run.lua tests

.include "../../lang/lua/module.mk"
.include "../../mk/bsd.pkg.mk"
10 changes: 5 additions & 5 deletions devel/lua-penlight/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.11 2020/02/15 05:50:37 mef Exp $
$NetBSD: distinfo,v 1.12 2020/11/23 20:06:46 nia Exp $

SHA1 (lua-penlight/penlight-1.7.0.tar.gz) = c9b1d1cdba4911438657dbc2a94c0bf08751bdd7
RMD160 (lua-penlight/penlight-1.7.0.tar.gz) = 5950e563a47a91ed81ccfe9224f1b09ec207e1d5
SHA512 (lua-penlight/penlight-1.7.0.tar.gz) = edeb09307c9feb5da6bccd82216a6ad71db988c433245d72d28abb6c555004f77eebba556928b0912937b29ef93e065ad491368041e17730610813de8e595d7d
Size (lua-penlight/penlight-1.7.0.tar.gz) = 384917 bytes
SHA1 (lua-penlight/penlight-1.9.2.tar.gz) = 04d6e6636bc17aa069223652ff7c330f36858ce4
RMD160 (lua-penlight/penlight-1.9.2.tar.gz) = 1d783a4c8a766e3b7e4d4fdc0ec1389f890248b8
SHA512 (lua-penlight/penlight-1.9.2.tar.gz) = 8df26e74f73ccf6dc73546640e1537b63e40357072855f9409e96b2ef8251c25b4653456d1237d5142573618af242e885490aa9750dffb387e4670ed9f3cfa91
Size (lua-penlight/penlight-1.9.2.tar.gz) = 396248 bytes

0 comments on commit 78dd5c5

Please sign in to comment.