Skip to content

Commit

Permalink
tio: update to 1.33.
Browse files Browse the repository at this point in the history
Changes since tio v1.32:

 * Show auto connect status in show configuration

 * Use '#pragma once' in all headers

 * Improve printed output

   Get rid of inconsistencies in the printed output (error printing,
   colors, etc.).

   Prepare for user configurable color.

 * Rename option -i to -L

 * Shorten timestamp

 * Shorten timestamp description

   We do not need the date part of the timestamp. It simply takes up too
   much precious line space. In case of logging to file, one can easily
   conclude the date from the file date information.

 * Replace Travis with circleCI

 * Replace autotools with meson

   To introduce much simpler build configuration which is also easier to
   maintain.

 * Add list serial devices feature

   For convenience, add a --list-devices option which lists the available
   serial devices.

 * Cleanup: Use dot notation for default options struct

 * Update AUTHORS

 * Add command to show version

   The key sequence ctrl-t v will now show the version of tio.

 * Align format of timestamps

 * Add Sylvain as official co-maintainer

Sylvain LAFRASSE:

 * Add '-t' option description for time stamping.

 * Add description for time stamping.

 * Resolved tio/tio#84: Added timestamps in log file if enabled.

attila-v:

 * Refine timestamps with milliseconds and ISO-8601 format (#129).

   * Show milliseconds too in the timestamp (#114) and log file (#124)
   * Change timestamp format to ISO-8601.

Yin Fengwei:

 * Output newline on stdout with hex print mode

   This is to fix the issue #104. The timestamp will always be
   printed at the beginning of line:

   [10:25:56] Switched to hexadecimal mode
   0d 0a 0d [10:25:57] 41 43 52 4e 3a 5c 3e 0d 0a 0d [10:25:58] 41

   is changed to:

   [12:34:56] 45 72 72 6f 72 3a 20 49 6e 76 61 6c 69 64 20
   [12:34:56] 41 43 52 4e 3a 5c 3e
   [12:34:56] 41 43 52 4e 3a 5c 3e
   [12:34:57] 41 43 52 4e 3a 5c 3e 6c 73

Jakob Haufe:

 * Make comparison POSIX compliant

   String comparison with == is not POSIX compliant and can fail with e.g.
   dash.

Henrik Brix Andersen:

 * Add bash completion of tty devices.

 * Add -t/--timestamp to bash completion script.

Henner Zeller:

 * Local echo: show character by character even if stdout buffered.

Björn Stenberg:

 * Show error when failing to open a tty

Alban Bedel:

 * Fix out of tree builds

   Out of tree builds are currently broken because $(top_srcdir)src/include
   is not in the search path. In tree builds are working because autconf add
   $(top_builddir)/src/include to the search path for the generated config.h.
   As $(top_builddir) and $(top_srcdir) are identical during in tree builds
   the search path still end up beeing somehow correct.

   To fix this add -I$(srcdir)/include to the CPPFLAGS in Makefile.am.

Fabrice Fontaine:

 * src/setspeed2.c: fix redefinition of termio

   Include ioctls.h and termbits.h from asm-generic instead of asm to avoid
   build failures.

Erik Moqvist

 * Exit if output speed cannot be set.

Lars Kellogg-Stedman:

 * fflush() after putchar() for print_hex and print_normal

   In order for local echo to work properly, we have to either call
   fflush(stdout) after every character or just disable line buffering.
   This change calls fflush() after putchar().

 * Disable line buffering in stdout

   In order for local echo to work properly, we have to either call
   fflush(stdout) after every character or just disable line buffering.
   This change uses setbuf(stdout, NULL) to do the latter.

George Stark:

 * dont show line state if ioctl failed

 * add serial lines manual control

arichi:

 * Flush every local echo char

   Flush stdout at every char in case it
   happens to be buffered.

Mariusz Midor:

 * Newline: handle booth NL and CR

   Flag ONLCRNL expects code \n after press Enter, but on some systems \r
   is send instead.
  • Loading branch information
fcambus committed Feb 13, 2022
1 parent 279e464 commit 7d4ac75
Show file tree
Hide file tree
Showing 3 changed files with 24 additions and 8 deletions.
8 changes: 4 additions & 4 deletions comms/tio/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.2 2022/02/11 12:14:20 fcambus Exp $
# $NetBSD: Makefile,v 1.3 2022/02/13 21:27:39 fcambus Exp $

DISTNAME= tio-1.32
DISTNAME= tio-1.33
CATEGORIES= comms
MASTER_SITES= ${MASTER_SITE_GITHUB:=tio/}
GITHUB_RELEASE= v${PKGVERSION_NOREV}
Expand All @@ -11,7 +11,7 @@ HOMEPAGE= https://github.com/tio/tio
COMMENT= Simple TTY terminal I/O application
LICENSE= gnu-gpl-v2

GNU_CONFIGURE= yes
CHECK_PORTABILITY_SKIP+= configure
MESON_ARGS+= -Dbashcompletiondir=${PREFIX}/share/bash-completion/completions

.include "../../devel/meson/build.mk"
.include "../../mk/bsd.pkg.mk"
9 changes: 5 additions & 4 deletions comms/tio/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.3 2021/10/26 10:06:06 nia Exp $
$NetBSD: distinfo,v 1.4 2022/02/13 21:27:39 fcambus Exp $

BLAKE2s (tio-1.32.tar.xz) = 0759f74a40dab68d5f5a89b6582bcba2c7ed8c626e01c86a1933e24292a2285c
SHA512 (tio-1.32.tar.xz) = 6ec216ea8e60fe8fb09e3bc378d8178f0d27789ba876e5a763c1eeef7de064831143270e644e64658d3b9acaf3c1b406f1e3331acc4c8bee91fd56851b99941f
Size (tio-1.32.tar.xz) = 88976 bytes
BLAKE2s (tio-1.33.tar.xz) = 91c8b1cb183f202a8f8417a5b8b9e890bf49b35d3b412546705615c2f07980cd
SHA512 (tio-1.33.tar.xz) = aa5eefe8b3d30910af82cc5303b073d914a48cb33088f45799d4f557819d51cfc6d3b04b660728f540f8b0e2b07ff81ec30ad7ae51945c5476bbc936376770d1
Size (tio-1.33.tar.xz) = 1411380 bytes
SHA1 (patch-meson.build) = 5a2dc0471874a80ba02dc729671cb091e6ac1657
15 changes: 15 additions & 0 deletions comms/tio/patches/patch-meson.build
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
$NetBSD: patch-meson.build,v 1.1 2022/02/13 21:27:39 fcambus Exp $

Fix include path for termios.h on NetBSD.

--- meson.build.orig 2022-02-13 20:06:11.931517636 +0000
+++ meson.build
@@ -10,7 +10,7 @@ version_date = '2022-02-13'

# Test for dynamic baudrate configuration interface
compiler = meson.get_compiler('c')
-tcgets2 = compiler.get_define('TCGETS2', prefix: '#include <asm/termios.h>')
+tcgets2 = compiler.get_define('TCGETS2', prefix: '#include <termios.h>')

# Test for supported baudrates
test_baudrates = [

0 comments on commit 7d4ac75

Please sign in to comment.