Skip to content

Commit

Permalink
(geography/R-osmdata) Updated 0.1.6 to 0.2.5
Browse files Browse the repository at this point in the history
0.2.5
===================

## Major changes

- v0.2.4 was removed without notice from CRAN because of #329; this is
  a rapid re-submission

0.2.4
===================

## Minor changes

- Bug fix to stop getbb call to Nominatim returning 405 error (#328)


0.2.3
===================

## Minor changes

- Fix failing test due to changes to 'sp' moving towards deprecation.


0.2.2
===================

## Major changes:
- `osmdata_data_frame` adds columns `osm_center_lat` and
  `osm_center_lon` for `out * center;` queries (#316, #319).

- Add parameters from `opq` to `opq_osm_id`: out, datetime, datetime2,
  adiff, timeout and memsize (#320)

- Fix `available_tags()` function which no longer worked (#322 thanks
  to @boiled-data)

- Implement `out:csv` queries (#321).

## Minor changes

- Fix queries with `!match_case` and only one value (#317).
- Fix queries with multiple features & multiple osm_types (#318).

0.2.1
===================

## Major changes:

- Very soft deprecation of `nodes_only` parameter in `opq` (#308, #312).

## Minor changes

- Couple of minor memory leak bug fixes in `osmdata_data_frame` C++ code.

0.2.0
===================

This release welcomes a new package author @jmaspons. The lists of
changes here gives an overview of the amazing work he has contributed
to this new major version.

## Major changes:

- New `osmdata_data_frame()` function to return non-spatial
  `data.frame` structures directly from overpass; thanks to @jmaspons
  (#285).

- Improved `add_osm_features` so that key-values pairs can be
  submitted as a list, rather than escape-delimited character strings;
  thanks to @elipousson (#277, #278).

- `opq()` can now utilise overpass ability to filter results by area;
  thanks to @jmaspons (#286).

- `opq()` now has additional "out" parameter to control the kinds of
  data returned by overpass; thanks to @jmaspons (#288).

- `opq()` now has additional "osm_types" parameter to provide finer
  control of which kinds of data are returned by overpass; thanks to
  @jmaspons (#295).

- Fix key modifications for non-valid column names and handle
  duplicated column names in `osmdata_*` functions; by @jmaspons
  (#303)

- @elipousson is new package contributor, thanks to the above work.

- @jmaspons is new package author, thanks to #285 (plus most of the
  above, and a whole lot more!)

## Minor changes:

- Downgraded `sp` from "Imports" to "Suggests"; thanks to @jmaspons
  (#302)

- Improved `osm_osm_id()` to accept vectors of ids and types; thanks
  to @jmaspons (#268, #282, #283)

- "get-osmdata.R" file now split into several smaller and more
  manageable files (#306, thanks to @jmaspons)

0.1.10
===================

## Major changes:

- Changed httr dependency for httr2 (#272)

- Removed two authors of code formerly including for stubbing results;
  which is now done via `httptest2` package.

## Minor changes:

- Moved jsonlite from Imports to Suggests (now only used in tests).

0.1.9
===================

## Major changes:

- New function `opq_around` to query features within a specified radius
  *around* a defined location; thanks to @barryrowlingson via #199 and
  @maellecoursonnais via #238
- New vignette on splitting large queries thanks to @Machin6 (via #262)

## Minor changes:

- New dependency on `reproj` package, so that `trim_osmdata()` can be applied
  to re-projected coordinates.

0.1.8
===================

## Minor changes:

- Fix some failing CRAN checks (no change to functionality)


0.1.7
===================

## Minor changes:

- `add_osm_feature` bug fix to revert AND behaviour (#240 thanks to @anthonynorth)
  • Loading branch information
mef committed Nov 29, 2024
1 parent 6a0548c commit c2319b6
Show file tree
Hide file tree
Showing 2 changed files with 25 additions and 11 deletions.
28 changes: 21 additions & 7 deletions geography/R-osmdata/Makefile
Original file line number Diff line number Diff line change
@@ -1,22 +1,36 @@
# $NetBSD: Makefile,v 1.2 2021/09/20 12:27:34 mef Exp $
# $NetBSD: Makefile,v 1.3 2024/11/29 15:31:15 mef Exp $

R_PKGNAME= osmdata
R_PKGVER= 0.1.6
R_PKGVER= 0.2.5
CATEGORIES= geography

MAINTAINER= pkgsrc-users@NetBSD.org
COMMENT= Import 'OpenStreetMap' Data as Simple Features or Spatial Objects
LICENSE= gnu-gpl-v3

DEPENDS+= R-Rcpp-[0-9]*:../../devel/R-Rcpp
DEPENDS+= R-crsmeta-[0-9]*:../../geography/R-crsmeta
DEPENDS+= R-curl>=4.2:../../www/R-curl
DEPENDS+= R-httr>=1.4.1:../../www/R-httr
DEPENDS+= R-httr2-[0-9]*:../../www/R-httr2
DEPENDS+= R-jsonlite>=1.6:../../textproc/R-jsonlite
DEPENDS+= R-lubridate>=1.7.4:../../time/R-lubridate
DEPENDS+= R-magrittr>=1.5:../../devel/R-magrittr
DEPENDS+= R-proj4-[0-9]*:../../geography/R-proj4
DEPENDS+= R-reproj-[0-9]*:../../geography/R-reproj
DEPENDS+= R-rvest>=0.3.5:../../www/R-rvest
DEPENDS+= R-sp>=1.3.1:../../math/R-sp
DEPENDS+= R-tibble>=2.1.3:../../math/R-tibble
DEPENDS+= R-jsonlite>=1.6:../../textproc/R-jsonlite
DEPENDS+= R-xml2>=1.2.2nb1:../../textproc/R-xml2
DEPENDS+= R-lubridate>=1.7.4:../../time/R-lubridate
DEPENDS+= R-curl>=4.2:../../www/R-curl
DEPENDS+= R-httr>=1.4.1:../../www/R-httr
DEPENDS+= R-rvest>=0.3.5:../../www/R-rvest

# Package suggested but not available: 'httptest2'

TEST_DEPENDS+= R-knitr-[0-9]*:../../print/R-knitr
TEST_DEPENDS+= R-markdown-[0-9]*:../../textproc/R-markdown
TEST_DEPENDS+= R-raster-[0-9]*:../../geography/R-raster
TEST_DEPENDS+= R-rmarkdown-[0-9]*:../../textproc/R-rmarkdown
TEST_DEPENDS+= R-sf-[0-9]*:../../geography/R-sf
TEST_DEPENDS+= R-testthat-[0-9]*:../../devel/R-testthat

USE_LANGUAGES= c c++

Expand Down
8 changes: 4 additions & 4 deletions geography/R-osmdata/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.4 2021/10/26 10:45:06 nia Exp $
$NetBSD: distinfo,v 1.5 2024/11/29 15:31:15 mef Exp $

BLAKE2s (R/osmdata_0.1.6.tar.gz) = 1ebe8132597a2546afb9ce2588fe7939ef1236acdd7ded218c1ae8f5b30891aa
SHA512 (R/osmdata_0.1.6.tar.gz) = b60563a84750290245d59caf841fa36a7b7c7a6ed96e517b1ca9536ef7900db780a32f5695c3ce7cc21294705e0b43d8f0b5c29856be6b53212c24cbf8ac0710
Size (R/osmdata_0.1.6.tar.gz) = 2719231 bytes
BLAKE2s (R/osmdata_0.2.5.tar.gz) = d8cb652863083616604f8774eef14f910daf99cdb97a6bc3564849d19151e219
SHA512 (R/osmdata_0.2.5.tar.gz) = c6cbe85f5f0e0e559cc12687b6fb50864f3c942ceef1556fa33df88fbe55f1847610dc98a93dfab6264ff9432dc68d352320bb5ca8256f9407b8aad61687f6ab
Size (R/osmdata_0.2.5.tar.gz) = 2530898 bytes

0 comments on commit c2319b6

Please sign in to comment.