-
Notifications
You must be signed in to change notification settings - Fork 414
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Jesse Visser <jssvssr2000@gmail.com>
- Loading branch information
Showing
3 changed files
with
113 additions
and
0 deletions.
There are no files selected for viewing
4 changes: 4 additions & 0 deletions
4
dynamic-layers/imx708-layer/recipes-kernel/linux/linux-raspberrypi-dev.bbappend
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,4 @@ | ||
SRC_URI += "file://imx708-overlay.dts;subdir=git/arch/${ARCH}/boot/dts/overlays" | ||
|
||
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" | ||
|
105 changes: 105 additions & 0 deletions
105
dynamic-layers/imx708-layer/recipes-kernel/linux/linux-raspberrypi/imx708-overlay.dts
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,105 @@ | ||
// SPDX-License-Identifier: GPL-2.0-only | ||
// Definitions for IMX708 camera module on VC I2C bus | ||
/dts-v1/; | ||
/plugin/; | ||
|
||
#include <dt-bindings/gpio/gpio.h> | ||
|
||
/{ | ||
compatible = "brcm,bcm2835"; | ||
|
||
fragment@0 { | ||
target = <&i2c0if>; | ||
__overlay__ { | ||
status = "okay"; | ||
}; | ||
}; | ||
|
||
clk_frag: fragment@1 { | ||
target = <&cam1_clk>; | ||
__overlay__ { | ||
status = "okay"; | ||
clock-frequency = <24000000>; | ||
}; | ||
}; | ||
|
||
fragment@2 { | ||
target = <&i2c0mux>; | ||
__overlay__ { | ||
status = "okay"; | ||
}; | ||
}; | ||
|
||
reg_frag: fragment@3 { | ||
target = <&cam1_reg>; | ||
cam_reg: __overlay__ { | ||
startup-delay-us = <70000>; | ||
off-on-delay-us = <30000>; | ||
regulator-min-microvolt = <2700000>; | ||
regulator-max-microvolt = <2700000>; | ||
}; | ||
}; | ||
|
||
fragment@4 { | ||
target = <&cam_node>; | ||
__overlay__ { | ||
lens-focus = <&vcm_node>; | ||
}; | ||
}; | ||
|
||
i2c_frag: fragment@100 { | ||
target = <&i2c_csi_dsi>; | ||
__overlay__ { | ||
#address-cells = <1>; | ||
#size-cells = <0>; | ||
status = "okay"; | ||
|
||
#include "imx708.dtsi" | ||
}; | ||
}; | ||
|
||
csi_frag: fragment@101 { | ||
target = <&csi1>; | ||
csi: __overlay__ { | ||
status = "okay"; | ||
brcm,media-controller; | ||
|
||
port { | ||
csi_ep: endpoint { | ||
remote-endpoint = <&cam_endpoint>; | ||
clock-lanes = <0>; | ||
data-lanes = <1 2>; | ||
clock-noncontinuous; | ||
}; | ||
}; | ||
}; | ||
}; | ||
|
||
__overrides__ { | ||
rotation = <&cam_node>,"rotation:0"; | ||
orientation = <&cam_node>,"orientation:0"; | ||
media-controller = <&csi>,"brcm,media-controller?"; | ||
cam0 = <&i2c_frag>, "target:0=",<&i2c_vc>, | ||
<&csi_frag>, "target:0=",<&csi0>, | ||
<&clk_frag>, "target:0=",<&cam0_clk>, | ||
<®_frag>, "target:0=",<&cam0_reg>, | ||
<&cam_node>, "clocks:0=",<&cam0_clk>, | ||
<&cam_node>, "VANA1-supply:0=",<&cam0_reg>, | ||
<&vcm_node>, "VDD-supply:0=",<&cam0_reg>; | ||
vcm = <&vcm_node>, "status", | ||
<0>, "=4"; | ||
link-frequency = <&cam_endpoint>,"link-frequencies#0"; | ||
}; | ||
}; | ||
|
||
&cam_node { | ||
status = "okay"; | ||
}; | ||
|
||
&cam_endpoint { | ||
remote-endpoint = <&csi_ep>; | ||
}; | ||
|
||
&vcm_node { | ||
status = "okay"; | ||
}; |
4 changes: 4 additions & 0 deletions
4
dynamic-layers/imx708-layer/recipes-kernel/linux/linux-raspberrypi_5.10.bbappend
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,4 @@ | ||
SRC_URI += "file://imx708-overlay.dts;subdir=git/arch/${ARCH}/boot/dts/overlays" | ||
|
||
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" | ||
|