Skip to content

Commit

Permalink
community/stlink: upgrade to 1.6.1
Browse files Browse the repository at this point in the history
  • Loading branch information
nmeum committed May 31, 2020
1 parent 3577586 commit a0c1b08
Show file tree
Hide file tree
Showing 3 changed files with 55 additions and 4 deletions.
24 changes: 24 additions & 0 deletions community/stlink/0001-doc-man-Fix-installation-directory.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
From 2016590502558caa98c21abad2ce83c5f4804a98 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
Date: Mon, 1 Jun 2020 00:20:26 +0200
Subject: [PATCH] doc/man: Fix installation directory

On Unix-like operating systems man pages are commonly installed to
`/usr/share/man` not `/usr/share/stlink/man`.
---
doc/man/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/doc/man/CMakeLists.txt b/doc/man/CMakeLists.txt
index 23da9e1..9b3c507 100644
--- a/doc/man/CMakeLists.txt
+++ b/doc/man/CMakeLists.txt
@@ -30,7 +30,7 @@ foreach (manpage ${MANPAGES})
endif ()

if (f AND NOT WIN32)
- install(FILES ${f} DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/${PROJECT_NAME}/man/man1)
+ install(FILES ${f} DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/man/man1)
unset(f)
endif ()
endforeach ()
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
From 59d0d1194d47f61db538eb6a1f451673355460a4 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
Date: Mon, 1 Jun 2020 00:27:18 +0200
Subject: [PATCH] CMakeLists.txt: Install pkgconfig files again

---
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8628277..60f9087 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,7 +49,7 @@ find_package(libusb REQUIRED)

## Package configuration (pkg-config) on unix-based systems
if (NOT WIN32 AND NOT CMAKE_CROSSCOMPILING)
- #add_subdirectory(cmake/pkgconfig)
+ add_subdirectory(cmake/pkgconfig)
find_package(PkgConfig)
pkg_check_modules(GTK3 gtk+-3.0)
endif ()
13 changes: 9 additions & 4 deletions community/stlink/APKBUILD
Original file line number Diff line number Diff line change
@@ -1,16 +1,18 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=stlink
pkgver=1.6.0
pkgrel=2
pkgver=1.6.1
pkgrel=0
pkgdesc="STM32 discovery line linux programmer"
url="https://github.com/texane/stlink"
arch="all"
license="MIT"
makedepends="cmake libusb-dev"
options="!check" # upstream doesn't have automated tests
subpackages="$pkgname-doc $pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/texane/stlink/archive/v$pkgver.tar.gz"
source="$pkgname-$pkgver.tar.gz::https://github.com/texane/stlink/archive/v$pkgver.tar.gz
0001-doc-man-Fix-installation-directory.patch
0002-CMakeLists.txt-Install-pkgconfig-files-again.patch"

build() {
if [ "$CBUILD" != "$CHOST" ]; then
Expand All @@ -20,6 +22,7 @@ build() {
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_SHARED_LIBS=True \
-DSTLINK_LIBRARY_PATH=/usr/lib \
-DCMAKE_C_FLAGS="$CFLAGS -Wno-error=cpp" \
$CMAKE_CROSSOPTS .
make -C build
Expand All @@ -36,4 +39,6 @@ package() {
mv "$pkgdir"/etc/udev/rules.d "$pkgdir"/usr/lib/udev
}

sha512sums="0bf2416dac69e490560063714d630c4f549568bd9047113fb334f0841f5db23b97876307be8f0b1731863a2438c9502b9916d0d652c516d50969cb8b2cfa1a15 stlink-1.6.0.tar.gz"
sha512sums="ac7ca0c23cd82a66be3ade4fec2a3fe757e5fc2e1d5c68a81316781a59568261a363efb58f5c529921b1c97185489fca5f1c1c4681098c72fb121b0858916fbc stlink-1.6.1.tar.gz
0825e51e46b65ad5c24d18edcd301823f02e8979dd793ada292eae3ac6d61cd32945a5ba8e102bc320991bbcd2cc5015a909f41e4c0a57aeed39aaff8b96d97f 0001-doc-man-Fix-installation-directory.patch
d31ecbbe5458ac0de20ca26277031c375da73ef600eec305b1c199d21560add6448a6b3086f3c60350d001dcc5f2a1113ed723fbc177c6bd1d02bdd868a9bfe0 0002-CMakeLists.txt-Install-pkgconfig-files-again.patch"

0 comments on commit a0c1b08

Please sign in to comment.