Skip to content

Commit

Permalink
pidgin: refresh patches
Browse files Browse the repository at this point in the history
WARNING: pidgin-2.12.0-r0 do_patch:
Some of the context lines in patches were ignored. This can lead to
incorrectly applied patches.
The context lines in the patches can be updated with devtool:

    devtool modify <recipe>
    devtool finish --force-patch-refresh <recipe> <layer_path>

Then the updated patches and the source tree (in devtool's workspace)
should be reviewed to make sure the patches apply in the correct place
and don't introduce duplicate lines (which can, and does happen
when some of the context is ignored). Further information:
http://lists.openembedded.org/pipermail/openembedded-core/2018-March/148675.html
https://bugzilla.yoctoproject.org/show_bug.cgi?id=10450
Details:
Applying patch sanitize-configure.ac.patch
patching file configure.ac
Hunk openembedded#1 succeeded at 642 with fuzz 1 (offset 170 lines).
Hunk openembedded#2 succeeded at 2397 (offset 537 lines).
Hunk openembedded#3 succeeded at 2429 (offset 537 lines).

Now at patch sanitize-configure.ac.patch

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
  • Loading branch information
shr-project authored and anujm1 committed Apr 9, 2018
1 parent 4a10234 commit da961d9
Show file tree
Hide file tree
Showing 3 changed files with 42 additions and 16 deletions.
Original file line number Diff line number Diff line change
@@ -1,9 +1,17 @@
Use pkg-config instead of ${PYTHON}-config to find python
From 855cc20bafa30597ae7a62f7672d42654b25cde0 Mon Sep 17 00:00:00 2001
From: Herrie <github.com@herrie.org>
Date: Mon, 24 Jul 2017 21:30:16 +0200
Subject: [PATCH] Use pkg-config instead of ${PYTHON}-config to find python

diff -uNr pidgin-2.10.12.orig/configure.ac pidgin-2.10.12/configure.ac
--- pidgin-2.10.12.orig/configure.ac 2016-01-01 00:19:40.000000000 +0100
+++ pidgin-2.10.12/configure.ac 2016-05-05 16:55:13.258945925 +0200
@@ -1585,20 +1585,15 @@
---
configure.ac | 21 ++++++++-------------
1 file changed, 8 insertions(+), 13 deletions(-)

diff --git a/configure.ac b/configure.ac
index d20a18e..c741829 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1567,20 +1567,15 @@ AM_CONDITIONAL(ENABLE_DBUS, test "x$enable_dbus" = "xyes")
dnl Check for Python headers (currently useful only for libgnt)
dnl (Thanks to XChat)
if test "x$enable_consoleui" = "xyes" -a ! -z "$PYTHON" -a x"$PYTHON" != x"no" ; then
Expand Down
18 changes: 13 additions & 5 deletions meta-oe/recipes-support/pidgin/pidgin/purple-OE-branding-25.patch
Original file line number Diff line number Diff line change
@@ -1,8 +1,16 @@
Index: pidgin-2.5.0/libpurple/protocols/irc/irc.h
===================================================================
--- pidgin-2.5.0.orig/libpurple/protocols/irc/irc.h 2008-08-19 01:53:38.000000000 +0000
+++ pidgin-2.5.0/libpurple/protocols/irc/irc.h 2008-08-27 11:15:58.000000000 +0000
@@ -36,9 +36,9 @@
From 43e9db656431ffb22b429d5fca4ce3b4af21bc9e Mon Sep 17 00:00:00 2001
From: Herrie <github.com@herrie.org>
Date: Mon, 24 Jul 2017 21:30:16 +0200

---
libpurple/protocols/irc/irc.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/libpurple/protocols/irc/irc.h b/libpurple/protocols/irc/irc.h
index fde35c4..66e52dd 100644
--- a/libpurple/protocols/irc/irc.h
+++ b/libpurple/protocols/irc/irc.h
@@ -40,9 +40,9 @@

#define IRC_DEFAULT_CHARSET "UTF-8"
#define IRC_DEFAULT_AUTODETECT FALSE
Expand Down
22 changes: 16 additions & 6 deletions meta-oe/recipes-support/pidgin/pidgin/sanitize-configure.ac.patch
Original file line number Diff line number Diff line change
@@ -1,15 +1,25 @@
--- /tmp/configure.ac 2007-05-08 17:29:02.000000000 +0200
+++ pidgin-2.0.0/configure.ac 2007-05-08 17:30:30.325251000 +0200
@@ -472,7 +472,7 @@
From c3058f9eadaf5ff28ba776cfed54b609a93a1249 Mon Sep 17 00:00:00 2001
From: Herrie <github.com@herrie.org>
Date: Mon, 24 Jul 2017 21:30:16 +0200

---
configure.ac | 10 +---------
1 file changed, 1 insertion(+), 9 deletions(-)

diff --git a/configure.ac b/configure.ac
index b8acd2a..d20a18e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -642,7 +642,7 @@ if test "x$enable_consoleui" = "xyes"; then
if test "x$enable_consoleui" = "xyes"; then
dnl # Some distros put the headers in ncursesw/, some don't
found_ncurses_h=no
- for location in $ac_ncurses_includes $NCURSES_HEADERS /usr/include/ncursesw /usr/include
+ for location in $ac_ncurses_includes $NCURSES_HEADERS
do
f="$location/ncurses.h"
AC_CHECK_HEADER($f,[
@@ -1860,10 +1860,6 @@
orig_CFLAGS="$CFLAGS"
@@ -2397,10 +2397,6 @@ if test "$kerberos" != "no" ; then
KRB4_CFLAGS="$KRB4_CFLAGS -I${kerberos}/include/kerberosIV"
fi
KRB4_LDFLAGS="-L${kerberos}/lib"
Expand All @@ -20,7 +30,7 @@
fi
AC_DEFINE(ZEPHYR_USES_KERBEROS, 1, [Define if kerberos should be used in Zephyr.])

@@ -1896,10 +1892,6 @@
@@ -2433,10 +2429,6 @@ if test "$zephyr" != "no" ; then
ZEPHYR_LDFLAGS="-L${zephyr}/lib"
elif test -d /usr/athena/include/zephyr ; then
ZEPHYR_CFLAGS="-I/usr/athena/include"
Expand Down

0 comments on commit da961d9

Please sign in to comment.